Sign in to follow this  
Lukkas2201

Erro com arma

Recommended Posts

boa tarde, seguinte, estou com um problema e não consigo saber oque é, meu servidor de dayz, quando equipo a shotgun, ou sniper (não é toda vez que acontece), mesmo estando com arma e munição, ela não atira, aparece a arma, a munição, ai quando clica pra atirar não acontece nada, ai tem que relogar do servidor, alguem sabe me dizer oque pode ser?

Share this post


Link to post

Já verificou o debugscript pra ver se não tem nem um erro ?

Share this post


Link to post
4 hours ago, OverKILL said:

Já verificou o debugscript pra ver se não tem nem um erro ?

sim já, eu pensei que fosse na função OnPlayerWeaponFire, porém lá ta tudo certo.

Share this post


Link to post

Tente depurar o código usando outputs para ver até onde o código esta sendo executado.

Só mais uma coisa, essa shotgun é arma duplicada? se for, talvez pode estar aí o erro.

Share this post


Link to post
15 hours ago, OverKILL said:

Tente depurar o código usando outputs para ver até onde o código esta sendo executado.

Só mais uma coisa, essa shotgun é arma duplicada? se for, talvez pode estar aí o erro.

sim, é arma duplicada, porém tem varias armas duplicadas, como assault rifles, snipers, e so buga com shotguns

Share this post


Link to post
3 hours ago, Lukkas2201 said:

sim, é arma duplicada, porém tem varias armas duplicadas, como assault rifles, snipers, e so buga com shotguns

Talvez você fez algo errado quando você duplicou teria que ver passo a passo essa duplicação de arma na maioria das vezes da b.o até por que você passa dos limites do GTA

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.