Sign in to follow this  
Pirulax

Error when trying to run MTA[netc_d.dll]

Recommended Posts

So, after i built the project using the Build -> Build Solution i tried to run MTA, but a msgbox appeared saying that it cannot find netc_d.dll.
Could someone help me?

 

Thanks in advance.

Edited by Pirulax

Share this post


Link to post

Solved, just forgot to run win-install-data.bat.
Got a new problem, but solved it[The debug build just stopped because VS was unable to load symbols for it. To fix this you should go to Tools -> Options -> Debugger -> Symbols and select  the chbox "Microsoft Symbol Server, and make sure to select a cache directory too"]

Edited by Pirulax

Share this post


Link to post

Now it just closes. 
 

'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Users\patri\Desktop\repos\mtasa-blue\Bin\Multi Theft Auto_d.exe'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ntdll.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\kernel32.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\KernelBase.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\user32.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\win32u.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\gdi32.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\gdi32full.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msvcp_win.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ucrtbase.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\advapi32.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msvcrt.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\sechost.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\rpcrt4.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\sspicli.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\cryptbase.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\bcryptprimitives.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\shell32.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\cfgmgr32.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\SHCore.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\combase.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\windows.storage.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\shlwapi.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\kernel.appcore.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\profapi.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\powrprof.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\fltLib.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\winmm.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\winmmbase.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\imm32.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Users\patri\Desktop\repos\mtasa-blue\Bin\mta\loader_d.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ole32.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\oleaut32.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\wintrust.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msasn1.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\crypt32.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\d3d9.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\version.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\dwmapi.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Users\patri\Desktop\repos\mtasa-blue\Bin\mta\netc_d.dll'. Cannot find or open the PDB file.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ws2_32.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\normaliz.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Users\patri\Desktop\repos\mtasa-blue\Bin\mta\pthread.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Unloaded 'C:\Users\patri\Desktop\repos\mtasa-blue\Bin\mta\pthread.dll'
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\wininet.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Users\patri\Desktop\repos\mtasa-blue\Bin\mta\pthread.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\clbcatq.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\wbem\wbemprox.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\wbemcomn.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\bcrypt.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\wbem\wbemsvc.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\wbem\fastprox.dll'. Symbols loaded.
15:53:53.272 - 15:53:53 - [DEBUG] BeginEventLog
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\XInput9_1_0.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\XInput9_1_0.dll'
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\XInput9_1_0.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\XInput9_1_0.dll'
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\xinput1_3.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\xinput1_3.dll'
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\xinput1_3.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\setupapi.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\setupapi.dll'
'Multi Theft Auto_d.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\xinput1_3.dll'
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Users\patri\Desktop\repos\mtasa-blue\Bin\mta\core_d.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Unloaded 'C:\Users\patri\Desktop\repos\mtasa-blue\Bin\mta\core_d.dll'
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Users\patri\Desktop\repos\mtasa-blue\Bin\mta\core_d.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\psapi.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Users\patri\Desktop\repos\mtasa-blue\Bin\mta\D3DX9_42.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Unloaded 'C:\Users\patri\Desktop\repos\mtasa-blue\Bin\mta\D3DX9_42.dll'
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\userenv.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\dbghelp.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\xinput1_3.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\xinput1_3.dll'
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Users\patri\Desktop\repos\mtasa-blue\Bin\mta\pthread_d.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Unloaded 'C:\Users\patri\Desktop\repos\mtasa-blue\Bin\mta\pthread_d.dll'
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Users\patri\Desktop\repos\mtasa-blue\Bin\mta\D3DX9_42.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\xinput1_3.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Users\patri\Desktop\repos\mtasa-blue\Bin\mta\pthread_d.dll'. Symbols loaded.
'Multi Theft Auto_d.exe' (Win32): Loaded 'C:\Windows\SysWOW64\setupapi.dll'. Symbols loaded.
15:53:53.463 - 15:53:53 - [DEBUG] DLL_PROCESS_ATTACH 00000000
15:53:53.464 - 15:53:53 - [DEBUG] CLocalization::CLocalization Localization set to 'en_US'
The thread 0x548 has exited with code 1 (0x1).
The thread 0x4cac has exited with code 1 (0x1).
The thread 0x1a00 has exited with code 1 (0x1).
The thread 0x4f68 has exited with code 1 (0x1).
The thread 0x12fc has exited with code 1 (0x1).
The thread 0x30d8 has exited with code 1 (0x1).
15:53:53.480 - 15:53:53 - [DEBUG] DLL_PROCESS_DETACH 00000001
The program '[14552] Multi Theft Auto_d.exe' has exited with code 1 (0x1).
 

Share this post


Link to post

Hi, I've solved everything.
I forgot what exactly caused the issues.
 

Thanks.

  • Like 1

Share this post


Link to post
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.