netc.dll version

Recommended Posts

Hello. I compiled the assembly of MTA SA, I did it according to the instructions Everything turned out, put the date files from the last "nightly" build, but when you try to run it says that netc.dll does not have the version you need. I tried to take it from other "nightly" builds, neither one is suitable. Actually the question. Where can I find a suitable one?

Thus the server (net.dll) is launched normally.

Edited by BeSS0n

Share this post

Link to post
  1. Execute the script win-create-projects.bat
  2. Open the solution file MTASA.sln in the Build directory
  3. Compile in Visual Studio with Debug configuration (may take some minutes)
  4. Execute the script win-install-data.bat

You don't have to copy anything from your Nightly installation. Running win-install-data.bat should download the most recent net.dll and netc.dll for your development purposes.

Share this post

Link to post

I started the script win_install_data, Everything started, but when I try to go to the server, the MTA hangs (the process gta_sa.exe loads the processor 30-40% all the time). In the log of the server itself, the player's connection is there, but after a minute it falls off by the timeout, but the MTA continues to hang.

Judging by debugging in VS it hangs on the line of the CStuckProcessDetector stuckProcessDetector (piLoadee.hProcess, 5000); A portion of the timeout code.

What could be the problem ?

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.