CodX

Errors

Recommended Posts

CodX    3

Hello ! I have a MTA:SA RolePlay Server and i don't know how can i solve this errors:

 

==================================================================
= Multi Theft Auto: San Andreas v1.5.2
==================================================================
= Server name      : || Romania RolePlay - PlayHard || [Mentenanta]
= Server IP address: 46.102.116.24
= Server port      : 22003

= Log file         : ..service5057/mods/deathmatch/logs/server.log
= Maximum players  : 30
= HTTP port        : 22003
= Voice Chat       : Disabled
= Bandwidth saving : Maximum with lightweight sync rate of 1500ms
==================================================================
[2017-06-17 16:55:15] ERROR: Couldn't find file skins/csher.txd for resource changeme
[2017-06-17 16:55:15] Loading of resource 'changeme' failed
[2017-06-17 16:55:15] ERROR: Couldn't find script s_marker.lua for resource job-system-trucker
[2017-06-17 16:55:15] Loading of resource 'job-system-trucker' failed
[2017-06-17 16:55:15] ERROR: Couldn't find map San Fierro/LSTR.map for resource map-system-old
[2017-06-17 16:55:15] Loading of resource 'map-system-old' failed
[2017-06-17 16:55:15] Resources: 160 loaded, 0 failed
[2017-06-17 16:55:15] MODULE: Loaded "MySQL 5.0 database module" (0.50) by "Alberto Alonso <rydencillo@gmail.com>"
[2017-06-17 16:55:15] Starting resources......
[2017-06-17 16:55:15] Server minclientversion is now 1.5.4-9.11354.0
[2017-06-17 16:55:15] INFO: MYSQL ERROR 1146: Table 'codx.maps_names' doesn't exist
[2017-06-17 16:55:15] INFO: 0 mape cu 0 obiecte si 0 stergeri din mapa incarcate in 1ms
[2017-06-17 16:55:15] Server password cleared
[2017-06-17 16:55:15] ERROR: faction-system/s_faction_admin.lua:513: attempt to index local 'maxrow' (a nil value)
[2017-06-17 16:55:15] Please wait...
[2017-06-17 16:55:15] INFO: MYSQL ERROR 1146: Table 'codx.blips' doesn't exist
[2017-06-17 16:55:15] INFO: 0 blipuri incarcate in 2ms
[2017-06-17 16:55:15] SCRIPT ERROR: interior-system/blips_s.lua:1: unexpected symbol near '\'
[2017-06-17 16:55:15] ERROR: Loading script failed: interior-system/blips_s.lua:1: unexpected symbol near '\'
[2017-06-17 16:55:15] ERROR: Couldn't find resource language-system. Check it exists.
[2017-06-17 16:55:15] INFO: MYSQL ERROR 1146: Table 'codx.clothes_pos' doesn't exist
[2017-06-17 16:55:16] ERROR: Couldn't find resource job-system-trucker. Check it exists.
[2017-06-17 16:55:16] INFO: Loaded 0 pilot licenses in 2ms.
[2017-06-17 16:55:16] INFO: MYSQL ERROR 1146: Table 'codx.tagging' doesn't exist
[2017-06-17 16:55:16] WARNING: vehicle-system/s_entry.lua [Server] is encoded in ANSI instead of UTF-8.  Please convert your file to UTF-8.
[2017-06-17 16:55:16] Some files in 'vehicle-system' use deprecated functions.
[2017-06-17 16:55:16] Use the 'upgrade' command to perform a basic upgrade of resources.
[2017-06-17 16:55:16] WARNING: Script 'vehicle-system/s_entry.lua' is not encoded in UTF-8.  Loading as ANSI...
[2017-06-17 16:55:16] SCRIPT ERROR: vehicle-system/s_entry.lua:1: unexpected symbol near '?'
[2017-06-17 16:55:16] ERROR: Loading script failed: vehicle-system/s_entry.lua:1: unexpected symbol near '?'
[2017-06-17 16:55:16] WARNING: File 'typing_icons/Brazil.png' in resource 'donators' is invalid.
[2017-06-17 16:55:16] WARNING: File 'typing_icons/Bulgaria.png' in resource 'donators' is invalid.
[2017-06-17 16:55:16] WARNING: carshop-system/s_crusher.lua:3: Bad argument @ 'createColCuboid' [Expected vector3 at argument 1, got none]
[2017-06-17 16:55:16] WARNING: carshop-system/s_crusher.lua:17: Bad argument @ 'addEventHandler' [Expected element at argument 2, got boolean]
[2017-06-17 16:55:16] WARNING: carshop-system/s_crusher.lua:69: Bad argument @ 'addEventHandler' [Expected element at argument 2, got boolean]
[2017-06-17 16:55:17] ERROR: Couldn't find resource resource-keeper. Check it exists.
[2017-06-17 16:55:17] Server started and is ready to accept connections!
[2017-06-17 16:55:17] To stop the server, type 'shutdown' or press Ctrl-C
[2017-06-17 16:55:17] Type 'help' for a list of commands.
[2017-06-17 16:55:18] Querying MTA master server... success! (Auto detected IP:46.102.116.24)
[2017-06-17 16:55:18] WARNING: global/s_account_globals.lua:43: getUserNameFromID(): Unable
[2017-06-17 16:55:18] WARNING: global/s_account_globals.lua:43: getUserNameFromID(): Unable  [DUP x6]
[2017-06-17 16:55:18] ERROR: vehicle-system/s_vehicle_system.lua:283: cannot resume dead coroutine [string "?"]
[2017-06-17 16:55:19] ERROR: vehicle-system/s_vehicle_system.lua:283: cannot resume dead coroutine [string "?"]  [DUP x2]
[2017-06-17 16:55:19] ERROR: ped-system/s_peds.lua:39: cannot resume dead coroutine [string "?"]
[2017-06-17 16:55:19] ERROR: ped-system/s_peds.lua:39: cannot resume dead coroutine [string "?"]  [DUP x6]
[2017-06-17 16:55:19] ERROR: vehicle-system/s_vehicle_system.lua:283: cannot resume dead coroutine [string "?"]
[2017-06-17 16:55:20] ERROR: vehicle-system/s_vehicle_system.lua:283: cannot resume dead coroutine [string "?"]  [DUP x2]
[2017-06-17 16:55:20] ERROR: ped-system/s_peds.lua:39: cannot resume dead coroutine [string "?"]
[2017-06-17 16:55:20] ERROR: ped-system/s_peds.lua:39: cannot resume dead coroutine [string "?"]  [DUP x6]
[2017-06-17 16:55:20] ERROR: vehicle-system/s_vehicle_system.lua:283: cannot resume dead coroutine [string "?"]
[2017-06-17 16:55:21] ERROR: vehicle-system/s_vehicle_system.lua:283: cannot resume dead coroutine [string "?"]  [DUP x2]
[2017-06-17 16:55:21] ERROR: ped-system/s_peds.lua:39: cannot resume dead coroutine [string "?"]
[2017-06-17 16:55:27] ERROR: ped-system/s_peds.lua:39: cannot resume dead coroutine [string "?"]  [DUP x6]
 

  • Like 1

Share this post


Link to post
kieran    18

@CodX looks to me as if you just chucked random stuff from resources in the wrong folders and hoped for the best.....  First of all sort all the missing files, for example...

[2017-06-17 16:55:15] ERROR: Couldn't find file skins/csher.txd for resource changeme
[2017-06-17 16:55:15] Loading of resource 'changeme' failed
[2017-06-17 16:55:15] ERROR: Couldn't find script s_marker.lua for resource job-system-trucker
[2017-06-17 16:55:15] Loading of resource 'job-system-trucker' failed
[2017-06-17 16:55:15] ERROR: Couldn't find map San Fierro/LSTR.map for resource map-system-old
[2017-06-17 16:55:15] Loading of resource 'map-system-old' failed

"Couldn't find" probably means that you don't actually have the files...   Go and make sure they are there, if you put them in a folder in your game mode (as I often do which is the WRONG WAY) you should make sure you have "Folder\Resource" in your meta.xml where Folder is your folder and Resource is the resource name, after that post again, that or send the parts of the script with errors and then players can see.....

[2017-06-17 16:55:21] ERROR: ped-system/s_peds.lua:39: cannot resume dead coroutine [string "?"] <<<Here the problem originates from line 39 in your ped-system/s_peds.lua file, I suggest searching the command/event/function on the wiki.

 

Useful tip, make a resource folder and call the folder(s) instead of the scripts on a game mode, this prevents problems such as black screens and other weird things like that when using the "upgrade" command in console. (Can still do weird stuff, but less likely to)

 

Also learn how to ask for help!  I do it a lot, but rules and guidelines for posting topics are here: https://forum.mtasa.com/topic/12275-forum-rules/

 

And rules for posting on this subforum are here: https://forum.mtasa.com/topic/94790-guidelines-and-formatting-for-this-section-read-before-posting/

Basically you forgot an accurate title missing [Question] or [Bug] tags.

Edited by kieran

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.