Turbe$Z

Why not start maps the race gamemode?

Recommended Posts

i added DD maps, but doesn't working.. when i connect the server, show votemanager, i vote for example 7, and the map does not start.. -_- Why? -.-

Share this post


Link to post

Make sure that maps are on normal folders or zip files. Folder with name "ddmap1" is ok while "[ddmap1]" isn't. Also say if there are any errors in /debugscript 3.

Share this post


Link to post
3 minutes ago, koragg said:

Make sure that maps are on normal folders or zip files. Folder with name "ddmap1" is ok while "[ddmap1]" isn't. Also say if there are any errors in /debugscript 3.

normal folder, and the name is ok

this is debugscript 3:

 

Share this post


Link to post

A stupid question but are you sure that you've started race gamemode :')?

/start race

And stop all other gamemodes before starting it. 

Share this post


Link to post
1 minute ago, koragg said:

A stupid question but are you sure that you've started race gamemode :')?

/start race

And stop all other gamemodes before starting it. 

Yeah, i started race gamemode..

Share this post


Link to post
2 minutes ago, Turbo777 said:

Yeah, i started race gamemode..

Attach a map that doesn't start for you and I'll try it on my server in around 30 mins. 

Edited by koragg
Maybe it's a map problem.

Share this post


Link to post

I gotta say that song is awesome :)

I get the following message exactly after I start the map from the admin panel:

ERROR: [gamemodes]\[race]\race\race_server.lua:74: attempt to concatenate field 'modename' (a nil value)

I tried other DD maps but still the same error happened. It has trouble getting the 'g_MapInfo.modename' as that's where the error happens (outputDebugString('Loaded race mode ' .. g_MapInfo.modename .. ' ' .. getResourceName(mapres))). I honestly thought that DD maps should work in the default race gamemode but seems like you have to modify something to get it fixed. I'm only a race guy (no DD, DM, etc...) so that's all from me, hope somebody can help you out.

 

PS: I actually had a few DD maps before but they were specifically designed for the server whose gamemode I'm using (it's opensource).

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.