ThatOneIowan

Error CD16

Recommended Posts

Hi all,

I am having issues connecting to any servers (map editor included) for MTA on my desktop. I always get "Error CD16". I have no issues connecting on either of my laptops nor to the internet on my desktop, so the connection itself is not an issue. I have tried both allowing MTA and the GTA SA executable in Windows Firewall as well as just turning Windows Firewall off completely. I know that it used to work on my desktop several months ago and now just... doesn't. I'm not sure what other information you need to look into this so please let me know. 

Thanks!

Share this post


Link to post

I apologize for the late response, i've troubleshooted CD16 before and in most cases this solution fixed it:

- Download this file: https://mirror.multitheftauto.com/mtasa/utils/servicing.bat

Rightclick it and select ''Run as Administrator'' and wait for it to complete before restarting your PC (will close on its own, please be patient)

This file, for example, revises your Windows networking stack, in most of the cases the problem is with that. Another possibility is your router filtering by internal firewall, so if this doesn't work please get back to me and I will give you instructions on how to check on that. You can also try running MTA and connecting to any server on your laptop which you said to have (or any second PC), the problem with CD16 error has a division between caused by router/ISP and by system issues, this way you can identify if the problem is with your router or PC. I assume PC, so try running the file I provided before anything else.

(Btw, you're also used a nonstandard, unrecognized gta_sa.exe, some custom launchers may be dodgy by not letting MTA traffic through - please restore gta_sa.exe with default one or re-install GTA.) @ThatOneIowan

Share this post


Link to post

No worries on the delayed response!

I ran the bat file via Teamviewer and tested connecting and it seemed to have worked. I'm not at my desktop and won't be until Tuesday morning 0730 CDT but I ran MTA through Teamviewer and it connected, so I'll assume it worked.

Also thanks for letting me know about the executable, if I remember correctly I had previously installed a radar mod that enlarged the radar in-game that required that or something. I'll look into that on my own. 

Share this post


Link to post
5 hours ago, ThatOneIowan said:

I ran the bat file via Teamviewer and tested connecting and it seemed to have worked. I'm not at my desktop and won't be until Tuesday morning 0730 CDT but I ran MTA through Teamviewer and it connected, so I'll assume it worked.

As expected, great that it's solved.

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.