Jump to content
  • 0

MTA:SA decreases FPS casually


GeroX

Question

I have no hardware issues or this kind of issue in any other games. I only have it in MTA:SA. My FPS is dropping to usually around 15-25 and then raises up again. Then decreases again. Do you guys have a fix for my issue?

  • I tried to close useless applications from CTRL + Alt + Del
  • Using CPU booster.
  • I don't have any mods installed.

Please don't suggest me to reinstall MTA or GTA:SA. Already tried.

Have a nice weekend.

Link to comment

25 answers to this question

Recommended Posts

  • 0
On 22.05.2017 at 17:42, ccw said:

Try:

Settings->Video->Anti-aliasing->Off

 

It raises up to 30-35 now, not the full solution at all but thanks for the effort.

I was always getting 50-60 with full settings, may it be computer wise problem?

Link to comment
  • 0
On 31.05.2017 at 18:22, Saml1er said:

What about your GPU and CPU fans? Are they running when you're playing MTA? I had this issue with AC4 when the game would make me lagg as hell and I later found out that it was my GPU getting heated up.

You got point, but i have zero issue in map editor or in empty servers. I don't think it's about that mate.

On 31.05.2017 at 04:28, ccw said:

Join this server: mtasa://91.121.44.90:22003

I did it. Only section with problem was vehicles. When the benchmark spawned vehicles, FPS decreased to 70-80. I was also thinking about that could be the issue.

Results: https://www.upload.ee/files/7076819/bench.log.html , thanks for paying attention.

Link to comment
  • 0
  • MTA Team

1. Edit mta\config\coreconfig.xml and find fps_limit and set to 0:

        <fps_limit>0</fps_limit>

2. Start MTA and disable Anti-Aliasing: Settings->Video->Anti-Aliasing->Off

3. Restart MTA and select option A from the NVidia Optimus menu

4. Join mtasa://91.121.44.90:22003 and save results as resultsA.txt

5. Repeat 3 & 4 with each of the 7 other NVidia Optimus options (B-H)

6. Zip up results and upload to https://upload.mtasa.com/ and post link here

  • Like 2
Link to comment
  • 0
5 hours ago, ccw said:

1. Edit mta\config\coreconfig.xml and find fps_limit and set to 0:


        <fps_limit>0</fps_limit>

2. Start MTA and disable Anti-Aliasing: Settings->Video->Anti-Aliasing->Off

3. Restart MTA and select option A from the NVidia Optimus menu

4. Join mtasa://91.121.44.90:22003 and save results as resultsA.txt

5. Repeat 3 & 4 with each of the 7 other NVidia Optimus options (B-H)

6. Zip up results and upload to https://upload.mtasa.com/ and post link here

http://upload.mtasa.com/u/661269790/output.zip_

there.

Link to comment
  • 0
  • MTA Anti-Cheat Team

Go to both Nvidia control panel/Intel configuration center, and make sure any setting similar to ''Use this GPU by preference'' is set to use the ''powerful Nvidia GPU'' (as how it's called in the Nvidia control panel - if not set like that it may pick the Intel GPU to run applications and games with, explaining the FPS decrease.. you don't have a Nvidia dedicated GPU for nothing.)

Also you updated to the latest drivers from Nvidia/Intel sites, but in some cases that breaks Optimus compatibility as some notebook models require running OEM drivers. If the first solution in control panels doesn't work, just give it a shot; go to laptop manufacturer driver page and download & install OEM intel HD and Nvidia drivers.

I've seen that way too often, laptops never utilising the Nvidia/dedicated GPU anymore when you use generic drivers.

Link to comment
  • 0
4 hours ago, Dutchman101 said:

Go to both Nvidia control panel/Intel configuration center, and make sure any setting similar to ''Use this GPU by preference'' is set to use the ''powerful Nvidia GPU'' (as how it's called in the Nvidia control panel - if not set like that it may pick the Intel GPU to run applications and games with, explaining the FPS decrease.. you don't have a Nvidia dedicated GPU for nothing.)

Also you updated to the latest drivers from Nvidia/Intel sites, but in some cases that breaks Optimus compatibility as some notebook models require running OEM drivers. If the first solution in control panels doesn't work, just give it a shot; go to laptop manufacturer driver page and download & install OEM intel HD and Nvidia drivers.

I've seen that way too often, laptops never utilising the Nvidia/dedicated GPU anymore when you use generic drivers.

 

Actually, this looks like working. I am not having FPS drops anymore since a while.

Keep this topic often, i will inform you guys in 1 week if it works. I appreciate it dude. 

@ccw Thanks for your big effort too, it's important to me.

Edited by GeroX
Link to comment
  • 0
  • MTA Anti-Cheat Team
On 6-6-2017 at 00:26, GeroX said:

Actually, this looks like working. I am not having FPS drops anymore since a while.

No, it doesn't fix.

Odd that it looked like improvement for a short while using OEM drivers.. maybe something is reverting the driver's compatibility with optimus.

Is windows update auto-replacing the driver with a newer/non-OEM version? Do you have some sort of ''Driver update'' program that may monitor the change in background and re-install the non-OEM driver as fast as it can?

Please generate a new MTADiag log

Edited by Dutchman101
Link to comment
  • 0
On 08.06.2017 at 19:53, Dutchman101 said:

Odd that it looked like improvement for a short while using OEM drivers.. maybe something is reverting the driver's compatibility with optimus.

Is windows update auto-replacing the driver with a newer/non-OEM version? Do you have some sort of ''Driver update'' program that may monitor the change in background and re-install the non-OEM driver as fast as it can?

Please generate a new MTADiag log

I updated all drivers already and it increased FPS a little more. But still not the solution.

https://pastebin.mtasa.com/903784835 New diag.

Link to comment
  • 0
  • MTA Anti-Cheat Team
6 hours ago, GeroX said:

I updated all drivers already and it increased FPS a little more. But still not the solution.

https://pastebin.mtasa.com/903784835 New diag.

You're not following my instructions, as you're running non-OEM drivers. Either follow the steps and only say you did so when you actually did, or I won't continue helping you.

Link to comment
  • 0

Try this if you didn't find any solution yet. @GeroX

1. Open MTA

2. Right click on taskbar

3. Open Task manager

4. Right click on gta_sa.exe 

5. Then click Go to options > right click on gta_sa.exe again > Set Priority "High"

This will give your MTA:SA more priority and the fps will increase.

Link to comment
  • 0
On 13.06.2017 at 01:48, Dutchman101 said:

You're not following my instructions, as you're running non-OEM drivers. Either follow the steps and only say you did so when you actually did, or I won't continue helping you.

I am not experienced as you are at all. What exactly non-OEM drivers are? And yeah i have a driver updating program, i updated all drivers. It would be good if you detail what should i do in a language i can understand, thanks for your try of helping btw.

10 hours ago, Heibara said:

Try this if you didn't find any solution yet. @GeroX

1. Open MTA

2. Right click on taskbar

3. Open Task manager

4. Right click on gta_sa.exe 

5. Then click Go to options > right click on gta_sa.exe again > Set Priority "High"

This will give your MTA:SA more priority and the fps will increase.

Are you sure there is such option like "Options"? I couldn't find it.

Link to comment
  • 0
  • MTA Anti-Cheat Team
53 minutes ago, GeroX said:

What exactly non-OEM drivers are? And yeah i have a driver updating program, i updated all drivers. It would be good if you detail what should i do in a language i can understand

I explained you before that OEM drivers are the ones you can get from laptop manufactorer driver page. And obviously a driver update tool will interfere with that..

As you still don't understand, let me clarify and repeat:

On 6/5/2017 at 15:59, Dutchman101 said:

Also you updated to the latest drivers from Nvidia/Intel sites, but in some cases that breaks Optimus compatibility as some notebook models require running OEM drivers. If the first solution in control panels doesn't work, just give it a shot; go to laptop manufacturer driver page and download & install OEM intel HD and Nvidia drivers.

Simply go to the laptop brand manufacturer site and then their driver/support page, enter your laptop model and get the drivers supplied for your laptop specifically, even if they are way outdated. There are too many laptops architecturally bad that suffer from having the latest drivers (generic) available, as it can disable your whole Nvidia card by breaking Optimus. (so if true, MTA would run on that slow Intel HD graphics only)

And don't forget to uninstall that ''driver update tool'' before doing so, as it will interfere by overwriting what you just installed from OEM drivers.

 

Edited by Dutchman101
  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...