ALw7sH

fetchRemote huge delay

Recommended Posts

fetchRemote hang up after loads of requests and starts to queue all the requests but do not process any of them. and starts to process x amount of requests every once awhile.

Share this post


Link to post

Well I'm using fetchRemote in four scripts. all four of them are being used constantly. In a login panel, radio script, avatars system and a bot

So once the server reaches around 5 players (Now all three scripts are probably being used) the fetchRemote function starts to have a huge delay. the more it is being used the more this delay becomes bigger.

And it is not like in seconds. sometimes you have to wait a good minute or even more for you request to be proceed

Edited by ALw7sH
  • Like 1

Share this post


Link to post

Try:

1) Setting connectTimeout to 6 seconds
2) Setting connectionAttempts to 2
3) Using a unique queueName for each resource

Don't forget to log errors in the callback

 

Share this post


Link to post

I can not find the right syntax for connectTimeout, connectionAttempts and queueName

Edit:

Nevermind it seems like I have to update my server because there is no such argument queueName in fetchRemote

Edited by ALw7sH

Share this post


Link to post
20 hours ago, ccw said:

Try:

1) Setting connectTimeout to 6 seconds
2) Setting connectionAttempts to 2
3) Using a unique queueName for each resource

Don't forget to log errors in the callback

 

It seems like queueName did the trick. Thank you

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.