Ronaldo!

Problem with joining to FFS Gaming

7 posts in this topic

Hello there, I have a problem with joining to FFS Gaming server. It was working fine till now. When I join the server my MTA crashes, I already tried to reinstall MTA but still didn't work.

Here is the error I get: 

 

Quote

Version = 1.5.3-release-11204.7.007
Time = Mon Mar 20 21:55:34 2017
Module = C:\Program Files\Rockstar Games\GTA San Andreas\gta_sa.exe
Code = 0xC0000005
Offset = 0x000C9691

EAX=00000000  EBX=00B3A1BC  ECX=00B3A1BC  EDX=00871120  ESI=00B3A1BC
EDI=00000000  EBP=00B3A1BC  ESP=0023EEF8  EIP=004C9691  FLG=00210246
CS=001B   DS=0023  SS=0023  ES=0023   FS=003B  GS=0000
 

 

Share this post


Link to post

Posted (edited)

This crash (0x000C9691) and the underlying mechanism is known to me, and most likely related to local mods to certain (vehicle) models that fail to load properly. Possibly this specific server, FFS, is interfering with your (corrupted/bad) installed mods by trying to replace them, or (pre)load them on connect where other servers you don't neccesarily encounter the mod you got installed except when you directly spawn or face this object or vehicle. (Assuming so as you said; the crash happens when you join FFS server). The crash more specifically is known to occur when your gta3 vehicle mod (one of them) is applied to a wrong vehicle type, like a train model on a car ID, and then the server (or another event/maybe even facing or loading it) tries to replace this original car ID with a car-type model again. (You can use this info if you want to try fix your mod install, however for a quick fix attempt I'd suggest starting with a clean install or even keeping it unmodded). Possibility 2 is that you have no existing, or unloadable (corrupted) model in your gta3.img which is being loaded/rendered at the server you're crashing on. (where the server doesn't neccesarily try to load a server-modded version of it)

So the first solution to try would be re-installing GTA with a clean, non modded version.

However, also please:

Please download, extract and run MTADiag and follow the instructions.

Press 'n' when asked.

Post any Pastebin URL MTADiag gives you in this topic

Edited by Dutchman101
1 person likes this

Share this post


Link to post

Hello Dutchman101,

first of all, thanks for your reply, I appreciate that! I installed a non modded gta3.img file but I still can't join the server, it's still crashing. After that I downloaded MTADiag and there were some modded files in the GTA folder so I downloaded the original files and replaced them. I tried to join the server but it's still crashing. Here is the pastebin file which MTADiag sent me:

https://pastebin.mtasa.com/565205691

Share this post


Link to post

The latest crash is caused because gta3.img is missing bullet.dff

Share this post


Link to post

Can't be. It's working on 1.5.2 but not in 1.5.2. I also downloaded the original gta3.img

Share this post


Link to post

Posted (edited)

1 hour ago, Ronaldo! said:

Can't be. It's working on 1.5.2 but not in 1.5.2. I also downloaded the original gta3.img

There was a row of patches making MTA more sensitive to corrupted gta3.img, you can verify 1.5.3 is runnable without this crash by 1) disabling auto-update in MTA settings, and then installing: https://nightly.mtasa.com/mtasa-1.5.3-full_rc-11199-20170223.exe

Let us know. Using 1.5.2 until those issues are nailed is far from ideal. Also, the nature of this underlying issue guarantees your GTA isn't unmodded (as said, corruption causes it for you). It simply can't happen with a 100% clean installation.

Edited by Dutchman101

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.