Jump to content

[REL] Cinema Experience 2.0 [Updated 13th January 2017]


Tails

Recommended Posts

2 hours ago, Mandalore5150 said:

sorry so late haha, was out for a few days. after they succeeded in wiping my server to default they wanted me to upload my local server to my hosted one in a zip via filezilla, to test and compare the two. i closed the ticket and told them its too much to do for one resource. if you guys have an easier solution id love to hear it, otherwise ill have to stick to using either only the map, or just sticking to my local server. its really weird. both servers are confirmed 1.5.2

Yep, it is pretty weird! My local server is running 1.5.2 as well and I have opened it up for public but a lot of people can't join because they're using an older client version. And I'm not running the nightly version or anything, so I don't get that either. However, the resource is working fine for most people even for the ones that are running their servers on paid hosts.

I guess the only thing you can do is to just wait for 1.5.3 or just simply do what they asked you to do, these are the only things I can think of.

I think 1.5.3 will be released soon. See here: https://bugs.multitheftauto.com/roadmap_page.php

Link to post
  • Replies 79
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

G&T Mapping & Loki present: Cinema Experience Beta 2.0.2 Description We're happy to finally release the first beta version of our Cinema Experience! Check out its features down bel

Hotfix has been uploaded! New bugs may be introduced with this version, however, playing videos should work again for the most part. Consider this is a temporary fix until we find a new and bette

Hello.... Basically i first say sorry about my English language, i am not from UK or USA Also, Nice work about Cinema BUT i got some .... BIG ... amm well i better write.. i guess it is

4 hours ago, Tails said:

Yep, it is pretty weird! My local server is running 1.5.2 as well and I have opened it up for public but a lot of people can't join because they're using an older client version. And I'm not running the nightly version or anything, so I don't get that either. However, the resource is working fine for most people even for the ones that are running their servers on paid hosts.

I guess the only thing you can do is to just wait for 1.5.3 or just simply do what they asked you to do, these are the only things I can think of.

I think 1.5.3 will be released soon. See here: https://bugs.multitheftauto.com/roadmap_page.php

sounds great. itll be the first resource i add on the update. thanks

  • Like 1
Link to post
  • 2 weeks later...
  • 5 weeks later...

@Tails @loki2143 maybe you can ship/integrate my anti-vehicle zone script within cinema experience (i'd allow that), so vehicles will not be able to get spawned inside and bloat the spaces of cinema?

https://community.mtasa.com/index.php?p=resources&s=details&id=12240

Working coordinates for the cinema are: {x = -1967.83, y = 400, z = -3.49, width = 64.00, depth = 144.42, height = 32.88},

(to be defined at the beginning of .lua)

Edited by Dutchman101
Link to post

Hi @Dutchman101,

We already have a colshape for the cinema itself, we could easily implement such a feature if we wanted to.

I'm currently working on a new version (rewritten from scratch) with custom gridlist and new features.

I'll see about implementing such a thing but again, I could write that within a couple minutes.

Thank you, though!

  • Like 1
Link to post
  • 2 weeks later...

Cinema Experience updated to version 1.1!

  • Players can no longer add the same video twice
  • Playlist gets cleared if a player leaves and the cinema is empty
  • Fixed messages showing up for players outside the cinema
  • Fixed some debug errors onResoureStart

Grab the latest version here!

Thanks @Dutchman101 for reporting these issues!

Edited by Tails
Link to post
  • 4 weeks later...

New patch released (ver. 1.1.2)  (Nov. 26, 2016)

This version fixes some bugs that unfortunately came with the last patch

  •  Fixed the screen playing videos through youtube.com intead of youtube.tv when being added through the youtube.com browser
  •  Fixed time changing when changing settings
  •  Some other minor issues fixed

Download the latest version here!

If you find any more bugs, please report them to us so we can fix them as soon as possible.

Edited by Tails
Link to post
  • 3 weeks later...
  • 3 weeks later...

Thanks all!

@ChrisM, No, but I took some time and implemented it for you. I'll release an update tomorrow which will include that + something else :)

I'll let you know when you can download it.

 

Edited by Tails
  • Like 1
Link to post
9 hours ago, Tails said:

I'll release an update tomorrow which will include that + something else :)

I hope that includes a bugfix; players can still hear the sound of anything playing in cinema when they're already outside. The sound persists as if they were still there, when in fact they're far from the cinema. It's annoying because only a reconnect fixes it.

Edited by Dutchman101
Link to post

@Dutchman101 I wasn't aware of this issue. Does it happen with older versions too? Because this was tested and there were no issues then. Also, does it happen when you're alone or when other players are in the cinema? Please let me know, thank you.

Link to post
48 minutes ago, Tails said:

@Dutchman101 I wasn't aware of this issue. Does it happen with older versions too? Because this was tested and there were no issues then. Also, does it happen when you're alone or when other players are in the cinema? Please let me know, thank you.

I already tried tracking it down but since it's random and has no reproduction I know of, no clue.. and yes it happened with earlier versions too.

Many players are complaining to me about it, if you've heard the same thing for others and are convinced of its existence, you could try adding some sort of force-fix to resolve it.

Maybe ive got the bug recorded when it happened, ill check and post a video if so. Doesn't happen that often though..

Edited by Dutchman101
Link to post
7 minutes ago, Dutchman101 said:

I already tried tracking it down but since it's random and has no reproduction I know of, no clue.. and yes it happened with earlier versions too.

The problem must be in closePanelOnLeave() or cleanUp() in c-main.lua. I don't see anything there, it's just doing its job, unless somehow it triggers an onMarkerHit and the screen gets recreated again. I'll have better look later.

Link to post

Sorry for the long delay, had to sort out my new computer and stuff.

I've added a new curved screen (custom 3d modeled) with new ambilight effects and added volume controls (+/-) on request and also fixed muting.

Here's a short clip of the new screen model:

https://clips.twitch.tv/sillybilly3/ComfortableArmadilloFailFish

And a screenshot here for you all:

NBanQBI.jpg

Hope you enjoy it! And please if you find any bugs, please report them so we can fix them as soon as possible.

Download now: Cinema Experience 2.0

@ChrisM @Dutchman101 and @EveryoneElse

Link to post

System:

The ambilights should be sync with audio, not with video.

You should add an Exit button, when someone wants to add a commandHandler to open the panel without a bind key. Example: /yt (without the exit button, the player will need to use F8 to use the /yt command because the chat is disabled while the panel is visible.)

Remove the F2 bind key, add a commandHandler to open/close the panel. Like /yt.

It would be great if remove the option to set night time (and never change the server time) and add the option to enable or disable vehicles inside the cinema. (Like the weapons)

There's a bug when the player search for a video using the search bar: When I pressed a binded key (like B) it triggered the resource that it was attached to, but it should not happen, it should be like searching for a resource name on Admin Panel.

Add an option to enable/disable HUD while the panel is open. It always bug the non-original HUDs.

Remove all "My Options" buttons. None of then works.

Remove "M" bindkey, keep only /mute command.

Make /proper always enabled by default.

Keep all the messages on a XML file, so anyone can translate it without edit the source code. (like the Admin Panel)

On a far away future: Staffs can schedule videos to run. Staffs can schedule the cinema to open only from one period of the day to another.

 

Map:

Remove the parking machines. When someone destroys them, it leaves money on the ground that can not be collected.

Remove the trees on the sidewalk, there's always someone hitting on them.

Add a Parking place and put some cars as examples to the players.

 

Keep the perfect job. This is the best cinema of the Universe of GTA.

Edited by lordhenry
  • Like 1
Link to post

Thanks @lordhenry, for all the suggestions!

Some of the stuff you mentioned isn't new to us and we've thought about a lot of it before already.

 

On 1/14/2017 at 17:45, lordhenry said:

The ambilights should be sync with audio, not with video.

We cannot sync it with the audio unfortunately because the audio is coming from the CEF browser and there's no functions or anything to get or read the audio.

On 1/14/2017 at 17:45, lordhenry said:

Remove the F2 bind key, add a commandHandler to open/close the panel. Like /yt.

I agree with a command to open/close the panel so people can bind it to any key they want and removing the F2 bind and adding a close button.

On 1/14/2017 at 17:45, lordhenry said:

It would be great if remove the option to set night time (and never change the server time) and add the option to enable or disable vehicles inside the cinema. (Like the weapons)

Night time doesn't change the server time, it's set locally, however I agree that it might be problematic on servers where the time matters like on rpg servers. We're looking into a shader currently that will darken the room instead of changing the time.

On 1/14/2017 at 17:45, lordhenry said:

There's a bug when the player search for a video using the search bar: When I pressed a binded key (like B) it triggered the resource that it was attached to, but it should not happen, it should be like searching for a resource name on Admin Panel.

The bug when typing text into the browser was already fixed at the start but I've noticed too that it doesn't work all the time. I will look into this.

On 1/14/2017 at 17:45, lordhenry said:

On a far away future: Staffs can schedule videos to run. Staffs can schedule the cinema to open only from one period of the day to another.

This is a sweet idea and I've thought about it before as well. Maybe in the far future but don't expect anything to happen.

On 1/14/2017 at 17:45, lordhenry said:

Remove the parking machines. When someone destroys them, it leaves money on the ground that can not be collected.

I've always wondered why sometimes some random money spawned outside the cinema... now I know.

 

As for the other suggestions, we will take them into consideration. I'm thinking about replacing the entire panel with a new one but I haven't quite decided on it yet. If I am then I will make sure there's no fixed binds and a command for every action and it will take care of unused settings and custom huds as well.

 

Please note that we're pretty busy and that we can't be working on this resource every day. It might take a long time before we can add in any of the suggested features or they might not make it in at all due to lack of time. Please bear with us!

 

Again, thank you for all the suggestions. We appreciate it a lot!

 

 

 

  • Like 1
Link to post
On 18/01/2017 at 00:13, Tails said:

Thanks @lordhenry, for all the suggestions!

Some of the stuff you mentioned isn't new to us and we've thought about a lot of it before already.

[...]

As for the other suggestions, we will take them into consideration. I'm thinking about replacing the entire panel with a new one but I haven't quite decided on it yet. If I am then I will make sure there's no fixed binds and a command for every action and it will take care of unused settings and custom huds as well.

Please note that we're pretty busy and that we can't be working on this resource every day. It might take a long time before we can add in any of the suggested features or they might not make it in at all due to lack of time. Please bear with us!

Again, thank you for all the suggestions. We appreciate it a lot!

Wow, thanks a lot by answering me. I didn't expect this...
Keep up your perfect job.

Do not worry, I'm not in a hurry.
Haste does not match with perfection.

  • Like 1
Link to post
  • 1 month later...

Hello.... Basically i first say sorry about my English language, i am not from UK or USA

Also, Nice work about Cinema

BUT

i got some .... BIG ... amm well i better write.. i guess it is problems about cinema

So i used ur script main code, and updated it to "Role-Play" Servers....

so basic idea is to improve roleplay... So editet, translated to my language, and updated a maping for "Goverment" players

and here starts problems, and i cant do anything, i dont even know why this is hapening...

1) When Resource is started everything go werry smoothy.... till players join ...

1.1) Those who was in game everything was still good- Movie, music, free road.... but those who went in server after script is started, they cant freely walk around in cinema, i thinked it is problem to client side, but then when i remapped it, i find out that u use scaling in many objects such as this one

<object id="object (bistro_blok) (3)" breakable="true" interior="0" collisions="false" alpha="255" model="3944" doublesided="false" scale="0.050000001" dimension="0" MSTalpha="255" posX="-1942.9" posY="422.60001" posZ="-2.6" rotX="0" rotY="0" rotZ="0"></object>

i dont know exacely if it is true but u know that scale ir visual only after reconnect to server.... so basically my players cant pass that "blok" they cant see it, because of 0.05 scale, but in main it is 1... same problem was to ladeers but there i just delited it and changed to other object, but this bistro_blok is for      {filename = "screen", id = "3944"}, --1952 - and u scaled it in .map file, but that scale dissapears natturally on recconet and then it is only visual...

2) Next problem - New screen curved... i guess u did your own texturing and DFF files... but there starts problems with interiors. :D bassically i cant anymore use "Costa Nori " mafias, amm restaurant... because when i enter interior, there is "Black HOLE" and weeeerrrry big monitor "Curved creen" So it replaces alll worlds textures

Suggestion : Well i cant right now swapped object ids because i dont have such a good pc to remap it :D but maybe next version u can use OBJects who aint used much in world = casino tokens or something as u can see i used 1952 ID to normal screen... but on 1 he is ... werry big.... and when i scale it to 0.05 (Object normal size is like hand of player) it is still collidable... cant get trough it... so i disabled those 3 litte screens for now while i figure it out why players cant pass or u will already do new version ;d

3 ) This problem is mystic.... Because for me it aint hapened even from 1 version... but players say they can hear the sound of YOUTUBE all around San andreas map... even they are out of colshape this is why??

3.1) Basic this problem is 70% of players in my server... they went in cinema, i put some music, video, etc.... they went out drive to commerce, and then write me that they still hear it and it kinda ruin their Roleplay...

3.2) Second problem about sound is - some of those who can hear sound all time they say they hear music there even aint played i asked what music -

I putted taio cruz - there she goes....

and they say after cruz ended they can hear Iglesias music..Outside cinema.... WTF

and lastly 4) Well this started on ur cinema V2... dont know why. but problem is - i cant add staff to cinema, i can add only myself and take away vip... but cant give staff/vip to others...( In FTP i can add manualy but not in server)

 

Thanks by the way, your cinema maked, my country roleplay level higer :D well a bit higer :D

  • Like 2
Link to post
  • 3 weeks later...

Thanks @Apocalypso!

Lots of bugs I hear =[

While we don't currently have time to work on this project we definitely appreciate you reporting these bugs!

I've had a new version laying around for quite a while, unsure if I'll finish it anytime soon but I will make sure these bugs will have been completely fixed when I finish it.

Thanks again!

Link to post
  • 4 weeks later...

@kleinmarquez Ah, yeah. That's the downside of replacing objects in MTA. If you want you could change the objects ids though but you have to go and find an id that you want to replace. You can use the map editor to check the ids on objects in the world.

Unpack the zip file and browse to the map folder and open TheCinema.map file with a text editor. Then replace the ids that you see in the first image.

Then browse to the screen folder and open up screen.lua and change the ids to the ones you put in the in the map file. (see second image)

EL9bAFy.png

Hope this helps. Sorry for any inconvenience.

Edited by Tails
Link to post

Often when you exit the cinema by door marker, you get a red box in top of screen saying You dont have permission to do this or smth, assuming it's trying to stop the video in incorrect way by that as when I re-enter cinema, the old video is still playing while the cinema was emptied.

Error seems only to happen when I exit while no one else is in cinema, so the bug was introduced with your recent update that empty cinema meant video auto-stops.

Also the bug of video that keeps playing in background when you're somewhere else in SA, long gone from cinema (you know because audio keeps playing only) is still present

  • Like 1
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...