Tails

[REL] Cinema Experience 2.0 [Updated 13th January 2017]

Recommended Posts

G&T Mapping & Loki present: Cinema Experience Beta 2.0.2

Description

We're happy to finally release the first beta version of our Cinema Experience! Check out its features down below...

Video

Screenshots

685b1f476801367.jpg 88cc90476801370.jpg NBanQBI.jpg d2f091476801373.jpg

896004476801380.jpg fa347e476801387.jpg 22e60c476801393.jpg ea8e2d476801400.jpg

Download Now Beta Ver. 2.0.2 [ October 7, 2019 ] Changelog

Authors:

Tails - Follow his group G&T Mapping on Facebook: http://fb.com/gtmapping

Check out their other resources as well: http://gtmapping.blogspot.com

Loki - Check out his original Cinema script here: https://community.multitheftauto.com/in ... s&id=11993

and his profile here: https://forum.mtasa.com/memberlist.php? ... le&u=79989

Please note that this resource is not 100% complete yet. Some features are disabled and there may still be some bugs.

To get started, scroll down the page and read "How to install".

The Features

- YouTube TV browser

- Fully automated playlist

- VIP manager - Add/remove VIPs who can manage the Cinema.

- Synced playback

- Vote to skip video

- Real-time Ambilight

- Open/close the cinema

- Kick players from the cinema

- And a lot more!

Commands

Global Cmds:

- F2 - Toggle the Cinema Panel (You have to be inside)

- M - Mute the playback [This is currently bugged]

- /play url - Adds a video to the playlist

- /playlist - Shows the playlist in the chat

- /geturl - Gives you the URL to the current video

- /proper - Adjusts the width of the screen making it more normal

VIP/Admin Cmds:

- /replay - Replays the current video

- /skipvideo - Force skip the current video

- /stopplay - Stops all playback and clears the playlist

- /remove nr - Removes a video from the playlist. E.x.: /remove 2

How to install

Step 1 (Unpack resource)

First update your server to the latest version! You need atleast version 1.5.2 anything lower is not supported! Type 'ver' without quotes into the server console (F8) to see what version you're running.

Unpack the zip file to your server resources folder: Multi Theft Auto\server\mods\deathmatch\resources\ in a new folder called CinemaExperience

Make sure you're an admin on your server if you don't know how to do that go and read the MTA wiki.

Step 2 (grant resource admin access)

Press P on your keyboard to open your admin panel and add the resource to the Admin ACL group

To do that go to the Resources tab and click on the 'Manage ACL' button in the top right corner then

double click 'Admin' under 'Groups' and press 'Add Object'. Type in resource.CinemaExperience and click on OK.

Step 3 (start resource)

Now start the resource. Open the in-game console (F8) and type in refresh and press enter, then type in start CinemaExperience and hit enter again.

Step 4 (add yourself as VIP)

Finally, you need to add yourself as VIP in the cinema panel. In order to do that, enter the cinema and press F2 to open up the cinema panel.

Now open the Settings tab, then open the Visitors tab (on the right side of the panel) and select your name. Click on 'Add/remove VIP'.

That's it! You have now access to all the settings so you can enjoy our Cinema Experience to the fullest :-)

How to change binds

You can change the bind for toggling the panel in the s-binds.Lua file.

Known issues / FAQ

Installation:

- I can't connect to API? Make sure the resource has admin privileges and server is up to date (1.5.2). Also try extracting the resource.

- I can't add videos? If you can't control the settings after you've added yourself as VIP, unpack the resource and delete the config files in the cfg folder.

Still need help? Leave us a message below or contact me through the G&T Mapping Facebook page (link at the bottom or top)

Panel:

- There's ads covering the screen! Sometimes there may be ads covering the video on the screen. You can click on the Skip Ads button to refresh the video, usually this will remove any ads on the video. Sorry for the inconvenience. There is no other solution at the moment.

In the future

- Add option to limit how many videos can be added per user

- Add option to set the max length of a video

- Add option to change the screens width and height and position

This list isn't finished yet

Bug reports / Questions / Feedback

If you encounter any bugs, glitches, have any suggestions, feature requests, or simply just like to ask a question, please don't hesitate to post them :-)

Thanks!

Edited by Tails
  • Like 8

Share this post


Link to post

Really nice resource !

Edited by Dutchman101
Revert to original post due to post ID bug
  • Like 1

Share this post


Link to post

Amazing script!

I really loved it, i already tested it.

Everything is working but seems there's something annoying

When i press on the button to move to a playlist, it doesn't do it, it pops-out a message saying "Connection Timed Out - Couldn't reach API"

I hope there's a solution for this.

Good work for making this script, can't wait to see the final version!

  • Like 1

Share this post


Link to post

Thanks all! @Fiction we're currently working out what's causing it. It seems like the Google APIs are getting blocked by your server/host. We will release the source tonight or tomorrow.

Share this post


Link to post

Thanks, LeSilver.

When i press on the button to move to a playlist, it doesn't do it, it pops-out a message saying "Connection Timed Out - Couldn't reach API"

Update your server and client to the latest version. That should fix the problem.

Cinema Experience updated!

Changelog - Beta ver.1.0.1:

-

 Now open-source!

- [API] "Fix" for connection issue - Update your server to the latest version!

- [GUI] Slightly raised video info so the progressbar doesn't overlap it on widescreen resolutions.

- [GUI] Help font size slightly reduced.

- [GUI] Made more room to display the help text, it should now fit properly on all resolutions.

Share this post


Link to post

Hi, I'm from Russia, I downloaded your site registered in admin but writes This resource does not have access to fetchRemote yet! I'm just not probyval did everything according to instructions

Share this post


Link to post

Thanks everyone for the nice comments!

@ rai2221,

Make sure you type in the resource name correctly, it's case-sensitive.

So not resource.cinemaexperience but resource.CinemaExperience

EDIT: My mistake. The resource by default is named cinemaexperience. So in that case you need to type in: resource.cinemaexperience. Sorry for the confusion.

Edited by Guest

Share this post


Link to post

@ Tails,

I am convinced more than once for 1 0 1 is not working for some reason and wiepke 1 0 0 runs, but the video does not have a version is not included, really want to make, can matter is that we have Ross's not working

Share this post


Link to post

Be sure to update your server to the latest 1.5.2! This resource won't work on MTA 1.5.0

Share this post


Link to post

Updated to version 1.0.3:

- Fixed a bug where players couldn't vote after two players had voted to skip with 3+ players in the room.

- Updated help in panel and in help manager (f9)

Download latest version now

Share this post


Link to post

swtiched it to minimum version 1.5 through the meta, but now it says timed out cant connect to API or something. i have it in the admin ACL, what can i do? (P.S. i switched i to 1.5 because the default version it was set at was incompatible with my server. not sure why but it only worked on my local server. my server is 1.5.2)

Share this post


Link to post
swtiched it to minimum version 1.5 through the meta, but now it says timed out cant connect to API or something. i have it in the admin ACL, what can i do? (P.S. i switched i to 1.5 because the default version it was set at was incompatible with my server. not sure why but it only worked on my local server. my server is 1.5.2)

What do you mean with it only worked on your local server? The reason you probably can't connect is because the Google API only supports https and your server doesn't support it or has it disabled for some reason. Mta only supports https since version 1.5.2. So make sure your server is indeed running 1.5.2. Type in ver in your server console to see which version you're running. If it is 1.5.2 then I can only suggest you try to reinstall the server and see if that helps anything.

If you happen to be running your server at Vortex Servers, we had one person reporting the same issue to us and was running a server at Vortex.

When he tested it on his own local server, the resource was working fine.

Let me know if it helps or if you're still having issues so we can look for a solution.

Share this post


Link to post

i tried switching the meta setting back to 1.5.2, and i got this message

[2016-08-22 17:21:16] Not starting resource cinemaexperience as this server version is too low (1.5.2 required)

[2016-08-22 17:21:16] ERROR: Unable to restart resource cinemaexperience

[2016-08-22 17:21:32] Not starting resource cinemaexperience as this server version is too low (1.5.2 required)

[2016-08-22 17:21:32] startResource: Failed to start resource 'cinemaexperience'

im positive im running 1.5.2, is there any way to solve this without restarting the server preferably?

UPDATE: i did a server restart (had to be done anyway) and still no luck

Share this post


Link to post

Are you running the server on your local computer? Also it really does seem you need to update it regardless if you think it's already 1.5.2 because it might be a different build.

Use the installer on the frontpage (http://www.mtasa.com), preferable change the folder location for a clean install, then move over your settings, databases, resources etc.

If you're running your server elsewhere, then contact your server host to see if you can get the latest update.

Share this post


Link to post
Are you running the server on your local computer? Also it really does seem you need to update it regardless if you think it's already 1.5.2 because it might be a different build.

Use the installer on the frontpage (http://www.mtasa.com), preferable change the folder location for a clean install, then move over your settings, databases, resources etc.

If you're running your server elsewhere, then contact your server host to see if you can get the latest update.

messaged my host, ill let you know what they say

Share this post


Link to post

so i updated my server but when i did, it wiped my ACL and .conf back to default so i need to fix all that before i can test the resource :/

Share this post


Link to post

sorry so late haha, was out for a few days. after they succeeded in wiping my server to default they wanted me to upload my local server to my hosted one in a zip via filezilla, to test and compare the two. i closed the ticket and told them its too much to do for one resource. if you guys have an easier solution id love to hear it, otherwise ill have to stick to using either only the map, or just sticking to my local server. its really weird. both servers are confirmed 1.5.2

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.