Sign in to follow this  
KissMTA

[HELP] How to open MTA PORTS !!!!

Recommended Posts

hey, i want open my MTA ports i was visit Youtube,Google but it not work im using win 8.1 help me all ports closed

Share this post


Link to post

It's most likely due to Windows Firewall or some form of anti-virus software, if you have port forwarded correctly. Look up how to add a firewall exception.

Share this post


Link to post
can you give me video "how to add a firewall exception ?"

There's no universal video for firewall management since they are all different, "openports" command will indicate that your ports are closed but not which ports. It could be your server machine or your router. First thing to try would be to attempt to connect to your server from another PC on your local network:

If that works then visit this page http://portforward.com/ for instructions regarding port forwarding in your router.

If it doesn't work then identify what firewall you are using, (usually the same program as your anti-virus program). Windows firewall usually ask if you want to add an exception first time you start your server. Once you know what firewall you are using you can start look for video tutorials.

Share this post


Link to post

If you're on Windows, go to cmd.exe, type ipconfig. Look for the Default Gateway. Type that in the URL bar of your web browser. Now go to your Firewall Settings. It might have something like Ports Forwarding or Applications. Click "Add new service". Type in the name of the service, and where it says Port Range, type of number of the port you want to open. It'll ask you whether it's UDP or TCP. Then click "Add to list". Do this for all the TCP/UDP ports. They are usually 22003 UDP, 22003 TCP, and 22126 UDP. Then go to the gridlist and where it says Add, add the application you just created. It might ask you where you want the application to be hosted on. It should be the name of the computer or some username. Or it might have automatically have it hosted on the computer you're on now. Then click add.

Now if you have a Firewall or Antivirus program, go to the Firewall settings, go to some place where it says ports. Click on that and go to Add Service. Type the name of the application, add a category, add a description, and then type the UDP and TCP ports. Then add the service.

Now go to your MTA Server.exe, type openports. The ports should now be opened.

Edited by Guest

Share this post


Link to post

In your case, I would ignore WAN, focus on LAN, type the port in LAN Host Start Port and in LAN Host End Port. So for example, if it was 22003, type 22003 in LAN Host Start Port and 22003 in LAN Host End Port. Type the name of the service. Make sure it's the right protocol. For LAN Host IP Address, I'm not sure about that. I don't know if it's required or not. If it is, I'd probably just put the Private IPv4 Address of your computer.

Share this post


Link to post

In your case, I would ignore WAN, focus on LAN, type the port in LAN Host Start Port and in LAN Host End Port. So for example, if it was 22003, type 22003 in LAN Host Start Port and 22003 in LAN Host End Port. Type the name of the service. Make sure it's the right protocol. For LAN Host IP Address, I'm not sure about that. I don't know if it's required or not. If it is, I'd probably just put the Private IPv4 Address of your computer.

Share this post


Link to post

please teach me i'll give u 5$ if u can help me open MTA ports im swear .

Share this post


Link to post

please teach me i'll give u 5$ if u can help me open MTA ports im swear .

Share this post


Link to post

You need to open the right ports, by default MTA uses: 22003 for the game itself, 22005 for the http server and 22126 for querying used by server browsers like game-state.com for instance.

So in the page in your picture you need to:

  • Mark the checkbox "Enable"
  • Select "Both" in the "protocol" field (or "UDP" if the option "Both" does not exist)
  • Due to limitations you'll have to open the whole range of ports from 22003 to 22126 in WAN start and end ports. You must do the same in LAN start and end port fields as well
  • In "LAN host ip adress" you should add your servers local IP adress, usually starting with 192.168. or 10.0.

Share this post


Link to post

You need to open the right ports, by default MTA uses: 22003 for the game itself, 22005 for the http server and 22126 for querying used by server browsers like game-state.com for instance.

So in the page in your picture you need to:

  • Mark the checkbox "Enable"
  • Select "Both" in the "protocol" field (or "UDP" if the option "Both" does not exist)
  • Due to limitations you'll have to open the whole range of ports from 22003 to 22126 in WAN start and end ports. You must do the same in LAN start and end port fields as well
  • In "LAN host ip adress" you should add your servers local IP adress, usually starting with 192.168. or 10.0.

Share this post


Link to post
You need to open the right ports, by default MTA uses: 22003 for the game itself, 22005 for the http server and 22126 for querying used by server browsers like game-state.com for instance.

So in the page in your picture you need to:

  • Mark the checkbox "Enable"
  • Select "Both" in the "protocol" field (or "UDP" if the option "Both" does not exist)
  • Due to limitations you'll have to open the whole range of ports from 22003 to 22126 in WAN start and end ports. You must do the same in LAN start and end port fields as well
  • In "LAN host ip adress" you should add your servers local IP adress, usually starting with 192.168. or 10.0.

not work too :shock::shock:

add me on facebook for talk pls . Khang Beatboxer

email: nguyenkhang.kiss@gmail.com

Share this post


Link to post
You need to open the right ports, by default MTA uses: 22003 for the game itself, 22005 for the http server and 22126 for querying used by server browsers like game-state.com for instance.

So in the page in your picture you need to:

  • Mark the checkbox "Enable"
  • Select "Both" in the "protocol" field (or "UDP" if the option "Both" does not exist)
  • Due to limitations you'll have to open the whole range of ports from 22003 to 22126 in WAN start and end ports. You must do the same in LAN start and end port fields as well
  • In "LAN host ip adress" you should add your servers local IP adress, usually starting with 192.168. or 10.0.

not work too :shock::shock:

add me on facebook for talk pls . Khang Beatboxer

email: nguyenkhang.kiss@gmail.com

Share this post


Link to post

Can you show us the completed page, showing what you typed?

Share this post


Link to post

By judging from the pictures it seems like your configuration is correct in your router so it must be your windows firewall or whatever anti virus software you use that has a local firewall. It also successfully connects to MTA master servers so it should work. What antivirus software are you using?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.