Jump to content

Resources download speed problem


Hero192

Recommended Posts

Hello,

I had started a Debian Linux server x64,

Status of it:

core 1, 1gb ram, 24 GB SSD Storage, 2 TB Transfer, 40 Gbps Network In, 125 Mbps Network Out

And now, I have a problem with the client resources download speed are too slow for the clients (new players) it takes a while to download some KBs.

Please tell me what I have to do to solve this problem, it's really annoying.

~Thanks in advance.

Link to post

I stuck on this point,

"Edit: /etc/nginx/sites-available/default"

Shall I open the file default of nginx folder with the SFTP and search for 'root' because there are about two lines with root and change them by this line?

root /PATH_TO_MTA_SERVER/mods/deathmatch/resource-cache/http-client-files;

And the same thing goes to listen?

Find listen and changes it to

listen 20080;

I wonder,

tell me what I have to do in this case please

Link to post

-default

##

# You should look at the following URL's in order to grasp a solid understanding

# of Nginx configuration files in order to fully unleash the power of Nginx.

# http://wiki.nginx.org/Pitfalls

# http://wiki.nginx.org/QuickStart

# http://wiki.nginx.org/Configuration

#

# Generally, you will want to move this file somewhere, and start with a clean

# file but keep this around for reference. Or just disable in sites-enabled.

#

# Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples.

##

# Default server configuration

#

server {

listen 20080;

access_log off;

listen [::]:80 default_server;

# SSL configuration

#

# listen 443 ssl default_server;

# listen [::]:443 ssl default_server;

#

# Self signed certs generated by the ssl-cert package

# Don't use them in a production server!

#

# include snippets/snakeoil.conf;

root /server/mods/deathmatch/resource-cache/http-client-files;

# Add index.php to the list if you are using PHP

index index.html index.htm index.nginx-debian.html;

server_name _;

location / {

# First attempt to serve request as file, then

# as directory, then fall back to displaying a 404.

try_files $uri $uri/ =404;

}

# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000

#

#location ~ \.php$ {

# include snippets/fastcgi-php.conf;

#

# # With php5-cgi alone:

# fastcgi_pass 127.0.0.1:9000;

# # With php5-fpm:

# fastcgi_pass unix:/var/run/php5-fpm.sock;

#}

# deny access to .htaccess files, if Apache's document root

# concurs with nginx's one

#

#location ~ /\.ht {

# deny all;

#}

}

# Virtual Host configuration for example.com

#

# You can move that to a different file under sites-available/ and symlink that

# to sites-enabled/ to enable it.

#

#server {

# listen 80;

# listen [::]:80;

#

# server_name example.com;

#

# root /var/www/example.com;

# index index.html;

#

# location / {

# try_files $uri $uri/ =404;

# }

#}

-nginx.conf

worker_rlimit_nofile 5000;

user www-data;

worker_processes 4;

pid /run/nginx.pid;

events {

worker_connections 5000;

# multi_accept on;

}

http {

##

# Basic Settings

##

sendfile on;

tcp_nopush on;

tcp_nodelay on;

keepalive_timeout 65;

types_hash_max_size 2048;

# server_tokens off;

# server_names_hash_bucket_size 64;

# server_name_in_redirect off;

include /etc/nginx/mime.types;

default_type application/octet-stream;

##

# SSL Settings

##

ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE

ssl_prefer_server_ciphers on;

##

# Logging Settings

##

access_log /var/log/nginx/access.log;

error_log /var/log/nginx/error.log;

##

# Gzip Settings

##

gzip on;

gzip_disable "msie6";

gzip_types *;

# gzip_vary on;

# gzip_proxied any;

# gzip_comp_level 6;

# gzip_buffers 16 8k;

# gzip_http_version 1.1;

##

# Virtual Host Configs

##

include /etc/nginx/conf.d/*.conf;

include /etc/nginx/sites-enabled/*;

}

#mail {

# # See sample authentication script at:

# # http://wiki.nginx.org/ImapAuthenticateW ... ePhpScript

#

# # auth_http localhost/auth.php;

# # pop3_capabilities "TOP" "USER";

# # imap_capabilities "IMAP4rev1" "UIDPLUS";

#

# server {

# listen localhost:110;

# protocol pop3;

# proxy on;

# }

#

# server {

# listen localhost:143;

# protocol imap;

# proxy on;

# }

#}

Link to post

2016/03/12 01:15:01 [emerg] 2430#0: bind() to 0.0.0.0:80 failed (98: Address already in use)

2016/03/12 01:15:01 [emerg] 2430#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 01:15:01 [emerg] 2430#0: bind() to 0.0.0.0:80 failed (98: Address already in use)

2016/03/12 01:15:01 [emerg] 2430#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 01:15:01 [emerg] 2430#0: bind() to 0.0.0.0:80 failed (98: Address already in use)

2016/03/12 01:15:01 [emerg] 2430#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 01:15:01 [emerg] 2430#0: bind() to 0.0.0.0:80 failed (98: Address already in use)

2016/03/12 01:15:01 [emerg] 2430#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 01:15:01 [emerg] 2430#0: bind() to 0.0.0.0:80 failed (98: Address already in use)

2016/03/12 01:15:01 [emerg] 2430#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 01:15:01 [emerg] 2430#0: still could not bind()

2016/03/12 12:06:10 [emerg] 3892#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:06:10 [emerg] 3892#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:06:10 [emerg] 3892#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:06:10 [emerg] 3892#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:06:10 [emerg] 3892#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:06:10 [emerg] 3892#0: still could not bind()

2016/03/12 12:15:21 [emerg] 3951#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:15:21 [emerg] 3951#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:15:21 [emerg] 3951#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:15:21 [emerg] 3951#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:15:21 [emerg] 3951#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:15:21 [emerg] 3951#0: still could not bind()

2016/03/12 12:17:31 [emerg] 3989#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:17:31 [emerg] 3989#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:17:31 [emerg] 3989#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:17:31 [emerg] 3989#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:17:31 [emerg] 3989#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:17:31 [emerg] 3989#0: still could not bind()

2016/03/12 12:25:54 [emerg] 4029#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:25:54 [emerg] 4029#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:25:54 [emerg] 4029#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:25:54 [emerg] 4029#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:25:54 [emerg] 4029#0: bind() to [::]:80 failed (98: Address already in use)

2016/03/12 12:25:54 [emerg] 4029#0: still could not bind()

Link to post

I typed this command, and returned with this message:

ls: cannot access /server/mods/deathmatch/resource-cache/http-client-files: No such file or directory 
  

Edited by Guest
Link to post

So the MTA server is currently installed into /root/server

nginx can not read files inside /root, so move the MTA server to another directory, like /srv

mv /root/server /srv 

Then edit /etc/nginx/sites-available/default

and change:

root /server/mods/deathmatch/resource-cache/http-client-files; 

to

root /srv/server/mods/deathmatch/resource-cache/http-client-files; 

and restart nginx

service nginx restart 

Link to post

Yeah sounds good, I had used the URL Compression toll to make test and returned with a green color saying that "Compressed"

results:

Uncompressed Page Size: 0.8 KB

Compressed Page Size: 0.4 KB

Savings: 49.9%

So that's done now? or I still have to do something else

Note: Because the download is till slow like before

And btw,thanks alot for helping me out to solve this, I appreciate that

Link to post

I tested your server and got 430 files in 6 seconds, which is about right for external http server and 50ms ping

(Max files per second is: httpmaxconnectionsperclient / ping * 1000 )

How long does it take for you to download the files?

Link to post

Currently I have few files on it, it takes 15secs If I had already the client filles it takes less than 7 secs but I am afraid when I will have more filles.

My ping on this server is betwewn 40 to 50.

Note: I just found a new problem when my ping goes high for examle 500/1000ping I lose the connection from the server

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...