Jump to content

[Solved(mostly)]x64 Arch server


rain_gloom

Recommended Posts

Problem 1:

The x64 version is giving this error:

]$ ./mta-server64  
libtinfo.so.5: cannot open shared object file: No such file or directory 
ERROR: Could not load ./x64/core.so 
* Check installed data files. 
Press enter to continue... 

But the x64 folder is right next to it with all the files. What's wrong then?

I tried ldd on the executable, but I'm not exactly how I should interpret the output.

linux-vdso.so.1 (0x00007ffc0ab7e000) 
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f2ebc974000) 
    libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f2ebc770000) 
    libz.so.1 => /usr/lib/libz.so.1 (0x00007f2ebc55a000) 
    librt.so.1 => /usr/lib/librt.so.1 (0x00007f2ebc352000) 
    libm.so.6 => /usr/lib/libm.so.6 (0x00007f2ebc054000) 
    libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f2ebbe3e000) 
    libc.so.6 => /usr/lib/libc.so.6 (0x00007f2ebba9a000) 
    /lib64/ld-linux-x86-64.so.2 (0x00007f2ebccf6000) 
    libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f2ebb87d000) 

Problem 2:

I thought maybe I could build it from source, but there is this error:

./logic/CObjectManager.cpp:51:1: error: narrowing conversion of ‘-1’ from ‘int’ to ‘unsigned int’ inside { } [-Wnarrowing] 
make[5]: *** [deathmatch_la-CObjectManager.lo] Error 1 
make[4]: *** [all] Error 2 
make[3]: *** [all-recursive] Error 1 
make[2]: *** [all-recursive] Error 1 
make[1]: *** [all-recursive] Error 1 
make: *** [all] Error 2 

I've downloaded the code from GitHub and checked out the 1.5.0 release. There was an initial problem with the ncursesw headers not being in the correct place, but that is an Arch bug(/feature) and I managed to fix it by some symlinking.

Note: I'm using the gcc-multilib package instead of the usual gcc, is that the problem? (the experimental Linux release of Unity 3D needs the multilib one)

Edited by Guest
Link to post

Arch x64 v225

Ah... that might be a problem, it's an rc version.

http://nightly.mtasa.com/multitheftauto ... 1DA.tar.gz

But does that explain the error?

The 32 bit was from linux.mtasa.com, that one runs fine.

(ok, it does give an error about missing configs, but I expected that and it was only downloaded to see if it starts at all)

edit:ok, the release version works fine, but I'm still curious about the GitHub build as it doesn't seem like one of the usual errors due to some missing header or shared library.

Link to post
  • MTA Team

Try adding -Wno-narrowing

e.g.

make \ 
    CFLAGS='-g -O2 -fPIC -DPIC -Wno-uninitialized -Wno-narrowing' \ 
  CXXFLAGS='-g -O2 -fPIC -DPIC -Wno-uninitialized -Wno-narrowing -std=c++0x' \ 
  CPPFLAGS='-g -O2 -fPIC -DPIC -Wno-uninitialized -Wno-narrowing' >_make.log 

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...