Jump to content

مشكلة في مود


Recommended Posts

عندي مشكلة في المود ،

المود هو يظهر رسالة لما يشتغل من ملف

xml

بس لما تظهر الرسالة مرة وحدة تختفي مرة ثانية

ابيها ما تختفي كيف اسويها

الكودات :

ClientSide

  
addEvent("node", true) 
addEventHandler("node", root, 
function(node) 
dxDrawText("Message : "..node.."", 17, 189, 763, 220, tocolor(255, 255, 255, 255), 1, "default-bold", "left", "top", false, false, true, false, false) 
end 
)  

ServerSide

  
addEventHandler ( "onResourceStart", root, 
function() 
local load = xmlLoadFile ("save.xml") 
if not load then 
return end 
local texte5 = xmlFindChild (load, "texte5", 0) 
if not texte5 then 
return end 
local node = xmlNodeGetValue ( texte5 ) 
triggerClientEvent ( root, "node", root, node ) 
xmlUnloadFile (load) 
end 
) 

Edited by Guest
Link to comment

كلنت

  
local node = "" 
  
addEvent("node", true) 
addEventHandler("node", root, 
function(Message) 
    node = Message 
end) 
  
  
  
function Render() 
    dxDrawText("Message : "..node.."", 17, 189, 763, 220, tocolor(255, 255, 255, 255), 1, "default-bold", "left", "top", false, false, true, false, false) 
end 
addEventHandler("onClientRender", root,Render) 
  
  
addEventHandler ( "onClientResourceStart", root, 
function() 
    triggerServerEvent ( "start", localPlayer ) 
end) 
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...