Jay91

Low FPS in MTA SA

Recommended Posts

Yes I tried running it in low settings and reinstalled drivers too but it did not work.

Share this post


Link to post

---------------------------------------

---------------------------------------

Benchmark results - 2015-05-25 16:40:24

---------------------------------------

Lua exec MHz: 2973

Part1(sea) FPS: 1

Part2(grove) FPS: 1

Part3(peds) FPS: 1

Part4(cars) FPS: 1

Player Name: John

Player Ping: 190

Player Version: 1.4.1-9.07246.0

TestMode: none

VideoCardName: Intel® HD Graphics 4000

VideoCardRAM: 4088

VideoCardPSVersion: 3

VideoMemoryFreeForMTA: 3210

VideoMemoryUsedByFonts: 0

VideoMemoryUsedByTextures: 0

VideoMemoryUsedByRenderTargets: 8

SettingWindowed: false

SettingFXQuality: 3

SettingDrawDistance: 100

SettingVolumetricShadows: true

SettingStreamingVideoMemoryForGTA: 256

AllowScreenUpload: true

DepthBufferFormat: intz

VideoCardMaxAnisotropy: 4

SettingAnisotropicFiltering: 4

SettingAntiAliasing: 3

SettingHeatHaze: false

SettingGrassEffect: true

Setting32BitColor: true

Resolution: 1366 x 768

---------------------------------------

Share this post


Link to post

MTA starts up using my Intel HD 4000 with which I got 20-35 FPS before.

GTA and SA:MP start up using my AMD Radeon HD 8730M with which I get 80-105 FPS.

Share this post


Link to post

Thanks. I can see there is a big problem.

When did you start using Windows 10 build 10122 ?

Share this post


Link to post

If the problem happened when you start using Windows 10 build 10122, then it could be that.

Look in Windows update for any patches.

Otherwise it's holding out until the next build and hope that fixes it, or going back to the previous one.

Share this post


Link to post

Can anyone tell any other possible problems and how I could fix them?

Share this post


Link to post

I think this is a Windows 10 issue, here's my log:

---------------------------------------

Benchmark results - 2015-06-04 13:53:05

---------------------------------------

Lua exec MHz: 3912

Part1(sea) FPS: 28

Part2(grove) FPS: 27

Part3(peds) FPS: 28

Part4(cars) FPS: 27

Player Name: SAES>Nikolai

Player Ping: 0

Player Version: 1.4.1-9.07246.4

TestMode: none

VideoCardName: AMD Radeon HD 7900 Series

VideoCardRAM: 4085

VideoCardPSVersion: 3

VideoMemoryFreeForMTA: 3215

VideoMemoryUsedByFonts: 0

VideoMemoryUsedByTextures: 0

VideoMemoryUsedByRenderTargets: 1

SettingWindowed: true

SettingFXQuality: 3

SettingDrawDistance: 100

SettingVolumetricShadows: true

SettingStreamingVideoMemoryForGTA: 256

AllowScreenUpload: true

DepthBufferFormat: intz

VideoCardMaxAnisotropy: 4

SettingAnisotropicFiltering: 4

SettingAntiAliasing: 3

SettingHeatHaze: false

SettingGrassEffect: true

Setting32BitColor: true

Resolution: 1600 x 900

---------------------------------------

Share this post


Link to post

Build 10074 was fine for me, but as soon as I upgraded to 10130 (after a fresh format + install) performance issues started to arise.

Edit: I also noticed that proxy_sa no longer exists for me now.

Edit 2: I think MTA might only be running on one GPU, the integrated one (Windows 10 laptop, dual-mode AMD and Intel graphics). I'm using the latest 15.5 AMD drivers. I heard DirectX12 was supporting running two GPUs simultaneously at once. Maybe that is the root of the cause?

Edit 3: I found a half fix. You just need to update your Intel Graphics drivers to ones that support Windows 10. Use this tool to do so. It got my FPS from 11 to 29.

Edited by Guest

Share this post


Link to post

Same here. My FPS decreased after I did a clean install of 10122. 10074 was fine. I did a clean install of 10130 but it had the same issue as 10122. And proxysa.exe is not there for me too.

Share this post


Link to post
Build 10074 was fine for me, but as soon as I upgraded to 10130 (after a fresh format + install) performance issues started to arise.

Edit: I also noticed that proxy_sa no longer exists for me now.

Edit 2: I think MTA might only be running on one GPU, the integrated one (Windows 10 laptop, dual-mode AMD and Intel graphics). I'm using the latest 15.5 AMD drivers. I heard DirectX12 was supporting running two GPUs simultaneously at once. Maybe that is the root of the cause?

Edit 3: I found a half fix. You just need to update your Intel Graphics drivers to ones that support Windows 10. Use this tool to do so. It got my FPS from 11 to 29.

Didn't work.

Share this post


Link to post

Same problem on 10130 Win10 build

  
--------------------------------------- 
--------------------------------------- 
Benchmark results - 2015-06-06 09:29:29 
--------------------------------------- 
Lua exec     MHz: 2623  
Part1(sea)   FPS: 1 
Part2(grove) FPS: 1 
Part3(peds)  FPS: 1 
Part4(cars)  FPS: 1 
  
Player Name: [url=TG://Sebihunter]TG://Sebihunter[/url] 
Player Ping: 0 
Player Version: 1.4.1-9.07274.0 
  
TestMode: none 
VideoCardName: NVIDIA GeForce GTX 560  
VideoCardRAM: 1024 
VideoCardPSVersion: 3 
VideoMemoryFreeForMTA: 767 
VideoMemoryUsedByFonts: 0 
VideoMemoryUsedByTextures: 0 
VideoMemoryUsedByRenderTargets: 0 
SettingWindowed: true 
SettingFXQuality: 3 
SettingDrawDistance: 100 
SettingVolumetricShadows: true 
SettingStreamingVideoMemoryForGTA: 256 
AllowScreenUpload: true 
DepthBufferFormat: intz 
VideoCardMaxAnisotropy: 4 
SettingAnisotropicFiltering: 4 
SettingAntiAliasing: 3 
SettingHeatHaze: true 
SettingGrassEffect: true 
Setting32BitColor: true 
Resolution: 1280 x 800 
--------------------------------------- 
  

Other games work completely fine. Only MTA is affected in both windowed and fullscreen.

Share this post


Link to post

Just found out that my FPS is normal when I am in jail in CIT.

Share this post


Link to post
Just found out that my FPS is normal when I am in jail in CIT.

FPS usually is pretty much higher than anywhere else if you're in an interior (as you're describing) because it has to render much less.

I've had it too on W10 but got the (for me working) solution as I describe to you below:

It's a pretty long list of steps but as it's a high chance of solving this problem you may find it worth the effort.

First open MTA, go to settings and see if Disable driver overrides option is checked, if it is uncheck it.

- Use the latest driver on your onboard graphics. For your laptop get and install this: http://downloadmirror.intel.com/24973/a08/win64_153336.exe (also newer)

- Don't use the ''engineering sample'' of your dedicated GPU that comes with Windows 10, but instead use the most recent driver for your laptop: (http://support.amd.com/en-us/kb-articles/Pages/latest-catalyst-windows-beta.aspx > select win8.1 64 version)

- Update intel chipset: http://downloadmirror.intel.com/20775/eng/SetupChipset.exe

Now delete your gta_sa.set.

The problem may be related to DX12 and codecs, so get this codecs (http://www.codecguide.com/download_k-lite_codec_pack_full.htm) and select only codecs (excluding player) for letting it install systemlevel codecs only that you need.

Then open commandprompt (cmd) as Administrator, and enter & let run the following:

Dism /Online /Cleanup-Image /RestoreHealth 

Make sure you're connected to the internet and you havent disabled Windows update and/or its service.

As soon that finishes reboot your PC, then again open cmd as administrator, then enter:

sfc/ scannow 

Then again reboot your PC once its done. Now go to Control panel, then Programs and components and look left up for ''Turn on or off Windows features'' and look for Legacy components then disable/remove DirectPlay checkbox, let it disable, then reboot your PC and go to the same window and Enable it again and let it re-add DirectPlay.

Now use an DirectX updater, not the web installer but the full redist package: http://www.microsoft.com/en-us/download/details.aspx?id=8109 and let it install from after you extracted it on the desired location using DXsetup.exe.

Then open up your Intel driver configuration page, reset all settings to default (if you got nothing like important custom configs there) and select your default GPU to be used as ''powerful ATI GPU'' or something like that. Now blank your 3D/application settings, and if its visible set global settings to always use the ATI GPU, if you can enable this per application add Multi Theft Auto and gta_sa.exe processes in that list and do the same for it, apart from letting it use application's default settings. Also go to your ATI/Nvidia dedicated config page and reset everything to default, then do basicly the same thing: select it to 'Use application settings'' or similar on global and also on Application specific settings for MTA/GTA processes.

Links in this guide were adapted to [TPO]Johns' laptop hardware, you can use the same guidelines apart from your own most recent drivers. I think the problem is a combination of DX deprecation/removal in that W10 build to make place for updated one, drivers adapted to this coming with it by default and the inability to restore to correct internals due to an system component store corruption bug that comes with this build making you unable to get any effect of re-enabling DirectPlay for DX after doing it following the step (this can be solved with the sfc /scannow and Dism on cmd instructions)

Share this post


Link to post
Just found out that my FPS is normal when I am in jail in CIT.

FPS usually is pretty much higher than anywhere else if you're in an interior (as you're describing) because it has to render much less.

I've had it too on W10 but got the (for me working) solution as I describe to you below:

It's a pretty long list of steps but as it's a high chance of solving this problem you may find it worth the effort.

First open MTA, go to settings and see if Disable driver overrides option is checked, if it is uncheck it.

- Use the latest driver on your onboard graphics. For your laptop get and install this: http://downloadmirror.intel.com/24973/a08/win64_153336.exe (also newer)

- Don't use the ''engineering sample'' of your dedicated GPU that comes with Windows 10, but instead use the most recent driver for your laptop: (http://support.amd.com/en-us/kb-articles/Pages/latest-catalyst-windows-beta.aspx > select win8.1 64 version)

- Update intel chipset: http://downloadmirror.intel.com/20775/eng/SetupChipset.exe

Now delete your gta_sa.set.

The problem may be related to DX12 and codecs, so get this codecs (http://www.codecguide.com/download_k-lite_codec_pack_full.htm) and select only codecs (excluding player) for letting it install systemlevel codecs only that you need.

Then open commandprompt (cmd) as Administrator, and enter & let run the following:

Dism /Online /Cleanup-Image /RestoreHealth 

Make sure you're connected to the internet and you havent disabled Windows update and/or its service.

As soon that finishes reboot your PC, then again open cmd as administrator, then enter:

sfc/ scannow 

Then again reboot your PC once its done. Now go to Control panel, then Programs and components and look left up for ''Turn on or off Windows features'' and look for Legacy components then disable/remove DirectPlay checkbox, let it disable, then reboot your PC and go to the same window and Enable it again and let it re-add DirectPlay.

Now use an DirectX updater, not the web installer but the full redist package: http://www.microsoft.com/en-us/download/details.aspx?id=8109 and let it install from after you extracted it on the desired location using DXsetup.exe.

Then open up your Intel driver configuration page, reset all settings to default (if you got nothing like important custom configs there) and select your default GPU to be used as ''powerful ATI GPU'' or something like that. Now blank your 3D/application settings, and if its visible set global settings to always use the ATI GPU, if you can enable this per application add Multi Theft Auto and gta_sa.exe processes in that list and do the same for it, apart from letting it use application's default settings. Also go to your ATI/Nvidia dedicated config page and reset everything to default, then do basicly the same thing: select it to 'Use application settings'' or similar on global and also on Application specific settings for MTA/GTA processes.

Links in this guide were adapted to [TPO]Johns' laptop hardware, you can use the same guidelines apart from your own most recent drivers. I think the problem is a combination of DX deprecation/removal in that W10 build to make place for updated one, drivers adapted to this coming with it by default and the inability to restore to correct internals due to an system component store corruption bug that comes with this build making you unable to get any effect of re-enabling DirectPlay for DX after doing it following the step (this can be solved with the sfc /scannow and Dism on cmd instructions)

Did not work.

EDIT: Ignore what I said before. I just saw the link you gave for the Intel display driver. I downloaded and installed it and rebooted but when I check device manager it shows the version I first saw after installing Windows 10. I think the driver does not get installed properly.

Share this post


Link to post

Never mind the previous post. I did all the steps again but my FPS is still low. Any other ideas?

Share this post


Link to post
Someone please help. :(:(:(

As it looks now i can only advise you downgrading your Windows 10 build to the one previously working fine with MTA, it's not unsupported without reason at the moment because it's still in development & unlike older editions they are making alot of changes in architecture/core so possibly that can deliver major problems like this here... before the final release MTA can't adapt to massive flaws some builds may include.

Share this post


Link to post

Damn... Guess I'll have to wait. Anyway, everyone thank you for trying to help me.

Share this post


Link to post

I can confirm. Running right now, and no issues whatsoever. FPS is running smooth, and audio is not glitchy (like it was with 9926).

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.