Jump to content

[Solucionado] Sonidos entre clientes


Recommended Posts

Buenasa a todos de nuevo (Alavado sea venado okno)

Ok pos, Traté de hacer un sistema de sound, nuevecito, de 0 vaya, y no logro hacer que el sonido se reproduzca en el servidor para las personas que estén alrededor del elemento, no funciona ni para client, ni para los demas :(

Client.luac

MvbR¦³ï§€xs°h´ñ{a›¯y˜C涌ÕXõ7„׫?> öêðÔR~¦i?­¾ÆTÝ­…º\åTû‰ï³'-|ŒcVv  

-----------------------

Client.lua

function bmanager () 
    if source == GUIEditor.button[1] then 
        if not creado then 
        triggerServerEvent("f5:create", root, localPlayer, guiGetText(GUIEditor.edit[1])) 
        creado = true 
        else 
        outputChatBox("#FF5000[TrosNos.F5] #FF0000Ya tienes un altavoz colocado", 0,0,0,true) 
        end 
    elseif source == GUIEditor.button[2] then 
        if creado then 
        triggerServerEvent("f5:destroy", root, localPlayer, guiGetText(GUIEditor.edit[1])) 
        creado = false 
        else 
        outputChatBox("#FF5000[TrosNos.F5] #FFFF00No tienes un altavoz colocado!", 0,0,0,true) 
        end 
    end 
end 
function creator (object, link) 
    if object ~= nil and link ~= nil then 
    local soundBeet = playSound3D(link,0,0,0,false) 
    setSoundMaxDistance(soundBeet, 100) 
    attachElements(object, soundBeet) 
    end 
end 
addEvent("f5client:create", true) 
addEventHandler("f5client:create", root, creator) 

Server.lua

addEvent("f5:create", true) 
addEvent("f5:destroy", true) 
objecT = {} 
function create (client, link) 
local x,y,z = getElementPosition(client) 
    if link ~= nil then 
    objecT[client] = createObject(2226,x,y+2,z) 
    triggerClientEvent(root, "f5client:create", root, objecT[client], link) 
    end 
end 
addEventHandler("f5:create", root, create) 
function destroy (client) 
    for k,v in ipairs(getAttachedElements(objecT[client])) do 
    destroyElement(v) 
    end 
destroyElement(objecT[client]) 
end 
addEventHandler("f5:destroy", root, destroy) 

Edited by Guest
Link to comment
local soundBeet = playSound3D(link,0,0,0,false) 

estas poniendo las coordenadas en 0 por lo tanto el sonido solo se reproducira en medio de todo el mapa de san andreas

Pero luego al añadir attach, no se tendria que "anclar" al objeto?, por eso las coordenadas 0,0,0, imaginé que se anclaba a la posicion del objeto :cry:

Link to comment
Hidden
local soundBeet = playSound3D(link,0,0,0,false) 

estas poniendo las coordenadas en 0 por lo tanto el sonido solo se reproducira en medio de todo el mapa de san andreas

Pero luego al añadir attach, no se tendria que "anclar" al objeto?, por eso las coordenadas 0,0,0, imaginé que se anclaba a la posicion del objeto :cry:

Tienes que usar attachElements y poner el client en el triggerClientEvent del serverside para no tener que usar localPlayer en clientside.

Link to comment
local soundBeet = playSound3D(link,0,0,0,false) 

estas poniendo las coordenadas en 0 por lo tanto el sonido solo se reproducira en medio de todo el mapa de san andreas

Pero luego al añadir attach, no se tendria que "anclar" al objeto?, por eso las coordenadas 0,0,0, imaginé que se anclaba a la posicion del objeto :cry:

Tienes que usar attachElements y poner el client en el triggerClientEvent del serverside para no tener que usar localPlayer en clientside.

El script que puse funcionó a la perfeccion despues de corregir el error de alex17, la duda es, si uso attachElements, no tendria que moverse con el objeto?

PD: Luego miro, creo que el codigo de aqui necesita una actualizacion

Link to comment
Hidden

El script que puse funcionó a la perfeccion despues de corregir el error de alex17, la duda es, si uso attachElements, no tendria que moverse con el objeto?

PD: Luego miro, creo que el codigo de aqui necesita una actualizacion

Si se pega al objeto, lo he probado hace meses.

Link to comment
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...