Jump to content

[Solucionado] un warning que no sé solucionar


Recommended Posts

estaba scripteando tan tranquilo (Como suele ser) y con (media) inspiracion cuando a la hora de probar el script, me vino este warning, funciona perfectamente, pero no entiendo el warning en sí.

aClientSync 

Ajá que pro ese control V

Codigo de GUI (Client side)

    if tostring(guiGetVisible(userpanel_ventana)) == 'false' then --Linea 38 
        userpanel_gui() 
        return 
    end 
    if tostring(guiGetVisible(userpanel_ventana)) == 'true' then 
        destroyElement(userpanel_ventana) 
        destroyElement(quickpanel_userpanel) 
        return 
    end 

y el warning es este:

Bad argument @ 'guiGetVisible' [Expected gui-element at argument 1] 

Edited by Guest
Link to comment

+1 Castillo

Tu función más eficiente y resumida.

  
  if not guiGetVisible(userpanel_ventana) then 
        userpanel_gui() 
  else 
        destroyElement(userpanel_ventana) 
        destroyElement(quickpanel_userpanel) 
 end 
  

Link to comment
Quiere decir que la ventana no existe.

P.S: Porque convertis el boolean a string? cual es la necesidad de hacer eso?

Sin string no me funcionaba, pero las lineas de tomas ya me fueron, tal como

if not guiGetVisible(userpanel_ventana) == true then 

No me funcionaba, y no sabia el por qué, al poner eso, ya no pasaba el if

Link to comment
Hidden
if not guiGetVisible(userpanel_ventana) == true then 

Con eso estas haciendo que se ejecute el codigo que vaya dentro del "if" si la ventana no esta visible, la parte de "== true" no es necesaria, solo con el "not" al principio haria que se ejecute si no esta visible la ventana.

Link to comment
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...