Sign in to follow this  
LawrenceKnight

Soucis encodage Lua

Recommended Posts

Bonjour, il m'arrive ce soucis lorsque j'ouvre certains fichier lua, pour résumer ça me donne ça (je vous donne un petit morceau en guise de démonstration):

"MvbR-èƒ-²»bTõÞ „÷9†!”í­z ô^ó\ã;Á™i“{?o3’

N!•QµÛëth¬¶H¹¬æOµ[®Ö‘qET$N>¥¹MÚ"à(]òÇÇ\Ãø/s¥Aƒõ_{¨ú"öOæaºm'5Ù¸ÖHrW(È„ ÏÀŽQ1ƒ+‹ãIÅHI%™¨8(@ /‡ø4ÖŒrÒ·×?Vê)0ãñhsü£FjþõŽØEåˆi_]ꆿcßR(똶»LÀ`fìÊ댹R¥ú‡­ãbÇ4üÌù+8dF´´]ÌN’Æ2åµÑiªõ!é¿ÈU»5Q»&j~Ö²Ù„=&iSÁÊüÔz[¡”D$´~›Wc‹G*Ø«øç¬ðÑ‚^¹M   Sb:ûÜþï“·â"²À€0:‚šžfÙîlö®2ËY¶íN—¥%:ç"°„>œ±‹ö‰ÒFz:œñAVä—X1ÆÚéo|BõYYùƒÔ/žUaDïƇe¶×oÝDfÐ|ÒÁgBÅÔŽýP*ûkø¾LåÄŸõ+Ǹ£IÔø

ZƵ¨—&U3jØᾜѢMÌ'þ¸†è;BŸ¶°‡|€Z`/[túËžþˆÌ겓¡{Á4“Î\=Pι°-¤

K¡"We{ §¬DrÙ¯=>{ã2™#¬íÆâøEƒŽô!X™`m|àf2ÖuW¨ó’*(ÈgZ6ÒiP+

Äã4þñ£I°¬4£'þ—S$WèÕŽ£{°SIç_M4-

õ&X©®Õ×›Ù¸a—ßù„,s6m“ˆ;õê|Ï\ã Y“!ž}l)°/»ÎS"

J'aimerais qu'on me dise comment je peu réparer tout ça car ça me le fait tout seul avec notepad++ et jedit et donc je peu pas avancer sur mon serveur quand j'ai de très bon script auquel j'aimerais y mettre ma touche :(

Share this post


Link to post

L'auteur a délibérément compilé ce script pour éviter qu'on en modifie le code source.

Donc ce n''est pas un bug, c'est fait exprès, et le script fonctionne très bien malgré tout. Il est juste compilé.

Si tu veux également compiler TES scripts, il te faut utiliser le compilateur de MTA (qui rajoute une protection supplémentaire par rapport aux compilateurs normaux de scripts Lua).

Cordialement,

Citizen

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.