Sign in to follow this  
Rosior

Debian 7 Segmentation Fault.

Recommended Posts

Hello, i have got a problem with segmentation fault, i tried every builds of MTA 1.4 and always iv got same problem. Here is my system info and strace alert.

  
execve("./mta-server", ["./mta-server"], [/* 15 vars */]) = 0 
[ Process PID=3312 runs in 32 bit mode. ] 
brk(0)                                  = 0x914b000 
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory) 
mmap2(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xffffffffb7752000 
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory) 
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xffffffffb7751000 
set_thread_area(0xbfa1d1b8)             = 0 
--- SIGSEGV (Segmentation fault) @ 0 (0) --- 
+++ killed by SIGSEGV +++ 
  

  
Linux vps118230.ovh.net 2.6.32-042stab102.9 #1 SMP Fri Dec 19 20:34:40 MSK 2014 x86_64 GNU/Linux 
  

cat /etc/debian_version 
7.7 
  

Share this post


Link to post

Segmentation fault occurs when an application attempt's to read from an address in memory that doesn't have any data assigned, are you sure your installation is correct, that all .so files are in correct place etc..

Did you follow this tutorial: https://wiki.multitheftauto.com/wiki/Installing_and_Running_MTASA_Server_on_GNU_Linux, there's a lot of useful information there that might help.

Share this post


Link to post

I get a segmentation fault when i run debian arm via the newest version of qemu-i386 usermode launcher. I know on the others i get syscall error 240, 318, do i not have the files in the right place that would be a silly mistake?

root@tomatoUSB:~/mtsa# ls -a 
.  ..  core.so  mods  mta-server  net.so  xmll.so 
  
  

  
via tree: 
  
~/mtsa 
. 
|-- core.so 
|-- mods 
|   `-- deathmatch 
|       |-- acl.xml 
|       |-- backups 
|       |   |-- 2015-02-08.zip 
|       |   `-- 2015-02-09.zip 
|       |-- banlist.xml 
|       |-- databases 
|       |   |-- global 
|       |   |   `-- registry.db 
|       |   `-- system 
|       |       |-- fileblock.db 
|       |       `-- stats.db 
|       |-- dbconmy.so 
|       |-- deathmatch.so 
|       |-- dumps 
|       |-- editor.conf 
|       |-- editor_acl.xml 
|       |-- internal.db 
|       |-- internal.db-journal 
|       |-- local.conf 
|       |-- logs 
|       |   |-- scripts.log 
|       |   |-- server.log 
|       |   `-- server_auth.log 
|       |-- mtaserver.conf 
|       |-- registry.db 
|       |-- resource-cache 
|       |   |-- DO_NOT_MODIFY_Readme.txt 
|       |   |-- http-client-files 
<edited out> 
|       |-- resources 
<edited out> 
|       |-- server-id.keys 
|       |-- settings.xml 
|       `-- vehiclecolors.conf 
|-- mta-server 
|-- net.so 
|-- tree.txt 
`-- xmll.so 
  
624 directories, 4036 files 
  

  
root@tomatoUSB:~/mtsa# cat /etc/debian_version 
7.8 
  

 

 

  
PATH=$PATH:. 
export PATH 
qemu-i386 mta-server 
"Segmentation fault" 
  

Share this post


Link to post

Had this problem the other day, figured it could help you. In your FTP client, make sure the files are transferred in binary mode, and not ASCII or even auto (FileZilla on my machine was set to auto and didn't detect that it was an executable). When transferred as ASCII, the mta-server (or mta-server64) executable gets corrupted, and running it produces a segfault.

Hope this helps.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.