Jump to content

weird admin resource error


xTravax

Recommended Posts

admin_server.lua

Line 1444 function

Change with

  
addEventHandler('onElementDataChange', root, 
    function(dataName, oldValue ) 
        if dataName ~= "myCustomElementDataName" then 
            if getElementType(source)=='player' and checkClient( false, source, 'onElementDataChange', dataName ) then 
                setElementData( source, dataName, oldValue ) 
                return 
            end 
        end 
    end 
) 
  

Link to comment
yea but whenever i make new or rename element data i would need to write that string for 2301902 times

and this keeps spamming my debugscript 3 when im e.g killing zombies,players,getting in vehicle,anything element data changes

  
elementResourcesNames = { 
   ['Sometest'] = true, 
} 
  
addEventHandler('onElementDataChange', root, 
    function(dataName, oldValue ) 
        if not elementResourcesName[getResourceName(sourceResource)]  then 
            if getElementType(source)=='player' and checkClient( false, source, 'onElementDataChange', dataName ) then 
                setElementData( source, dataName, oldValue ) 
                return 
            end 
        end 
    end 
) 
  
  

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...