Jump to content

[Resolved...?] Replaced Model issues


Recommended Posts

I'll make this short and simple.

I'm currently just doing things for fun and for a server i'm using with friends, and i've been replacing cars for awhile.

However, some cars have this super annoying issue of having their details being completely white, instead of using the correct textures.

Image: http://puu.sh/cHBHP/93cbb76430.png (Image is big, but useful.)

Parts that are white: Hood vents, car marker(s), everything in the interior, grills, wheels, tires, and much more.

Parts that are not white: Hood, bumpers, roof, main body, license plate(s), and top-rear break light.

This has annoyed me today and i've tried everything to fix it.

Before you ask, this is the car i'm using: http://www.gta-worldmods.de/phpkit/start/include.php?path=content/overview.php&type=4&contentid=1847

This is the entire LUA code:

-- The cars are in no way in alphabetical, nor category order. 
  
-- Elegy 
txd = engineLoadTXD("M3.txd") 
engineImportTXD(txd, 562) 
dff = engineLoadDFF("M3.dff", 562) 
engineReplaceModel(dff, 562) 
  
-- Tuning Parts for the Elegy, Sultan, etc 
-- For Elegy (BMW M3) 
txd = engineLoadTXD("M3.txd") 
engineImportTXD(txd, 1034) 
dff = engineLoadDFF("bodyparts/m3/exh_a_l.dff", 1034) 
engineReplaceModel(dff, 1034) 
txd = engineLoadTXD("M3.txd") 
engineImportTXD(txd, 1037) 
dff = engineLoadDFF("bodyparts/m3/exh_c_l.dff", 1037) 
engineReplaceModel(dff, 1037) 
txd = engineLoadTXD("M3.txd") 
engineImportTXD(txd, 1171) 
dff = engineLoadDFF("bodyparts/m3/fbmp_a_l.dff", 1171) 
engineReplaceModel(dff, 1171) 
txd = engineLoadTXD("M3.txd") 
engineImportTXD(txd, 1172) 
dff = engineLoadDFF("bodyparts/m3/fbmp_c_l.dff", 1172) 
engineReplaceModel(dff, 1172) 
txd = engineLoadTXD("M3.txd") 
engineImportTXD(txd, 1149) 
dff = engineLoadDFF("bodyparts/m3/rbmp_a_l.dff", 1149) 
engineReplaceModel(dff, 1149) 
txd = engineLoadTXD("M3.txd") 
engineImportTXD(txd, 1148) 
dff = engineLoadDFF("bodyparts/m3/rbmp_c_l.dff", 1148) 
engineReplaceModel(dff, 1148) 
txd = engineLoadTXD("M3.txd") 
engineImportTXD(txd, 1038) 
dff = engineLoadDFF("bodyparts/m3/rf_a_l.dff", 1038) 
engineReplaceModel(dff, 1038) 
txd = engineLoadTXD("M3.txd") 
engineImportTXD(txd, 1035) 
dff = engineLoadDFF("bodyparts/m3/rf_c_l.dff", 1035) 
engineReplaceModel(dff, 1035) 
txd = engineLoadTXD("M3.txd") 
engineImportTXD(txd, 1147) 
dff = engineLoadDFF("bodyparts/m3/spl_a_l_b.dff", 1147) 
engineReplaceModel(dff, 1147) 
txd = engineLoadTXD("M3.txd") 
engineImportTXD(txd, 1146) 
dff = engineLoadDFF("bodyparts/m3/spl_c_l_b.dff", 1146) 
engineReplaceModel(dff, 1146) 
txd = engineLoadTXD("M3.txd") 
engineImportTXD(txd, 1036) 
dff = engineLoadDFF("bodyparts/m3/wg_l_a_l.dff", 1036) 
engineReplaceModel(dff, 1036) 
txd = engineLoadTXD("M3.txd") 
engineImportTXD(txd, 1040) 
dff = engineLoadDFF("bodyparts/m3/wg_r_a_l.dff", 1040) 
engineReplaceModel(dff, 1040) 
txd = engineLoadTXD("M3.txd") 
engineImportTXD(txd, 1039) 
dff = engineLoadDFF("bodyparts/m3/wg_l_c_l.dff", 1039) 
engineReplaceModel(dff, 1039) 
txd = engineLoadTXD("M3.txd") 
engineImportTXD(txd, 1041) 
dff = engineLoadDFF("bodyparts/m3/wg_r_c_l.dff", 1041) 
engineReplaceModel(dff, 1041) 

Meta file

    "Moka_Akashiya85" Atom="Real cars." version="0.1" type="script"/> 
    

P.S: Before i forget, i'd like to mention that the car worked flawlessly at first, then didn't. I suspect it has something to do with that i took the car from the big pack i made and put it into it's own pack.

Edited by Guest
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...