UnG//Macaus

Problems while creating a server.

Recommended Posts

Hello there,

I have problems while creating a mta server on my Debain 7.0 Linux VPS , i did everything from the manual of wiki. But i can't start my server.

  
root@9tcyndxp2e:~# rm multitheftauto_linux-1.4.0.tar.gz 
root@9tcyndxp2e:~# wget [url=http://linux.mtasa.com/dl/140/multitheftauto_linux-1.4.0.tar.gz]http://linux.mtasa.com/dl/140/multithef ... 4.0.tar.gz[/url] 
--2014-10-15 17:15:23--  http://linux.mtasa.com/dl/140/multitheftauto_linux-1.4.0.tar.gz 
Resolving linux.mtasa.com... 46.105.46.97, 2a01:4f8:a1:221::11 
Connecting to linux.mtasa.com|46.105.46.97|:80... connected. 
HTTP request sent, awaiting response... 200 OK 
Length: 3508992 (3.3M) [application/x-gzip] 
Saving to: `multitheftauto_linux-1.4.0.tar.gz' 
  
100%[======================================>] 3,508,992    859K/s   in 4.2s 
  
2014-10-15 17:15:27 (821 KB/s) - `multitheftauto_linux-1.4.0.tar.gz' saved [3508992/3508992] 
  
root@9tcyndxp2e:~# tar -xf multitheftauto_linux-1.4.0.tar.gz 
root@9tcyndxp2e:~# cd multitheftauto_linux-1.4.0 
root@9tcyndxp2e:~/multitheftauto_linux-1.4.0# ./mta-server 
-bash: ./mta-server: No such file or directory 
root@9tcyndxp2e:~/multitheftauto_linux-1.4.0# 
  

I tried realy everything , i can't fix this problem alone so i'm asking for help.

Regards.

Share this post


Link to post

Could be that your Debian installation is not set up for 32 bit applications. Try this:

dpkg --add-architecture i386 
apt-get update 

Share this post


Link to post

Still doesen't work.

dpkg: unknown option --add-architecture 
  
Type dpkg --help for help about installing and deinstalling packages [*]; 
Use `dselect' or `aptitude' for user-friendly package management; 
Type dpkg -Dhelp for a list of dpkg debug flag values; 
Type dpkg --force-help for a list of forcing options; 
Type dpkg-deb --help for help about manipulating *.deb files; 
  
Options marked [*] produce a lot of output - pipe it through `less' or `more' ! 
root@9tcyndxp2e:~# apt-get update 
Hit [url=http://security.debian.org]http://security.debian.org[/url] squeeze/updates Release.gpg 
Ign [url=http://security.debian.org/]http://security.debian.org/[/url] squeeze/updates/contrib Translation-en 
Ign [url=http://security.debian.org/]http://security.debian.org/[/url] squeeze/updates/main Translation-en 
Ign [url=http://security.debian.org/]http://security.debian.org/[/url] squeeze/updates/non-free Translation-en 
Hit [url=http://security.debian.org]http://security.debian.org[/url] squeeze/updates Release 
Hit [url=http://security.debian.org]http://security.debian.org[/url] squeeze/updates/main amd64 Packages 
Hit [url=http://security.debian.org]http://security.debian.org[/url] squeeze/updates/contrib amd64 Packages 
Hit [url=http://security.debian.org]http://security.debian.org[/url] squeeze/updates/non-free amd64 Packages 
Hit [url=http://http.debian.net]http://http.debian.net[/url] squeeze Release.gpg 
Ign [url=http://http.debian.net/debian/]http://http.debian.net/debian/[/url] squeeze/contrib Translation-en 
Ign [url=http://http.debian.net/debian/]http://http.debian.net/debian/[/url] squeeze/main Translation-en 
Ign [url=http://http.debian.net/debian/]http://http.debian.net/debian/[/url] squeeze/non-free Translation-en 
Hit [url=http://http.debian.net]http://http.debian.net[/url] squeeze Release 
Hit [url=http://http.debian.net]http://http.debian.net[/url] squeeze/main amd64 Packages 
Hit [url=http://http.debian.net]http://http.debian.net[/url] squeeze/contrib amd64 Packages 
Hit [url=http://http.debian.net]http://http.debian.net[/url] squeeze/non-free amd64 Packages 
Reading package lists... Done 
root@9tcyndxp2e:~# dpkg --add-architecture i386 
dpkg: unknown option --add-architecture 
  
Type dpkg --help for help about installing and deinstalling packages [*]; 
Use `dselect' or `aptitude' for user-friendly package management; 
Type dpkg -Dhelp for a list of dpkg debug flag values; 
Type dpkg --force-help for a list of forcing options; 
Type dpkg-deb --help for help about manipulating *.deb files; 
  
Options marked [*] produce a lot of output - pipe it through `less' or `more' ! 
root@9tcyndxp2e:~# cd multitheftauto_linux* 
root@9tcyndxp2e:~/multitheftauto_linux-1.4.0# ./mta-server 
-bash: ./mta-server: No such file or directory 
root@9tcyndxp2e:~/multitheftauto_linux-1.4.0# 
Debian -- Security Information 
security.debian.org 

Share this post


Link to post

Looks like you have Debian 6. Try this:

apt-get install ia32-libs 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.