Aeron

MTA:mA Fixes / FAQ

Recommended Posts

MTA:mA V4.0

..:: FAQ ::..

Q. What is the Admin2Admin protocol?

A. A protocol for communication between MTA:mA's to restore information and notifications of MTA:mA's actions.

Q. How works Admin2Admin protocol?

A. It works via the player-console echo or if there are no players, via normal chat. (In further MTA-updates this might change into Admin to Admin private messages)

Q. Is Admin2Admin protocol then not open for sensitive information?

A. Sensitive informantion gets 'encoded' on a way only admins can read.

Q. How to disable Admin2Admin protocol?

A. Edit mta.ini and change 'admin2admin' item under topic '0' to value '0'

[0]
admin2admin=0

Q. I can't connect to a R1.1 server.

A. Change version to '2'.

Q. Some functions are disabled.

A. It ain't finished!

Q. Where's the documentation?

A. I'm lazy.

Q. Which commands are availible?

A. http://www.mtavc.com/docu/index.php/MTA ... A_4_series

Q. How do I load scripts?

A. Do the following key-combo's in mIRC:

ALT+R, ALT+R ,CTRL+L

Now you see a select file dialog.

MTA:mA v3.0

..:: FIXES::..

Latest files and script fixes:

http://home.deds.nl/~aeron/downloads.html

..:: FAQ ::..

Q. I get a CRC-error.

A. Download manual the files @ http://home.deds.nl/~aeron/downloads.html and type "/reload -rs mta.mrc"

Q. I see sometimes "Disabled" how to fix?

A. Connect with Admin+ connection.

Q. Admin-System kicks/bans me when i do !kick/!ban

A. Download the latest fix.

Q. Admin-System still kicks me after login.

A. Download the latest fix.

Q. I get banned when I give up a incorrect password first time.

A. Download the latest fix.

Q. Scripts doesn't work.

A. Turn "Enable scripts" on in the options dialog.

Q. My !-commands doesn't work.

A. They are handeled in the "mta.command" alias. (See scripting.html for more info)

Q. I get a strange error when I click the "Scripts" button.

A. Bug, fixed in MTA:mA v3.01. Update MTA:mA by typing "/update" in MTA:mA.

Q. I all see "Unknown"'s when i connect.

A. Bug, fixed in MTA:mA v3.02. Update MTA:mA by typing "/update" in MTA:mA

Q. I see no nicknames when I join a GTA:3 server.

A. Bug, fixed in MTA:mA v3.03. Update MTA:mA by typing "/update" in MTA:mA

..:: Known MTA bugs ::..

Q. When I send text to the server, I get some part of the msg what i send before.

A. This is a known bug. It's not that MTA:mA is bugged but the server, the server can't handle so much text packets with no time space between it.

In other words:

MTA:mA send the correct text (1) ==> Server recieves the correct text (2) ==> Dual a server bug it sends the bugged text ==> MTA:mA / Client recieves bugged text (3 / 4).

Here is a screenshot:

proof.gif

Edited by Guest

Share this post


Link to post

In regard s to the last 'bug' its funny because if you reverse it, and do the action before the text it works fine. Now, why wont mta.slap work? I'm having to use 'mta.say $1 /slap $mta.name($1,$2)' which is ok but why have an alias that doesnt work?

(tho of course according to you it does, tho ive yet to see an example of it that does)

Share this post


Link to post
In regard s to the last 'bug' its funny because if you reverse it, and do the action before the text it works fine. Now, why wont mta.slap work? I'm having to use 'mta.say $1 /slap $mta.name($1,$2)' which is ok but why have an alias that doesnt work?

(tho of course according to you it does, tho ive yet to see an example of it that does)

Nothing wrong with 'mta.slap '

Share this post


Link to post

Except that it doesnt work :P

nm tho, everyone can use mta.say /slap blah blah instead so no biggy

Share this post


Link to post
Guest

if i install the whole crap, and run a script it just won't work, nothing special happens.

anybody who can tell me what i do wrong?

Share this post


Link to post

lol u can see that Bump typed the same thing in IRC in the background :)

Share this post


Link to post

ADDED:

Q. I can't connect to a R1.1 server.
A. Change version to '2'.

Share this post


Link to post

Not sure if u know aeron, but by double clicking a race name off the list, doesnt always start the correct race, looks like the packet info comes in any order, so as u add the races they get added to the list in the wrong order. :? It Might be better for users if u sort the list A to Z. I know I have trouble finding maps on it. just thought id point it out anyway.

Share this post


Link to post
Not sure if u know aeron, but by double clicking a race name off the list, doesnt always start the correct race, looks like the packet info comes in any order, so as u add the races they get added to the list in the wrong order. :? It Might be better for users if u sort the list A to Z. I know I have trouble finding maps on it. just thought id point it out anyway.

Thx, about the double clicking thing! Fixed in 4.14.

You can type in the beginning of the race name on the top of the list to auto select the correct one, see it as 'auto-complete'. Searching on keyword or ordering the maps on A-Z eats a bit of CPU.

Share this post


Link to post
Not sure if u know aeron, but by double clicking a race name off the list, doesnt always start the correct race, looks like the packet info comes in any order, so as u add the races they get added to the list in the wrong order. :? It Might be better for users if u sort the list A to Z. I know I have trouble finding maps on it. just thought id point it out anyway.

Thx, about the double clicking thing! Fixed in 4.14.

You can type in the beginning of the race name on the top of the list to auto select the correct one, see it as 'auto-complete'. Searching on keyword or ordering the maps on A-Z eats a bit of CPU.

Ahh ok thx, i used to find the next map, click it once to bring the name up, then wait for the race to finish b4 starting the next race, the trouble was, when a new map started, it replaced the name lol. eventually i kinda gave up on using it to select maps... i just noticed it wasnt quite right and thought id give it a mention:)

/me waits for 4.14 :)

Share this post


Link to post
Guest

where must i put these .jpg files in?

Share this post


Link to post
Guest

there are 5 .jpg files. they are for mta:ma.

they are called map_sa2.jpg, map_sa3.jpg, map_sa4.jpg, map_sa5.jpg and map_sa6.jpg and i DONT know where to put these files :-(

maybe someone knows mta:ma and can help me!

Share this post


Link to post
there are 5 .jpg files. they are for mta:ma.

they are called map_sa2.jpg, map_sa3.jpg, map_sa4.jpg, map_sa5.jpg and map_sa6.jpg and i DONT know where to put these files :-(

maybe someone knows mta:ma and can help me!

I have mine in my mIRC dir, they seem to work just fine, although i hardly ever use them. maybe u should try there 8)

Share this post


Link to post

Put them to your mtama root dir:

[sum dir.]

mta.mrc

...

mta_sa2.jpg (Which is 2000x2000 px)

mta_sa3.jpg (Which is 3000x3000 px)

mta_sa4.jpg (Which is 4000x4000 px)

mta_sa5.jpg (Which is 5000x5000 px)

mta_sa6.jpg (Which is 6000x6000 px)

They havent worked for me until i deleted the mta_sa6.jpg cuz it just made my mta: ma lag as hell. (Due the big filesize)

Share this post


Link to post
Guest

oh j-fox u are german. i cant speak english very well...

so can u give me your icq or msn adress? then we can talk german!

Share this post


Link to post

where did you get the map files? and why when someone breakes the record its says that, a new record in 'Unknown'?

Share this post


Link to post

  • Recently Browsing   0 members

    No registered users viewing this page.