Ransom

If you have Wireless Internet and have teleporting

Recommended Posts

I have just found out something great today. Ever since MTA .2 I've been warping anywhere from 1-3 seconds about every minute or less. I have finally figured out why:

You need to turn off a service called "Wireless Zero Configuration". What this service does is automatically configure your wireless Internet adapter and connect you to a network (in other words when you plug it in it does all the work and connects you to your router). But the problem is every minute it scans for a better network. This is what causes that teleporting.

You still need that service so your wireless Internet adapter can connect you to your router (internet network) initially however. So what you do is first let your internet connect, then:

1. Go to start menu > run

2. Type "services.msc" in run

3. On this list scroll down to "Wireless Zero Configuration"

4. Press "Stop" to stop the service.

This should fix your teleport problem. I was so happy when I finally figured this out today. Hope it helps other wireless Internet adapter users. The only catch is the service will turn on again everytime you restart your computer, so you must stop the service again.

You cannot just DISABLE it with "msconfig" because you need the service to connect you to your network and configure your Internet at first.

I have not figured out if this can be automated, but I do see something about "start parameters" when you right click it and choose properties. It only needs to be on until your adapter connects to your router (internet network).

For people without wireless internet:

I think it says you can disable this service since you don't need it. Look up "Wireless Zero Configuration" on google sometime.

Edited by Guest

Share this post


Link to post

I tried it . But now it keeps disconnecting every minute (cause i set 60 seconds) . it might be that my signal if low on some places .

Share this post


Link to post

nifty, now it will also stop connecting to my neighbors damn router...i tell it "connect to my router" 5 mins later i see "hinojos" lan dfdsfdkls;fjsd;fkjas anyhoot, nice find :)

Share this post


Link to post
nifty, now it will also stop connecting to my neighbors damn router...i tell it "connect to my router" 5 mins later i see "hinojos" lan dfdsfdkls;fjsd;fkjas anyhoot, nice find :)

wtf?

Share this post


Link to post

i've been using the software that came with my wireless network cards, disabled the windows one altogther, found overall its slower and less reliable, generally connects at 22mbps, with windows generally connects at 5.5, wierd huh?

although i guess not all wireless routers/cards come with thier own software? origo is the ones i have in case anyone is wondering :o

Share this post


Link to post

i think it does better speeds on mac's . or ... your using a wireless card with one frequence and the router with another . they combine but ... it might be slower . And vass , thats the network name ...

Share this post


Link to post
I tried it . But now it keeps disconnecting every minute (cause i set 60 seconds) . it might be that my signal if low on some places .

You set what at 60 seconds? Nothing should be set... you just disable the service once your internet is connected on computer startup like normal

Share this post


Link to post

no , cause my wireless card has a program that came with it . that ads more options to these windows menu things . and now i can select the time i want for the card to look for networks . and it is set to 60 seconds (default)

Share this post


Link to post

I see, this can't really help you then unless you don't use that software.

Share this post


Link to post

if you set the software to 0 seconds i'd imagine that would disable it automatically scanning, then when you want to look for a new network (if ever you do) there should be like a refresh connections buttons or rescan or something

maybe?

Share this post


Link to post

well i imagine if u wanted to join another network, you'd have to open the network connection and go to the select network dialog box

Share this post


Link to post

moved to useful topics..... Since I dont have cable its really pointless for me though =P

Share this post


Link to post

And moved badly. Please re-do it without the shadow topic left in original forum xerox. Shadows defeat the object of moving it in the first place, unless it is into 'Useful topics' or somesuch. thanks

Share this post


Link to post

ok - unlocked due to unpopular demand =)

Share this post


Link to post
Guest

hi ransom. i tryed disabling this wireless zero config, and i get disconnected form the game within a minute. i always get teleports and freeezes on every game ive played ever since ive gotten the wireless. i am using netgear and a 802.11 network. HELP ME>!!!

Share this post


Link to post

well, then, why dont you turn it back on to return your connection to normalcy?

i wonder if all wireless connections timeout with all network adapters.

ive been using a Netgear MA101 USB adapter before i got an SMC 2602W PCI adapter, and ive experienced these same disconnection problems as Ransom with the Netgear one - in BF1942 i would get 'Warning: Connection Problems' every 30 seconds or so for a few seconds and warping. ever since switching to the SMC adapter these problems were greatly reduced, but i still get the occasional 'connection problems' and warping in other games. i dont know how often, but many times when i see the taskbar i get a 'Wireless Connection Unavailable' warning that lasts a couple of seconds before it connects. this doesnt seem to appear every minute though. i will give disabling the Wireless Zero Config a shot and see how it turns out.

EDIT: just now, ive noticed a wireless connection unavailable message appear over my quicklaunch for a couple of seconds before it connected back. i go into Wireless Zero Configuration, and now it says Started instead of being blank like it was when i disabled it. i am not running my wireless adapter's software - so why would it disconnect me for a couple of seconds? how is it possible that it searches for connections if nothing should be telling it to (SMC software is not running, Wireless Zero Config was OFF in Services)?

Share this post


Link to post

  • Recently Browsing   0 members

    No registered users viewing this page.