Woovie

Multi Theft Auto: San Andreas 1.3.4 released!

Recommended Posts

Awesome! But i wonder if people are able to decompile the scripts easily? :?

Edited by Guest

Share this post


Link to post

To try out the SFX stuff that Jusonex added:

Make sure you've got sfxbrowser resource (It comes with the official resources)

Start local server

execute: start sfxbrowser (This starts the resource)

execute: sfxbrowser (This opens the GUI)

And away you go.

If you don't hear anything or some of the sound banks don't work, see the warning box here: https://wiki.multitheftauto.com/wiki/PlaySFX

Share this post


Link to post

I updated to 1.3.4 version and every time I launch it says to update my MTA to 1.3.4 :D wtf?

Share this post


Link to post

Great Job MTA Team the sfxBrowser is a totally awesome.

Finally i can listen and use the italian voice :mrgreen:

container : spc_na Bank : 136 VOICE_GNG_VMAFF4

Epic and fail italian voice hahaha example this : playSFX("spc_na", 49, 126, true)

Share this post


Link to post

Okay can someone tell me what i need to do when it appends:

WARNING: gps-system c_gps.lua is invalid and will not work in future versions. Please re-compile at http://luac.mtasa.com/

I need update the file?

Some resources in the community are compiled so how i will fix it? If i put the compiled file in http://luac.mtasa.com/ this will fix the file or i need to original file?

I got 46 errors like that :S

Oh and sorry if this is the wrong place to post this but i think it will be helpfull for others when someone reply

Share this post


Link to post

You need to recompile original files, not the pre-compiled ones.

Share this post


Link to post

So the people will lost lots of resources in de community because the most of them are compiled :S

Share this post


Link to post

Amazing!! Well done team. I'm very proud of your work, and it tickles me that we've had this mod for years. Rockstar should award you guys. I'm eagerly waiting GTAV but will always come back to this from time to time :D Had some great fun, so thanks again.

Share this post


Link to post

Scripts:

Added function setHeliBladeCollisionsEnabled

Added function getHeliBladeCollisionsEnabled

Game:

Added "shared" export type in meta.xml

Added Lua source encryption option

Bugs:

Fixed crash when streaming in tec-9 with a replaced weapon model (Finally!! :D)

fixed guiCreateFont fails each second time resource is started (Thank god :D )

Fixed client ammo desync when using giveWeapon sometimes

Resources:

Fixed 'Use LODs' option in the map editor resource

Thanks! I waited long for this, good job MTA :D

Okay can someone tell me what i need to do when it appends:

WARNING: gps-system c_gps.lua is invalid and will not work in future versions. Please re-compile at http://luac.mtasa.com/

I need update the file?

Some resources in the community are compiled so how i will fix it? If i put the compiled file in http://luac.mtasa.com/ this will fix the file or i need to original file?

I got 46 errors like that :S

Oh and sorry if this is the wrong place to post this but i think it will be helpfull for others when someone reply

You need to recompile almost every ValhallaGaming script you have :D

Share this post


Link to post

"WARNING ... is invalid and will not work in future versions, please ..."

I don't like this, i compile a file in "luac.mtasa.com" and I can still decompile this, I prefer to use another compiler, honestly I do not see the use.

Share this post


Link to post
"WARNING ... is invalid and will not work in future versions, please ..."

I don't like this, i compile a file in "luac.mtasa.com" and I can still decompile this, I prefer to use another compiler, honestly I do not see the use.

Ecrypt it and try again.

Share this post


Link to post
"WARNING ... is invalid and will not work in future versions, please ..."

I don't like this, i compile a file in "luac.mtasa.com" and I can still decompile this, I prefer to use another compiler, honestly I do not see the use.

Lol, that's impossible the file uses a entirely different method for compiling that only MTA:SA could read, i tried to decompile my own file and it didn't even tried to because it said ''Unknown symbol'' et cetera.

Edit: this is ofcourse with the new encrypt method.

luadec: test.luac:1: unexpected symbol near 'char(28)'

Share this post


Link to post

I have a question (maybe is a stupid question) MTAsa 1.3.4 now work only with original file and Mta luac?

If i compiled my script with other compiler no work?

Share this post


Link to post

That's right, in future releases, the scripts compiled by a compiler which isn't the MTA one, won't work.

Share this post


Link to post

Ok tnx for reply,this is really great idea.

Good job MTA team.

Share this post


Link to post
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.