nadeeja

Texture replace help

Recommended Posts

I found a wheel pack with only *.dff files that replaces all the upgradable wheels. So this wheel pack is working fine with MTA when the original vehicle.txd file is replaced with the vehicle.txd file that came with this wheel pack. Now I want to install this pack to my server and I successfully replaced all the .dff files. But wheels are displayed white if clients don't have this modded vehicle.txd file. I examined this .txd file and found that there are some new images inside it. So my question is how can I add those new textures to game?(Shader Texture replacement ain't going to work since those texture are not originally came with the game :? ) Or is there a way to replace the client vehicle.txd file?

I also stucked in this texture replacement. I replaced jester with a highpoly car mod and now I want to add paint jobs that came with this mod. But texture replacement (I used the shader replacement method mentioned here) is not working when the original jester is replaced with this car mod. I used engineGetVisibleTextureNames and found out that when the original car is replaced by the mod, the paintjob textures are not loading :? .

Edited by Guest

Share this post


Link to post

Upload the vehicle.txd file to a site, or send it to my Skype: Chrisinater22, we can use shaders to include it.

Share this post


Link to post

Can you upload it somewhere else? I am using IE 8, firefox and stuff do not work on our school laptops, the school has added patches to stop us accessing it.

Share this post


Link to post

I sent you new links. Check your pms.

Upload the vehicle.txd file to a site, or send it to my Skype: Chrisinater22, we can use shaders to include it.

How you are going to do it? Please at least give me a hint. Is it like adding new texture to the game? I'm dying to test it.

Edited by Guest

Share this post


Link to post
I sent you new links. Check your pms.
Upload the vehicle.txd file to a site, or send it to my Skype: Chrisinater22, we can use shaders to include it.

How you are going to do it? Please at least give me a hint. Is it like adding new texture to the game? I'm dying to test it. :lol:

Shader can be used to replace textures. vehicles.txd does not hold paintjob textures. You can use simple texture replace shader to replace textures if you can't get to replace some textures.

https://wiki.multitheftauto.com/wiki/El ... der#Simple

This is the shader you'd have to use. You will need to apply this shader to world texture (https://wiki.multitheftauto.com/wiki/DxCreateShader). To know which texture you need to replace you can use https://wiki.multitheftauto.com/wiki/Sh ... ture_names resource to help you find the paintjob texture.

Share this post


Link to post

I replaced jester1body256, jester2body256, jester3body256 using shaders. But my problem is none of these textures are loading when the original jester.dff & jester.txd are replaced with a mod.

Any idea why this is happening?

I tested it without loading the mod and textures are replaced fine then. But whenever I loaded the mod I don't see any paintjob textures using texture names resource. :? There are no jester1body256, jester2body256 or jester3body256 textures loaded when I add paintjobs to car. :|

Share this post


Link to post

That makes sense. When you apply a paintjob the vehicle's texture changes. If you check gta3.img you'll find jester1.txd jester2.txd and jester3.txd. Each of these txds has only 1 texture (jester1body256, jester2body256 and jester3body256). If you want to replace the texture of your modded jester then you can simply replace texture with the shader (the texture name that is applied to the car, with a paintjob texture). I can't remember how GTA engine works when you use setVehiclePaintjob on custom vehicles. But the only way to replace your original texture (not jester1body256, etc) with a paintjob texture would be with a shader.

Share this post


Link to post

Texture replaced fine with the original model;

73475418.png

Here is what happend when the mod is loaded

pj2e.png

As you may notice the jester2body256 is gone when the model is replaced. I tried adding the paintjob again. But the paintjob texture is not loading. :(

Share this post


Link to post

Try to apply a paintjob (you showed in the second screenshot it was set to 0, change it) and check the list again. If it doesn't work, well, find your texture name on the list and then replace that with custom paintjob texture.

EDIT:

You can find some information here: http://www.gtaforums.com/index.php?showtopic=209878 Seems like the original texture applied to your modded vehicle needs to be "remap" to support paint jobs.

Share this post


Link to post

The original texture of my modded vehicle is remap_supra. You may see it in the 2nd pic. I tried renaming it to remapjesterbody256 (original remap texture name) and remap_jester_body (the method mentioned in your link). But both times the renamed textures didn't load. Instead there was a new texture (named @hite) loaded which covered the body of the model.

Edit: Ok I guess there is something wrong with modded jester. :(

Thank you 5op and csmit195 for helping me. :) If anyone know a better solution please share it here. 8)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.