Jump to content

MTAMA Problems Thread


Si|ent

Recommended Posts

  • Replies 314
  • Created
  • Last Reply

Top Posters In This Topic

  • 3 weeks later...

Hi,

I'm trying to get mta:ma 4.14 working, but I'm having a lot of problems that didn't occur in the previous release.

I'm getting a writini error (insufficient parameters) on line 22 of mta.mrc

This is the line is trying to pass: !writini 1.ini (userid) nick1 (username)

But since the error is insufficient parms, either the userid or username cannot be found in the data sent from the server. Am I experiencing packetloss?

The problem is that since the username isn't found, when $mta.nick is called for that userid, it sends an a2a BROADCAST "LOSTNICK" message. However, some users have been complaining that the script was sending pm to them with that message!

I'm also getting a few LOSTMAP problems, and I have no idea how this is happening! If I look at 1.ini under [races] I see races 1-93 or something, and then race 150-234... It's just missing a random block in the middle? Then I disconnect and reconnect (to clear 1.ini and refresh maplist) and it's fine again.

Any ideas what's causing this? It seems as though the servers information is getting jarbled.

Btw I did noticed that if I changed:

$bvar(&a,$calc(%b + 8),$calc(%c - %b - 8)).text,"

to

$+(",$bvar(&a,$calc(%b + 8),$calc(%c - %b - 8)).text,")

in line 22 it seemed to eliminate some of the LOSTNIC messages. However, over time.. I still noticed in my userlist that there were userIDs with no name.

Any help is appreciated!

Link to post
Hi,

I'm trying to get mta:ma 4.14 working, but I'm having a lot of problems that didn't occur in the previous release.

I'm getting a writini error (insufficient parameters) on line 22 of mta.mrc

This is the line is trying to pass: !writini 1.ini (userid) nick1 (username)

But since the error is insufficient parms, either the userid or username cannot be found in the data sent from the server. Am I experiencing packetloss?

The problem is that since the username isn't found, when $mta.nick is called for that userid, it sends an a2a BROADCAST "LOSTNICK" message. However, some users have been complaining that the script was sending pm to them with that message!

I'm also getting a few LOSTMAP problems, and I have no idea how this is happening! If I look at 1.ini under [races] I see races 1-93 or something, and then race 150-234... It's just missing a random block in the middle? Then I disconnect and reconnect (to clear 1.ini and refresh maplist) and it's fine again.

Any ideas what's causing this? It seems as though the servers information is getting jarbled.

Btw I did noticed that if I changed:

$bvar(&a,$calc(%b + 8),$calc(%c - %b - 8)).text,"

to

$+(",$bvar(&a,$calc(%b + 8),$calc(%c - %b - 8)).text,")

in line 22 it seemed to eliminate some of the LOSTNIC messages. However, over time.. I still noticed in my userlist that there were userIDs with no name.

Any help is appreciated!

The !writeini error is caused by a invailed nick MTA:mA can't handle (I still dont know which nicks this happens). Because of the empty spot in the information file of MTA:mA, MTA:mA v4.14 asks other MTA:mA's (via the new Admin2Admin protocol, thats the BROADCAST LOSTNICK pm) if they have that name. This is the same thing about maps. When you join, each map name gets sends to you in a seperated packets. If the packet gets lost on the way from the Server to you, you miss a packet and thus missing a MAP name. MTA:mA then asks again to other MTA:mA if they have such map ID. If there are no other MTA:mA's to help your current MTA:mA you can disable Admin2Admin protocol (See MTA:mA Fixes / FAQ thread). About the pm's: because the curretn MTA release doesn't support Admin to Admin privaye messages, I have to do it with Admin to Player Console echo's (You can only see them in Console not in chat, and only the player with the lowest playerID can see them). IP's gets encode on such way only admins can read.

Link to post

Aeron, thanks for the reply.

I had a feeling that's what was happening... I'm not sure what was the problem.. I'll try to debug by having mIRC spit out the raw data for usernames and see if I can't pin down the error...

I did notice that a fairly normal name "Sampson" or something got lost a few times (found by comparing the ID to the remote admin nick list). I'm going to try running mIRC on the same machine as the MTA server itself and see if that helps at all.

Besides reconnecting, is there any way to ask the server to send the nicklist or the maplist? If so we could have mtama request the list until there are no errrors.

Link to post

Aeron this might help

I added an echo line (line 22 below) in mta.mrc to debug:

21: !writeini -n $+(",$scriptdir,%a,.ini") $bvar(&a,%b) Nicks 1
22: echo ID: $bvar(&a,%b)  b = %b c = %c b + 8 = $calc(%b +  c - b - 8: $calc(%c - %b - 
23: !writeini -n $+(",$scriptdir,%a,.ini") $bvar(&a,%b) Nick1 $+(",$bvar(&a,$calc(%b + ,$calc(%c - %b - ).text,")

And got the following output on connect:

ID: 0 b = 66 c = 87 b + 8 = 74 c - b - 8: 13
ID: 10 b = 88 c = 103 b + 8 = 96 c - b - 8: 7
ID: 5 b = 104 c = 124 b + 8 = 112 c - b - 8: 12
ID: 2 b = 125 c = 147 b + 8 = 133 c - b - 8: 14
ID: 13 b = 148 c = 157 b + 8 = 156 c - b - 8: 1
ID: 16 b = 158 c = 177 b + 8 = 166 c - b - 8: 11
ID: 3 b = 178 c = 201 b + 8 = 186 c - b - 8: 15
ID: 1 b = 202 c = 208 b + 8 = 210 c - b - 8: -2    ***** NOTICE NEGATIVE NUMBER
ID: 68 b = 209 c = 221 b + 8 = 217 c - b - 8: 4
ID: 11 b = 222 c = 246 b + 8 = 230 c - b - 8: 16
ID: 12 b = 247 c = 258 b + 8 = 255 c - b - 8: 3
ID: 19 b = 259 c = 282 b + 8 = 267 c - b - 8: 15
ID: 8 b = 283 c = 296 b + 8 = 291 c - b - 8: 5
ID: 25 b = 297 c = 311 b + 8 = 305 c - b - 8: 6
ID: 26 b = 312 c = 323 b + 8 = 320 c - b - 8: 3
ID: 17 b = 324 c = 346 b + 8 = 332 c - b - 8: 14
ID: 7 b = 347 c = 361 b + 8 = 355 c - b - 8: 6
ID: 20 b = 362 c = 376 b + 8 = 370 c - b - 8: 6
ID: 22 b = 377 c = 394 b + 8 = 385 c - b - 8: 9
ID: 23 b = 395 c = 411 b + 8 = 403 c - b - 8: 8
ID: 27 b = 412 c = 424 b + 8 = 420 c - b - 8: 4
ID: 28 b = 425 c = 447 b + 8 = 433 c - b - 8: 14
ID: 9 b = 448 c = 461 b + 8 = 456 c - b - 8: 5
ID: 29 b = 462 c = 479 b + 8 = 470 c - b - 8: 9
ID: 30 b = 480 c = 498 b + 8 = 488 c - b - 8: 10
ID: 6 b = 499 c = 513 b + 8 = 507 c - b - 8: 6
ID: 4 b = 514 c = 532 b + 8 = 522 c - b - 8: 10
ID: 24 b = 533 c = 545 b + 8 = 541 c - b - 8: 4
ID: 31 b = 546 c = 570 b + 8 = 554 c - b - 8: 16
ID: 15 b = 571 c = 591 b + 8 = 579 c - b - 8: 12

I confirmed that ID#1's name was NOT visible in to mtama ans was missing in 1.ini...

Looking under remote admin, ID 1's name was "Desert_King"

So clearly from the code we can see that the error occurs when (%c - %b -8) < 0, which makes sense since you can't do bvar on neg. numbers (I don't believe?)

Clearly there is some problem w/ remote admin protocol and its communication with mtama. Please help if you can b/c this part of the script is imperative for what I'd like to do...

I tested what would happen if I detected the negative number and replaced it with 0, 1 and length(&a), but nothing worked. Any ideas?

Link to post

Is anybody here, who would like to explain in german how I can get this work?

I dont have a clue about mIRC, but these scripts are nice. More fun when you can see the best race times, and so on. What exactly do I need, and how do I use the stuff the. Which file comes to which place, and on what server I have to connect with IRC? So many questions. Maybe I have already read the answears, but I dont understand the most perfectly.

So, if there is any guy out there with some minutes for me, I would be very dankbar. :D

Please mail me then: truespin25@hotmail.com

Link to post
Is anybody here, who would like to explain in german how I can get this work?

I dont have a clue about mIRC, but these scripts are nice. More fun when you can see the best race times, and so on. What exactly do I need, and how do I use the stuff the. Which file comes to which place, and on what server I have to connect with IRC? So many questions. Maybe I have already read the answears, but I dont understand the most perfectly.

So, if there is any guy out there with some minutes for me, I would be very dankbar. :D

Please mail me then: truespin25@hotmail.com

1. Download the latest version of mIRC at http://www.mirc.com

2. Download the latest version of MTA:mA at http://home.deds.nl/~aeron/mtama/4.0/

3. Install mIRC

4. Unpack MTA:mA in a directory (Recommended "C:\Program Files\mIRC\MTAmA")

5. Startup mIRC

6. Type in the mIRC 'Status window' '//load -rs $+(",$$sfile(*.mrc,Select your mta.mrc,Load),")' (Without qoutes)

7. Select your 'mta.mrc'

8. Press 'Load'

9. Done

Link to post

im not sure if this is a MTAMA problem or a MTAMAGRS ..

- the all maps list gets broken , either by to much files (it loads about 633 of 2400 maps on my server) .. or by maps with odd characters

The server send 2400 packets in 1 second. I can't help it you lose some. :>

well .. if that would be the cause my guess is the list would be different every time the script loads ..

it jumps in my list from country racing to dzei derby .. and from dzei derby to Eagle's Avenged Map

jumps from Hc Jump Race to lol ..

making a lot of races come out as 'unknown'

Link to post
  • 3 months later...

I am running MTA:MA 3.24 and GRS script on a server for MTA 0.5:VC, these files have not been changed in any way (yet 8) ).

When some players (unknown ones) join I get a CRC failed error and have to restart the scripts. With other players nothing happens.

Questions:

1. Can the script crash be caused because people are running mIRC or some other IRC (like they might have their own server ;) )

2. Will it be solved by setting the listen port ?

3. Is it possible to make the script restarts automatic ?

4. Will it help to remove the CRC check (I will find out how to do it myself :twisted: )

I want the scripts to be up 24/7 tell me if there is aa way to avoid them from stopping.

Link to post
I am running MTA:MA 3.24 and GRS script on a server for MTA 0.5:VC, these files have not been changed in any way (yet 8) ).

When some players (unknown ones) join I get a CRC failed error and have to restart the scripts. With other players nothing happens.

Questions:

1. Can the script crash be caused because people are running mIRC or some other IRC (like they might have their own server ;) )

2. Will it be solved by setting the listen port ?

3. Is it possible to make the script restarts automatic ?

4. Will it help to remove the CRC check (I will find out how to do it myself :twisted: )

I want the scripts to be up 24/7 tell me if there is aa way to avoid them from stopping.

1 No

2 No idea

3 Yes

4 Yes

Link to post

I have made progress on finding the reason why the scripts close with CRC error.

When a player joins from a connection with a strict firewall (and probably proxy as well) it causes a crash of scripts because of CRC error.

I came across this because while testing I connected in this way.

By loading the scripts one by one I found that the MTA:MA GRS is the one that causes the crash.

MTA:MA and my own coding continue running when I join from behind a strict firewall.

I suspect the DNS resolving to cause the problem, if I get it fixed I will tell. If anyone already fixed this, help (post or PM) is appreciated.

Link to post
  • 1 month later...
  • 1 month later...

First of all I hope you know that the 4.15 is for MTA:SA

If you want to connect to a MTA:VC server you need to get version 3.24 (correct me if I am wrong)

About the problem with connection check where you have your MOTD and see if the URL is set correct. Not finding the MOTD can cause time outs.

Link to post

if hes trying to connect to vc he wouldnt do that on 44003 ;)

but ive talked to several with this problem

ive helped them with a old version of mta:ma and no problem

ive had it myself when i updated it .. but disappeared when i reverted to old backup ( ..,,yay sometimes i actually make backups and its worthwile :D )

connection keeps timing out after a few seconds

Link to post
  • 2 months later...
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...