Jump to content

i have problem


Machine

Recommended Posts

[root@localhost multitheftauto_linux-1.3.1]# yum install ncurses-devel ncurses 
Loaded plugins: fastestmirror, refresh-packagekit 
Loading mirror speeds from cached hostfile 
 * base: centos.spd.co.il 
 * epel: mirror.affix.me 
 * extras: centos.spd.co.il 
 * updates: centos.spd.co.il 
Setting up Install Process 
Package ncurses-devel-5.7-3.20090208.el6.x86_64 already installed and latest version 
Package ncurses-5.7-3.20090208.el6.x86_64 already installed and latest version 
Nothing to do 
[root@localhost multitheftauto_linux-1.3.1]# 
  

and it gives same error when i start server!

Link to post

i did it

it says

  
[root@localhost ~]# yum install ncurses.i386 
Loaded plugins: fastestmirror, refresh-packagekit 
Loading mirror speeds from cached hostfile 
 * base: centos.spd.co.il 
 * epel: mirrors.n-ix.net 
 * extras: centos.spd.co.il 
 * updates: centos.spd.co.il 
Setting up Install Process 
No package ncurses.i386 available. 
Error: Nothing to do 
[root@localhost ~]# 
  
  

Link to post

That is weird, it is in my yum repository but I have two more repos though.

yum list ncurses.i386 
Loaded plugins: fastestmirror 
base                                                     | 1.1 kB     00:00 
epel                                                     | 3.7 kB     00:00 
extras                                                   | 2.1 kB     00:00 
updates                                                  | 1.9 kB     00:00 
[b]vz-base                                                  |  951 B     00:00 
vz-updates                                               |  951 B     00:00[/b] 
Excluding Packages in global exclude list 
Finished 
Installed Packages 
ncurses.i386                      5.5-24.20060715                      installed 

Good luck. Maybe you can get the ncurses.i386 package a different way or you can add a repo to yum that does have this package. If all else fails install CentOS as x86.

Link to post

it would be great if you told me how can i edit my mirror list and give me your mirror list

this will be very usefull so when i make this command

yum list ncurses.i386

it will take it from your same country

pls tell me how to edit and whats the link

Link to post

i have great idea which was to do this!

i have edited this /etc/yum.repos.d/CentOS-Base.repo

to this

[base] 
name=CentOS-$releasever – Base 
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os 
#baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/ 
gpgcheck=1 
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6 
  
#released updates 
[updates] 
name=CentOS-$releasever – Updates 
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates 
#baseurl=http://mirror.centos.org/centos/$releasever/updates/$basearch/ 
gpgcheck=1 
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6 
  
#additional packages that may be useful 
[extras] 
name=CentOS-$releasever – Extras 
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=extras 
#baseurl=http://mirror.centos.org/centos/$releasever/extras/$basearch/ 
gpgcheck=1 
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6 
  
#additional packages that extend functionality of existing packages 
[centosplus] 
name=CentOS-$releasever – Plus 
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=centosplus 
#baseurl=http://mirror.centos.org/centos/$releasever/centosplus/$basearch/ 
gpgcheck=1 
enabled=1 
includepkgs=kernel* 
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6 
  
#contrib – packages by Centos Users 
[contrib] 
name=CentOS-$releasever – Contrib 
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=contrib 
#baseurl=http://mirror.centos.org/centos/$releasever/contrib/$basearch/ 
gpgcheck=1 
enabled=0 
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6 

but lol it still didnt work

it will be usefull if you open you /etc/yum.repos.d/CentOS-Base.repo

and copy whats inside and send it to me

i will be very thanks full to you

Link to post

the info wasnt in that file for me, it was in a file called vz.repo

[vz-base] 
name=vz-base 
mirrorlist=[url=http://vzdownload.swsoft.com/download/mirrors/centos]http://vzdownload.swsoft.com/download/mirrors/centos[/url]-5 
gpgcheck=0 
  
[vz-updates] 
name=vz-updates 
mirrorlist=[url=http://vzdownload.swsoft.com/download/mirrors/updates-released-ce5]http://vzdownload.swsoft.com/download/m ... leased-ce5[/url] 
gpgcheck=0 
  

Link to post

well i edit it and i got this

[root@localhost ~]# yum list ncurses.i386 
Loaded plugins: fastestmirror, refresh-packagekit 
Loading mirror speeds from cached hostfile 
 * centosplus: centos.spd.co.il 
 * epel: mirror.kiewel-online.ch 
 * extras: centos.spd.co.il 
Error: No matching Packages to list 
[root@localhost ~]# 
  

what i do i really need that server!

Link to post

same thing but now look what gives

[root@localhost yum.repos.d]# yum update 
Loaded plugins: fastestmirror, refresh-packagekit 
Determining fastest mirrors 
 * centosplus: centos.spd.co.il 
 * epel: mirror.imt-systems.com 
 * extras: centos.spd.co.il 
vz-base                                                  |  951 B     00:00 
vz-updates                                               |  951 B     00:00 
Setting up Update Process 
Resolving Dependencies 
--> Running transaction check 
---> Package kernel.x86_64 0:2.6.32-71.el6 will be obsoleted 
--> Processing Dependency: kernel >= 2.6.29.1-52.fc11 for package: libdrm-2.4.25-2.el6.x86_64 
--> Processing Dependency: kernel >= 2.6.30 for package: pulseaudio-0.9.21-14.el6_3.x86_64 
--> Processing Dependency: kernel >= 2.6.29.1-52.fc11 for package: libdrm-2.4.25-2.el6.x86_64 
--> Processing Dependency: kernel >= 2.6.30 for package: pulseaudio-0.9.21-14.el6_3.x86_64 
---> Package kernel.x86_64 0:2.6.32-279.19.1.el6 will be obsoleted 
---> Package kernel.x86_64 0:2.6.32-279.19.1.el6.centos.plus will be obsoleted 
---> Package vzdummy-kernel-el5.noarch 0:2.0-1.ce.swsoft will be obsoleting 
--> Running transaction check 
---> Package kernel.x86_64 0:2.6.32-279.14.1.el6.centos.plus will be installed 
--> Processing Conflict: udisks-1.0.1-4.el6.x86_64 conflicts kernel < 2.6.26 
--> Processing Conflict: udisks-1.0.1-4.el6.x86_64 conflicts kernel < 2.6.26 
--> Finished Dependency Resolution 
Error: udisks conflicts with vzdummy-kernel-el5 
 You could try using --skip-broken to work around the problem 
 You could try running: rpm -Va --nofiles --nodigest 
[root@localhost yum.repos.d]# yum install ncurses.i386 
Loaded plugins: fastestmirror, refresh-packagekit 
Loading mirror speeds from cached hostfile 
 * centosplus: centos.spd.co.il 
 * epel: mirror.imt-systems.com 
 * extras: centos.spd.co.il 
Setting up Install Process 
No package ncurses.i386 available. 
Error: Nothing to do 
  

Link to post

aaaaaargh I'm terribly sorry that this is such a messy topic. I am on CentOS 5, you are on CentOS 6. In the vz.repo file, change the fives (5) to sixes (6):

  
[vz-base] 
name=vz-base 
mirrorlist=[url=http://vzdownload.swsoft.com/download/mirrors/centos]http://vzdownload.swsoft.com/download/mirrors/centos[/url]-6 
gpgcheck=0 
  
[vz-updates] 
name=vz-updates 
mirrorlist=[url=http://vzdownload.swsoft.com/download/mirrors/updates-released-ce6]http://vzdownload.swsoft.com/download/m ... leased-ce6[/url] 
gpgcheck=0 
  

Link to post

i tried it

  
[root@localhost ~]# yum install ncurses*i686 
Loaded plugins: fastestmirror, refresh-packagekit 
Loading mirror speeds from cached hostfile 
epel/metalink                                            |  17 kB     00:00 
 * centosplus: centos.spd.co.il 
 * epel: mirror.imt-systems.com 
 * extras: centos.spd.co.il 
base                                                     |  951 B     00:00 
centosplus                                               | 3.5 kB     00:00 
extras                                                   | 3.5 kB     00:00 
updates                                                  |  951 B     00:00 
vz-base                                                  |  951 B     00:00 
vz-updates                                               |  951 B     00:00 
Setting up Install Process 
No package ncurses*i686 available. 
Error: Nothing to do 
[root@localhost ~]# 
  
  

pls give me your skype so can give you root so we can fix this

Link to post

well i tried to install ncurses-devel ncurses manually ,and i had another problem which i think is easy maybe

rpm -Uvh --force ncurses-devel-5.6-7.20070612.fc8.i386.rpm 

but it gives me this

error: Failed dependencies: 
        libform.so.5 is needed by ncurses-devel-5.6-7.20070612.fc8.i386 
        libformw.so.5 is needed by ncurses-devel-5.6-7.20070612.fc8.i386 
        libmenu.so.5 is needed by ncurses-devel-5.6-7.20070612.fc8.i386 
        libmenuw.so.5 is needed by ncurses-devel-5.6-7.20070612.fc8.i386 
        libncurses.so.5 is needed by ncurses-devel-5.6-7.20070612.fc8.i386 
        libncursesw.so.5 is needed by ncurses-devel-5.6-7.20070612.fc8.i386 
        libpanel.so.5 is needed by ncurses-devel-5.6-7.20070612.fc8.i386 
        libpanelw.so.5 is needed by ncurses-devel-5.6-7.20070612.fc8.i386 
        libtic.so.5 is needed by ncurses-devel-5.6-7.20070612.fc8.i386 
        libtinfo.so.5 is needed by ncurses-devel-5.6-7.20070612.fc8.i386 
        ncurses = 5.6-7.20070612.fc8 is needed by ncurses-devel-5.6-7.20070612.fc8.i386 
  

so how can i install all of these to make ncurses-devel work and finally my mta server work !

Link to post

tried it but ! gives this

  
[root@localhost ~]# yum install libncursesw.so.5 
Loaded plugins: fastestmirror, refresh-packagekit 
Loading mirror speeds from cached hostfile 
epel/metalink                                            |  17 kB     00:00 
 * centosplus: mirror.isoc.org.il 
 * epel: mirror.1000mbps.com 
 * extras: mirror.isoc.org.il 
 * rpmforge: archive.cs.uu.nl 
base                                                     |  951 B     00:00 
centosplus                                               | 3.5 kB     00:00 
epel                                                     | 4.3 kB     00:00 
epel/primary_db                                          | 5.0 MB     00:01 
extras                                                   | 3.5 kB     00:00 
rpmforge                                                 | 1.9 kB     00:00 
updates                                                  |  951 B     00:00 
vz-base                                                  |  951 B     00:00 
vz-updates                                               |  951 B     00:00 
Setting up Install Process 
No package libncursesw.so.5 available. 
Error: Nothing to do 
  

Link to post

Sorry to interrupt before a reply, but I don't think ncurses.i386 is available in centos 6

Machine, please show the output from this command:

cat /etc/*release* 

and this one:

yum list ncurses* 

Link to post

i made this and it gives

[root@localhost ~]# cat /etc/*release* 
CentOS release 6.3 (Final) 
cat: /etc/lsb-release.d: Is a directory 
CentOS release 6.3 (Final) 
CentOS release 6.3 (Final) 
cpe:/o:centos:linux:6:GA 
[root@localhost ~]# 
  

and then this!

[root@localhost ~]# yum list ncurses* 
Loaded plugins: fastestmirror, refresh-packagekit 
Loading mirror speeds from cached hostfile 
 * centosplus: mirror.isoc.org.il 
 * epel: mirror.1000mbps.com 
 * extras: mirror.isoc.org.il 
 * rpmforge: archive.cs.uu.nl 
Error: No matching Packages to list 
[root@localhost ~]# 
  

Link to post

It looks like you are missing the base repo for some reason.

Please run this command:

tar cvzf yumfiles.tar.gz /etc/yum* 

Upload the file 'yumfiles.tar.gz' somewhere and give me the link.

Link to post

hello i made everythign and it even download it ,

but when i start server it says

libsqlite3.so.0: cannot open shared object file: No such file or directory 
  
ERROR: Loading mod (/root/mta/multitheftauto_linux-1.3.1/mods/deathmatch/deathma 
tch.so) failed! 
Press Q to shut down the server! 
  

so how to fix this?

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...