Jump to content
  • 0

MTA Crashes due to very specific reasons. HALP!



Ohai there,

Having some troubles, tried fixing it myself by just checking here but, nothing, so, hoping you lot can help.

Been playing for a while now, up until recently MTA has functioned fine, but since a few days ago i have not been able to connect to my "home" server, we've done some tests via "starting/stopping" specific resources and come to the conclusion that it's one particular object we've "replaced" in-game, now, if we leave said resource "stopped", i can play fine, but then upon "starting" the resource again, crash, bam, thank you mam.

The game itself doesn't crash instantly, i can get through server browser, select the specific server, wait for the standard 300kb*-ish to download, so far so good, but then riiiiight at the end of the download/loading sequence, right after the resources/map finishes downloading, crash, bam, thank you mam.

SO! I'm hoping you can help, somehow...

Various things to note:

- I have run MTADiag.exe and provided a pastebin at the bottom of this post, just fyi.

- I believe my video/audio drivers are up to date, though i am not %100 sure.

- I have tried deleting "gtasa/set", to no avail.

- I only noticed this connection issue since connecting to a random server which also had surely replaced certain objects.

- I have since then though, deleted my entire "resources" folder, to allow re-downloading of my "home" servers resources and its resources alone, to no avail.

- I have tried "fresh" installs of both MTA and SA, to no avail.

- I have tried a fresh "gta.img" file, to no avail.

- We have tried manually installing the specific items in my user files to avoid having to load them at all, to no avail.

- I have tried MANY different versions of the MTA installer, from version 1.0 (and updating while connecting), to version 1.3.1 (which requires no update), to the nightly/beta versions (which are simply silly to even try in this situation).

- I'm the only one experiencing the "instant death" crash, but others do crash upon stopping/starting the particular service abruptly.

Any help would be greatly appreciated.

Crash dump:

Version = 1.3.1-release-4793.0.000

Time = Wed Nov 14 22:26:31 2012

Module = C:\Program Files (x86)\Rockstar Games\GTA San Andreas\gta_sa.exe

Code = 0xC0000005

Offset = 0x003F0BF7

EAX=00000000 EBX=0028F158 ECX=20136678 EDX=00000000 ESI=00000000

EDI=20136678 EBP=00000000 ESP=0028F0AC EIP=007F0BF7 FLG=00210246

CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B



Thanks in advance for any assistance :)

- Angel <3

Link to comment

3 answers to this question

Recommended Posts

  • 0

So... we re-exported one of the models that was causing the problem, and that appears to have fixed it. We will do the rest latter today.

Something interesting we found is that a model that used to work (between October 25th and November 8th) now causes crashes for some. Don't know if it's hardware or software, all I know is that it crashes Tephy and atleast 3 other people.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...