Jump to content

MTAVC lags when shooting...


Guest Euphoria

Recommended Posts

Everytime I shoot a machine gun the game lags up totally, but never does it in the one player. Also the level takes a while to catch up (details disappear) now at some points... I have tried re-installing VC and updating to v1.1 but it still does it. Any ideas how to sort this. It never used to do this... :(

Link to comment

Even my PC bogs up sometimes, playing 640x480 w/2xAA8xAF (get high refresh rates... ;)). Its my videocard holding me back and nothing more, but still, it can be quite taxing on a system.

When I stop Prime95 (have it automatically stop when playing MTA:VC), its usually a bit more responsive... so it seems MTA:VC (and perhaps even GTA:VC itself) are prone to having issues when resources are utilized....

Link to comment

Its definatelly not my computer spec: :lol:

AMD Athlon XP3000+

OCZ 512MB PC2700 DDR RAM

nVidia GeForce 4 Ti4200 8xAGP 128MB Graphics

Over 200GBs of Hard Drive

MSI KT4 Ultra Motherboard

Terratec DMX 6 Fire Soundcard

I don't know why it does it. Its only just started doing it since I upgraded my soundcard to the one stated above. I used to use the onboard sound. I have downloaded the latest drivers for it and updated what I can... I'm stuck!

PS

RAM - Random Access Memory

ROM - Read Only Memory

Link to comment

Never heard of that soundcard...

But man, putting your 3000+ through the torture of a VIA chipset! Shame!

Get a Soltek N64-400 or whatever the hell that model is :P less than $80, no need for two sticks of RAM, quite stable, and though the audio isn't the greatest, it hardly hits the CPU and beats out whats on your current board.

Link to comment
Its only just started doing it since I upgraded my soundcard to the one stated above. I used to use the onboard sound.

Then u got it dude !

knowin' this u can :

- try to disable your onboard soundchipset if not already done

- try to adjust sound options in gta:vc (try to not play with EAX or things like that)

- format and reinstall windows without your soundchip but with your new soundcard and believe in God (this solution definitly not for me)

- use your new sound card when doing something else / use the onboard soundchip to play mta:vc (not for me too, but fun :D)

Link to comment

The problem is certainly with your soundcard, as DeLuXxX said. The only thing I can add is that you pull all of your other peripherals out after you disable the onboard sound, so that the Terratec has the PCI bus all to itself (aside from HDs of course).

A $200 soundcard should have pretty dang good hardware audio processing, so your problem isn't the soundcard sucking, you just need to get your configuration to play nice.

Link to comment

I've formatted my computer and downloaded MTA again... same problem. I will emable my onboard sound again as I disabled it in the BIOS and see if it plays well through that. Will let you all know in a bit! Cheers for all the help guys :D

Link to comment

Soundz like your've got an ASIO card or something similar. The DSP on the cards proberbly doesn't like directX too much. Check the driver. Don't install the one from CD. Download a new one from their website (URL proberbly printed in the manual or on the box). 99% chance there is a driver update/fix. Read the manual does it say anything at all about DirectX? You could also try and reduce hardware acceleration for the soundcard. (Control panel/sounds and multimedia devices) I've had problems with my soundcard lagging me to the max.

This is how I fixed it...(bare with me it was ages ago, so I'm doing my best to remember...)

I swapped the soundcard to the first PCI slot (furthest away from videocard) updated EVERY driver and DirectX on my machine. (I like to know that any old OEM driver bugs are gone from my machine). I then reset the DMI pool in my bios. (I'm pretty sure this is all I had to do to stop the soundcard lagging my machine)

Basically this is what's happening to you... You've got a $$$ soundcard. Chances are that it has a pretty good cpu/DSP on it. This CPU uses your PCI bus to send the data. LOT'S OF DATA! Basically it's overloading your PCI bus with data and the rest of your machine has to catch up. I did look at your system specs and yes this even happens to the fastest of machines. Check your soundcards manufactures website for any fixes for this lag...

When you formatted and reinstalled did you install the chipset drivers for your motherboard? Most people don't do this. (tsk, tsk...) You're motherboard has to know how to efficiently talk to it's own components. It's best when You start reinstalling to take all the bits out of your machine and install them one by one wilst installing each driver as you go.

Be greatfull it's not a creative audigy. Those things are bitches to get working correctly...

You could also try and choose the most crap sound option in GTAVC and see if that helps...

I've run out of time, if I remember anymore I'll post it for ya...

Link to comment

I did install my motherboard drivers again when I re-did everything, so every driver on my computer has the correct settings! I downloaded the newest drivers for my soundcard and graphics card, and I have downloaded ALL of the windows xp pro updates which included new graphics card drivers and the very latest versions of directx. I also updated my BIOS not so long ago! I did a test yesterday and installed my onboard sound again... the game worked perfectly! And when I used the worst settings with my new soundcard the game worked perfectly but the sound was aweful or non-existant.

This is VERY frustrating!

Link to comment

Try to disable (or lower) hardware accelleration for the soundcard, then in gta vc sound options, select the simplest playback. You should then at least hear the apropriate sounds, but they're not processed to reflect the surroundings. Hope it helps you.

Link to comment
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...