Jump to content

Windows 98 compatibility!


Guest rglaf

Recommended Posts

What about making Windows 98SE compatible in the next version? I bet there is alot of people who would be more than happy to see this included in the next version - included me! :roll:

Link to comment
win98 sux !

viva win2k & xp !

if you can run gta on your computer, you probably could run win2k :):idea:

:arrow: less bugs

:arrow: less win98 crap

= g00d stuff !

Of course, but that's not what I asked about... I will not change OS (for personal reasons)... So, if anyone of the programmers would take the job, you will at least get one satisfied user! :D

Link to comment
win98 sux !

viva win2k & xp !

All Windows sux!

if you can run gta on your computer, you probably could run LINUX! :):idea:

:arrow: less bugs

:arrow: less win98 / win2k / winxp crap

= g00d stuff

:twisted:

Link to comment
  • MTA Team

Win 9x compatibility is not easy to do. Since Winçx handles memory completly differently then Win 2k/Xp. Due to the fact the software is incompatible we also have used other things that are not compaitble with Win9x making comaptibility even less possible.

Win9x is used by a minority of the MTA site visitors and the chance we make it comaptible is small att the moment

Link to comment

he said he wont change for personal reasons...

win9x compatibility wont happen by wat blokker said. it will take alot of work to make it compatible and the devs prolly think that its not worth the time due to little demand. you either have to upgrade your os, or, sacrifice mta

Link to comment
  • 2 weeks later...

I can understand Windows 98 users are in the minority, even more so on a board for a game it's not compatible with. ;)

Seems there is some strange logic used on these boards though. If we can run VC we can run XP? VC runs on windows 98, every single game or product I have recently bought has worked on 98. So why would I update? If it isn't broke, don't fix it. So I think I can do without MTA, I'm just dissappointed with the attitude displayed.

It is understandable for the current version of MTA to be incompatable, but I am rather dissapointed to hear there are no plans of making it so. It is though, the developers own time, and I can understand their unwillingness to devote that time to a minority.

It looks like the developers have done a good job (apart ofcourse, from the compatibility issues ;) ), this is directed at the, usually almost incoherant posts of XP users who fail to understand that windows 98 is an incredibly stable OS, atleast in my experience, and that upgrading purely so that we can play a buggy (yes, it's beta, it will have bugs) beta program is a ridiculous idea.

Maybe I'll upgrade when proffesional developers start to limit their player base.

Link to comment
So why would I update? If it isn't broke, don't fix it.

wrong!! windows98 IS broke, even though u dont notice, theres alot of bugs that havent been discovered.

also, its not just mta that is not compatible w/ 9x. theres alot of programs that only work on nt based os's. hell, ati is slowly not supporting win9x. thats only 1 to name out of alot. getting atleast 2000 is a wise decision of you use your computer alot.if not, well then your sol.

and, to some people windows9x is amazingly stable. hell, i can get this winme machine running for 4 weeks straight. but theres another side to the broken windows 9x. memory leaks, yes, thats y u have to restart every so often to keep maximum preformance. but wtvr, i dont use ur computer so i dont know how it operates

Link to comment
  • MTA Team

Since a couple of weeks microsoft has suspended all support for Windows 98, this means that no patches will come out anymore (not even for critical errors). On January the first this will also happen for Windows Me.

Despite what Win98 users think, Win98 isn't stable, at least not anymore. Due to the new software that is optimised for the NT based operating systems (2000, XP, 2003, LongHorn, ...) the stability of 9x gets compromised.

Also a lot of 9x users seem to think that that the majority of people still uses 9x, which is not the case. Most people with newer hardware use a newer operating system since that operating system is more optimised for there hardware and therefore makes the system more stable and faster.

When we look at compatibility for Windows 9x we see that more and more developers are dropping the compatibility. When you surf the net you see that a lot of small software projects have problems keeping there software compatible. Even Microsoft itself has now dumped 9x. Office 2003 requires Windows 2000 SP3 or higher. The game firestarter that has gone gold 2 days ago also does not support 9x. This only shows that compatibility is becoming more and more of a problem.

We do look into the compatibility when we are tired of looking at all the numbers are all those e-mails. And we do make some small progress. It is not that we have given up on it, it is just not top priority.

Link to comment

I remember about 2 years ago, all my pcs ran 98, mainly because i was afraid of incompatibility of nt, and my 98 software. Well, now i swear by win2k pro, and the ONLY problem i've had is viper racing doesn't run on nt...but who the hell care when you have vice mulitplayer lmao. I don't know how much 2kpro costs, but it's easy to , er , get it free ;x

Link to comment
  • 3 weeks later...

Hey all,

I feel Windows 98 should be supported. I run both 98 and 2000. I know 98 is a old OS and MS is dropping or has dropped support for it. But it works well for alot of people.

All my systems run 98/2k dual boot, before only my main machine did. But since usually every friday i have a gaming session, which my friends bring there own system most of the time. But since there's those times where they don't, i put 2k on the other 2 machines just for this mod.

Also another reason I feel it should be supported is because well the game supports it. Supported OS's for the game are: 98 and 98SE, ME, 2000 Pro Sp3+, XP Home and Pro. 95 and NT aren't supported. I believe if the game supports those OS's then mods should as well. Thats just my opinion.

Well thats all for now.

Link to comment

Hey SKnight did you just skip to the second page or just ignore this post :

Win 9x compatibility is not easy to do. Since Winçx handles memory completly differently then Win 2k/Xp. Due to the fact the software is incompatible we also have used other things that are not compaitble with Win9x making comaptibility even less possible.

Win9x is used by a minority of the MTA site visitors and the chance we make it comaptible is small att the moment

(it was on the first page of this topic)

Its not that they dont want to make it 98/me compatible its just because they cant.

Link to comment
  • 1 month later...

Well on my servers/ important comps i have Windows 98 running simply for the reason that it supports hardrive mirroring. Windows 2k does not, i donno about xp. Windows 98 support would be great but you gotta understand these guys do this stuff for free, and use most if not all there free time doing it. If they dont wanna use even more free time just to satisfy the minority i dont blame them one bit.

Link to comment
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...