Jump to content
  • 0

Running MTA 1.3 on Ubuntu 12.04


Evel

Question

Recently, I made the switch to Ubuntu from Windows, as Windows was causing a whole world of trouble. Now I'd like to get MTA 1.3 working. I've heard a number of people have managed to get it working, but mine will not function for some reason.

I installed it under Wine v1.4, but on startup, a grey box appears, then it closes and nothing starts. I have tried a number of solutions, in no particular order:

-Installing DirectX files through Winetricks (No d3d9.dll in the SA folder however)

-Installing allfonts through Winetricks

-Running MTADiag (Through Wine, it updated MTA)

-Deleting the gta_sa.set

-Installing C++ 2010, 2008, and 2005 through Winetricks (However, I got an error at the end of one of their installations saying that a .dll file was not found)

-Running Wine in Windows XP, Vista and 7 mode, as well as Virtual Desktop mode

Singleplayer works just fine, as does SA:MP 0.3d R2. I'm running on Ubuntu 12.04 64-bit with the latest updates. And my computer specs, if at all important, are as follows:

CPU: Intel i7 2600K (Overclocked @ 4.2GHz)

GFX: NVIDIA GTX 560 Ti 1GB

Motherboard: MSI Z68A-GD55 (B3)

RAM: 8GB DDR3

Perhaps I'm missing some Winetricks add-ons? Maybe one of them didn't install properly? Any advice would be appreciated, thanks in advance!

Edit: If it helps, I tried running MTA through Terminal in the main folder with the command "wine MultiTheftAuto.exe" and I got this error:

  
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub! 
fixme:wbemprox:wbem_locator_ConnectServer 0x13f200, L"ROOT\\CIMV2", (null), (null), (null), 0x00000000, (null), (nil), 0x32f880) 
err:module:LdrInitializeThunk Main exe initialization for L"Z:\\media\\531C1353E752EF64\\Games\\GTA San Andreas\\gta_sa.exe" failed, status c0000022 

Link to post

Recommended Posts

  • 0

Created wineprefix as win32, installed that vc2008 through winetricks - got no errors.

Installed GTA SA, got no errors.

Then installed MTA and it required that vc2008 thing during the installation, though it's installed, lol.

Installed it too, got no errors again.

But when trying to run MTA, still get that 22 error code.

Wanted to see some people connected with the development opinions, but as I see they're not really interested in supporting Linux players.

Should we report to MTA bugtracker?..

Okay, reported!

http://bugs.mtasa.com/view.php?id=7040

Link to post
  • 0
Created wineprefix as win32, installed that vc2008 through winetricks - got no errors.

Installed GTA SA, got no errors.

Then installed MTA and it required that vc2008 thing during the installation, though it's installed, lol.

Installed it too, got no errors again.

But when trying to run MTA, still get that 22 error code.

Wanted to see some people connected with the development opinions, but as I see they're not really interested in supporting Linux players.

Should we report to MTA bugtracker?..

Okay, reported!

http://bugs.mtasa.com/view.php?id=7040

Looking through the bug report, as well as your thread, it seems that this bug has something to do with Ubuntu 12.04. Perhaps this is worth posting on the Ubuntu forums?

Link to post
  • 0
  • MTA Team

It is a bug in Ubuntu 12.04 or it's version of wine (1.4). See https://bugs.launchpad.net/ubuntu/+sour ... bug/978678

You can work around it by issueing the following command on the console:

echo 0|sudo tee /proc/sys/kernel/yama/ptrace_scope 

Please note that this is a temporary workaround and that the Ubuntu dev team needs to come up with a real fix.

Link to post
  • 0
It is a bug in Ubuntu 12.04 or it's version of wine (1.4). See https://bugs.launchpad.net/ubuntu/+sour ... bug/978678

You can work around it by issueing the following command on the console:

echo 0|sudo tee /proc/sys/kernel/yama/ptrace_scope 

Please note that this is a temporary workaround and that the Ubuntu dev team needs to come up with a real fix.

Great, the command fixed it. Thanks a bunch!

Link to post
  • 0
  • MTA Team

I have to add a small warning. Basicly what you do by issueing that command is disabling a small safety feature that Ubuntu (badly?) implemented. It makes it possible for one process to manipulate the memory of another process (basicly what MTA does and probably why it crashes). From what I understand Ubuntu, with this setting, wants to prevent one process from fidling with another if they are unrelated but somehow it gets messed up.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...