Sign in to follow this  

MTA 1.3 won't start on Ubuntu 12.04

Recommended Posts

Hello :)

After update to 12.04 from 11.10 MTA installation broke :|

Singleplayer works, when running from the console I get some weird error codes.

nikita@nikita-EP43-S3L:~$ cd .wine/drive_c/Program\ Files/MTA\ San\ Andreas\ 1.3/ 
nikita@nikita-EP43-S3L:~/.wine/drive_c/Program Files/MTA San Andreas 1.3$ wine Multi\ Theft\ Auto.exe 
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub! 
fixme:wbemprox:wbem_locator_ConnectServer 0x145c18, L"ROOT\\CIMV2", (null), (null), (null), 0x00000000, (null), (nil), 0x32f880) 
err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\Rockstar Games\\GTA San Andreas\\gta_sa.exe" failed, status c0000022 

Necessary fonts are installed.

cegui.log in MTA San Andreas/MTA doesn't exist, so I can't get what's wrong.

Maybe some people would be able to help me so that's I'm writing this post.


The solution seems to be found by Blokker_1999!

Edited by Guest

Share this post

Link to post

Heh, Ubuntu isn't the best OS to play executable games, over all MTA, isn't there any Windows compatibility mode in Ubuntu?

Share this post

Link to post

Well, the only way to play games there is through 'Wine', so that's what I do.

And what's more - I reinstalled the OS, to make the installation 'fresh', but it's all the same - singleplayer works, MTA doesn't.

Sad :S

Share this post

Link to post

Already checked this, that's why I wrote that I have no log file.

Fonts are installed, of course.

Created win32 prefix for wine, but mta still doesn't want to start.

MTA Server starts w/o any problem.

Share this post

Link to post

Perhaps something with the visual C++ redists?

I remember having issues with those using wine..

Share this post

Link to post

Some time ago I had problems with them too, but there were some debug messages telling me which library causes the problem.

I had no such messages neither in the installation process, not when running MTA.

Also tried installing all the redists through winetricks but that has no effect.

I'm still able to play singleplayer, even GTA IV, lol, but not MTA.

Now I'll try to find older versions and try to run them.

1.1 crashes in the same way.

1.0.4 crashes too, but differently.

Just says "fixme:advapi:SetSecurityInfo stub" and then processes of gta/mta hang.

[DEBUG EVENT] 04-29-2012 @ 12:01:35 # CCommands::CCommands 
[DEBUG EVENT] 04-29-2012 @ 12:01:35 # CCore::CCore 
[DEBUG EVENT] 04-29-2012 @ 12:01:35 # CDirect3DHookManager::CDirect3DHookManager 
[DEBUG EVENT] 04-29-2012 @ 12:01:35 # CDirectInputHookManager::CDirectInputHookManager 
[DEBUG EVENT] 04-29-2012 @ 12:01:35 # CMessageLoopHook::CMessageLoopHook 
[DEBUG EVENT] 04-29-2012 @ 12:01:35 # CSetCursorPosHook::CSetCursorPosHook 
[DEBUG EVENT] 04-29-2012 @ 12:01:35 # CDirectInputHook8::CDirectInputHook8 
[DEBUG EVENT] 04-29-2012 @ 12:01:35 # CDirect3DHook9::CDirect3DHook9 
[DEBUG EVENT] 04-29-2012 @ 12:01:35 # Direct3D9 hook applied 

Found another guy who has the same issue.

P.S. I guess, the conversation moved here viewtopic.php?f=104&t=42805

Share this post

Link to post

There are more issues with Ubuntu 12.04

Share this post

Link to post

It is a bug in Ubuntu 12.04 or it's version of wine (1.4). See ... bug/978678

You can work around it by issueing the following command on the console:

echo 0|sudo tee /proc/sys/kernel/yama/ptrace_scope 

Please note that this is a temporary workaround and that the Ubuntu dev team needs to come up with a real fix.

Share this post

Link to post

Has this bug been fixed?

Edited by Guest

Share this post

Link to post
This bug has been fixed?

Bug are still present on Ubuntu 14.04 LTS & Wine 1.4 & MTA 1.4.0, but fix from Blokker_1999 works.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.