Jump to content

Failure detecting version of Vice City.


Recommended Posts

FDR Wrote:

It must be the australian version problem they mentioned in the FAQ. Mine doesnt work either, & you guys who cant get it to work are from aust too. Same problem. Dissapointing...

The previous version gave me the unhaldled exception error, and this one gives me the version error. yey

That makes 2 of us! Can somone send me a quickmessage if they stumble across a patch for the Australian version pls.

-Yes, my game is legit

-No, I do not use a no-cd

FDR Wrote:

Are u talkin GTA 3? yea it is edited, but you can just change ur regional settings to US and you can pick up prostitutes

Message me if this works for Vice City, I'll try 2... :) Thanx

Link to post
  • Replies 93
  • Created
  • Last Reply

Top Posters In This Topic

The dll relies on checking specific data in the gta-vc.exe executable in order to automatically detect and use the correct memory addresses to interface the game. I was not aware that there was a separate executable for australians. In order to work out a fix i'd need to pull information out of the 1.0 and 1.1 australian executables.


aka slush

Link to post

Alright, we are going to try and debug the australian exe, but we need a copy of it.

Can someone that is having this problem zip up there exe and send it to cray@multitheftauto.com ? In the email, please state what language you have, whether it actually is the australian version or not and we will start to look at it and see what is actually happening.

I will reply here once I receive an email.

Link to post

G'day (just assusring u I have the aussie version of VC :wink: ) hey can a moderator (cray?) make a new thread (is that the term, or is it topic, go n00bs!) in the bugs section (thats a thread isnt it :D ). cause we need a central talking place for australians, as now suggestions and complaints are spread across many topics). Oh, and I finally realised why 1.1 patch didnt work, whover sad that 8)

Link to post

First off, we will be releasing a .AU Patch within a few minutes that will replace the DLL that you have downloaded with the original installation.

It should allow for .AU users to use MTA, lets hope.

Second, I will move this thread to the Problems and Bugs forum, which is where it should actually be.

Link to post
Alright, check the Problems & Bugs forum for a Unhandled Exception on Start Game.

You are now experiencing a different problem, which you should be able to solve by reading that thread.

I tried all of those possible Fixes, that were in that Thread, none of them worked! I don't know where it Situates, but I know that it's not a different Problem. I also received this Error Message after the Exception.


I Use Orignal exe. Not a Nocd Crack! I'll wait and see if any other people are experiencing this.

Link to post

From my initial testing (5 minutes tonight), it seems that the memory is once again different in this version of the exe (which means a lot of memory searching on our parts).

For my own interests, is this 1.0 or 1.1? It definitely seems like a cracked version, but what version of the game I must ask ....

Link to post

It's a modified 1.0. When I tryed to Install 1.1, it said, "this program cannot update the installed version of Gta:ViceCity because of the following reason: gta-vc.exe: unknown version. I have no idea what's different in the Australian Game of VC. I know in the Australian version of GTA III, your not allowed to pick up Prostitutes. But Changing the Regional Settings to US, some people said that it enabled Prostitutes, (I haven't tryed personally), Does VC have that? Other things must of been been changed, though it's a mystery of what?

Link to post

Hmm. Well a noCD [patch i shouldnt have - xerox], appears to work with the .AU patch, to some extent. Alot of problems! Many Exceptions at different locations. Very Random. other problems. Could there be a way to create a Patch that actually fixes the problem with the Original exe, because it kind of works with the noCD exe. Weird

Edited by Guest
Link to post
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...