DazzaJay

.\CRenderWareSA.cpp Crash on Join of server / loading editor

Recommended Posts

11crash.jpg

I have followed Towncivilian's instructions here: http://forum.multitheftauto.com/viewtop ... 78be830855

And none of which solve the issue :-(

(no d3d9.dll in game folder, deleting .set file did nothing, directX installer said up to date or newer already installed, and am using latest patch that he linked.)

------------------ 
System Information
------------------
Time of this report: 9/3/2011, 19:44:07
       Machine name: DAZZAJAY
   Operating System: Windows XP Professional x64 Edition (5.2, Build 3790) Service Pack 1 (3790.srv03_sp1_rtm.050324-1447)
           Language: English (Regional Setting: English)
System Manufacturer: Gigabyte Technology Co., Ltd.
       System Model: GA-790FXTA-UD5
               BIOS: Default System BIOS
          Processor: AMD Phenom(tm) II X4 965 Processor (4 CPUs), ~3.4GHz
             Memory: 6142MB RAM
          Page File: 2301MB used, 5488MB available
        Windows Dir: C:\WINDOWS
    DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
     DxDiag Version: 5.03.3790.1830 32bit Unicode
 
------------
DxDiag Notes
------------
  DirectX Files Tab: No problems found.
      Display Tab 1: No problems found.
        Sound Tab 1: No problems found.
          Music Tab: No problems found.
          Input Tab: No problems found.
        Network Tab: No problems found.
 
--------------------
DirectX Debug Levels
--------------------
Direct3D:    0/4 (n/a)
DirectDraw:  0/4 (retail)
DirectInput: 0/5 (n/a)
DirectMusic: 0/5 (n/a)
DirectPlay:  0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow:  0/6 (retail)
 
---------------
Display Devices
---------------
        Card name: ATI Radeon HD 4800 Series        
     Manufacturer: ATI Technologies Inc.
        Chip type: ATI Radeon Graphics Processor (0x9442)
         DAC type: Internal DAC(400MHz)
       Device Key: Enum\PCI\VEN_1002&DEV_9442&SUBSYS_E810174B&REV_00
   Display Memory: 512.0 MB
     Current Mode: 1280 x 1024 (32 bit) (60Hz)
          Monitor: Plug and Play Monitor
  Monitor Max Res: 1600,1200
      Driver Name: ati2dvag.dll
   Driver Version: 6.14.0010.7171 (English)
      DDI Version: 9 (or higher)
Driver Attributes: Final Retail
 Driver Date/Size: 3/9/2011 14:48:00, 507392 bytes
      WHQL Logo'd: n/a
  WHQL Date Stamp: n/a
              VDD: n/a
         Mini VDD: ati2mtag.sys
    Mini VDD Date: 3/9/2011 19:14:18, 7881216 bytes
Device Identifier: {D7B71EE2-D702-11CF-F868-1AC8A1C2CB35}
        Vendor ID: 0x1002
        Device ID: 0x9442
        SubSys ID: 0xE810174B
      Revision ID: 0x0000
      Revision ID: 0x0000
      Video Accel: ModeMPEG2_C ModeMPEG2_D
 Deinterlace Caps: {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
                   {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
                   {3C5323C1-6FB7-44F5-9081-056BF2EE449D}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
                   {552C0DAD-CCBC-420B-83C8-74943CF9F1A6}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
                   {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
         Registry: OK
     DDraw Status: Enabled
       D3D Status: Enabled
       AGP Status: Enabled
DDraw Test Result: Not run
 D3D7 Test Result: Not run
 D3D8 Test Result: Not run
 D3D9 Test Result: Not run
 
-------------
Sound Devices
-------------
            Description: Realtek HD Audio output
 Default Sound Playback: Yes
 Default Voice Playback: Yes
            Hardware ID: HDAUDIO\FUNC_01&VEN_10EC&DEV_0889&SUBSYS_1458A102&REV_1000
        Manufacturer ID: 1
             Product ID: 100
                   Type: WDM
            Driver Name: RTKHDA64.SYS
         Driver Version: 5.10.0000.5964 (English)
      Driver Attributes: Final Retail
            WHQL Logo'd: n/a
          Date and Size: 10/22/2009 00:29:02, 5628928 bytes
            Other Files:
        Driver Provider: Realtek Semiconductor Corp.
         HW Accel Level: Full
              Cap Flags: 0xF5F
    Min/Max Sample Rate: 8000, 192000
Static/Strm HW Mix Bufs: 33, 32
 Static/Strm HW 3D Bufs: 33, 32
              HW Memory: 0
       Voice Management: No
 EAX(tm) 2.0 Listen/Src: Yes, Yes
   I3DL2(tm) Listen/Src: Yes, Yes
Sensaura(tm) ZoomFX(tm): No
               Registry: OK
      Sound Test Result: Not run
 
---------------------
Sound Capture Devices
---------------------
            Description: Realtek HD Audio Input
  Default Sound Capture: Yes
  Default Voice Capture: Yes
            Driver Name: RTKHDA64.SYS
         Driver Version: 5.10.0000.5964 (English)
      Driver Attributes: Final Retail
          Date and Size: 10/22/2009 00:29:02, 5628928 bytes
              Cap Flags: 0x41
           Format Flags: 0xFFF
 
            Description: Realtek HD Digital input
  Default Sound Capture: No
  Default Voice Capture: No
            Driver Name: RTKHDA64.SYS
         Driver Version: 5.10.0000.5964 (English)
      Driver Attributes: Final Retail
          Date and Size: 10/22/2009 00:29:02, 5628928 bytes
              Cap Flags: 0x41
           Format Flags: 0xFFF
 
-----------
DirectMusic
-----------
        DLS Path: C:\WINDOWS\SYSTEM32\drivers\etc\GM.DLS
     DLS Version: 1.00.0016.0002
    Acceleration: n/a
           Ports: Microsoft Synthesizer, Software (Not Kernel Mode), Output, DLS, Internal, Default Port
                  Microsoft MIDI Mapper [Emulated], Hardware (Not Kernel Mode), Output, No DLS, Internal
                  Microsoft GS Wavetable SW Synth [Emulated], Hardware (Not Kernel Mode), Output, No DLS, Internal
        Registry: OK
     Test Result: Not run
 
-------------------
DirectInput Devices
-------------------
      Device Name: Mouse
         Attached: 1
    Controller ID: n/a
Vendor/Product ID: n/a
        FF Driver: n/a
 
      Device Name: Keyboard
         Attached: 1
    Controller ID: n/a
Vendor/Product ID: n/a
        FF Driver: n/a
 
      Device Name: USB Gaming Mouse
         Attached: 1
    Controller ID: 0x0
Vendor/Product ID: 0x046D, 0xC042
        FF Driver: n/a
 
      Device Name: USB Gaming Mouse
         Attached: 1
    Controller ID: 0x0
Vendor/Product ID: 0x046D, 0xC042
        FF Driver: n/a
 
      Device Name: Logitech Gaming Keyboard
         Attached: 1
    Controller ID: 0x0
Vendor/Product ID: 0x046D, 0xC221
        FF Driver: n/a
 
      Device Name: Logitech Gaming Keyboard
         Attached: 1
    Controller ID: 0x0
Vendor/Product ID: 0x046D, 0xC221
        FF Driver: n/a
 
      Device Name: G15 Keyboard
         Attached: 1
    Controller ID: 0x0
Vendor/Product ID: 0x046D, 0xC222
        FF Driver: n/a
 
Poll w/ Interrupt: No
         Registry: OK
 
-----------
USB Devices
-----------
+ USB Root Hub
| Vendor/Product ID: 0x1002, 0x4399
| Matching Device ID: usb\root_hub
| Service: usbhub
 
----------------
Gameport Devices
----------------
 
------------
PS/2 Devices
------------
+ HID Keyboard Device
| Vendor/Product ID: 0x046D, 0xC221
| Matching Device ID: hid_device_system_keyboard
| Service: kbdhid
|
+ HID Keyboard Device
| Vendor/Product ID: 0x046D, 0xC222
| Matching Device ID: hid_device_system_keyboard
| Service: kbdhid
|
+ HID Keyboard Device
| Vendor/Product ID: 0x046D, 0xC232
| Matching Device ID: hid_device_system_keyboard
| Service: kbdhid
|
+ Terminal Server Keyboard Driver
| Matching Device ID: root\rdp_kbd
| Upper Filters: kbdclass
| Service: TermDD
|
+ Logitech HID-compliant G3 Laser Mouse
| Vendor/Product ID: 0x046D, 0xC042
| Matching Device ID: hid\vid_046d&pid_c042&mi_00
| Upper Filters: LMouFilt
| Lower Filters: LHidFilt
| Service: mouhid
|
+ HID-compliant mouse
| Vendor/Product ID: 0x046D, 0xC231
| Matching Device ID: hid_device_system_mouse
| Service: mouhid
|
+ Terminal Server Mouse Driver
| Matching Device ID: root\rdp_mou
| Upper Filters: mouclass
| Service: TermDD
 
----------------------------
DirectPlay Service Providers

Share this post


Link to post

Do you get a crash dump with this? If you hit abort, i'm guessing it crashes with one? Also, does your MTA work on maps without custom textures (I'm assuming this happens when a custom texture is loaded)

Share this post


Link to post

Abort, Retry, Ignore, MTA closes with all 3 and no dump is written.

Benji has suggested that it could be my road textures. (in my forums)

Assertions are programmer-intended graceful crashes to prevent more difficult-to-determine faults down the line. Someone specifically told the program to crash if that condition failed.

It's not an issue with hardware drivers.

Now I don't know what m_UniqueTexInfoMap is, (and I doubt it's a strUniqueKey generation failure) but it sounds to me like a problem with the base SA data. I would try re-installing SA.

Maybe modifying the gta3.img is causing it if you have the PHATT Pack still installed. I know 1.1 added in more file modification checking.

So I will remove my Epic roads and HD Guns :-( and give it a shot on a blank install. will reply back if its fixed afterwoods.

========================================

Looks like i'm not the only one with this problem, this person asked Microsoft, and needless to say they were... useless.

http://answers.microsoft.com/en-us/wind ... d6ff7fd392

Read it to lol at MS's responce about "Internet Explorer"

Share this post


Link to post

Actually, GTA directory & files must be completely clean with no mods for an optimized and unlimited gaming.

Well, there are such allowed mods like SRT 3 or ENBSeries that should work properly.

Share this post


Link to post

Confirmed, Reinstalled GTA SA from the disc and now it works. I will experiment with the gta3.img file and tell what does it.

:::EDIT:::

Confirmed Working

GTA San Andreas\models\generic\vehicles.txd editing works fine. (Not the cause, Trying something else)

Blacktop Roads (TXD Change) (Not the Cause)

Admin Paintjobs (TXD change) (not the cause)

:::EDIT:::

Possible Causes

Yep, changed out my gta3.img with the old one, and sure enough same error. so its deffinatly a change in my gta3.img

only had 5 specific changes done to it.

Better Reflections on cars (Probably the cause, involved changing EVERY cars .dff file with ones that had edited reflection maps)

SPC Wheelpack (.dff change)

and then the hi poly guns, also a .dff change. (Not visible in image)

id=46.html

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.