Jump to content

[REL] Stage 1.5.0 - virtual actors and camera workshop


vovo4ka

Recommended Posts

  • Replies 152
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I wondered about creating a movie, but the freecam resource by itself wouldn’t suffice. I made this resource to help moviemakers to make more cinematic camera effects and help with actors. There are

Sorry for the bump. Just wanted to commend this tool for San Andreas machinima directors. I made a more recent tutorial with voice commentary. I'm guessing this tool is no longer further

Good idea : Do you can add a function to reccord with this tool your race before playing it, so when you begin a race you need to wait for the other players, but this fuction will replace the waiting for other players and with it you can see what the track (your race or map) look like before playing it in a custom reccording with this tool like the replays in Track mania, thats could be very nice with music and all the stuff this tool have. :wink:

Link to post

the ping will go up ? if that is not a video file, but just a recording position like the replay in gta solo, the ping will go up too?, (like the replay in gta solo) maybe im wrong. but look this resource : http://community.mtasa.com/index.php?p= ... ils&id=665

its a ghost of the player so its a recording position and movement of the player maybe we can do that with a camera and not with a car.

Link to post
@jjsullivan: You don't need to quote all LONG post :o

@benox583: And ping will increase about 100ms when playing xD

Uhh that wasn't the point, it was the correct grammer translation that vovo4ka requested....now a mod thought it was a copy-pasta quote and removed it....

Link to post
@jjsullivan: You don't need to quote all LONG post :o

@benox583: And ping will increase about 100ms when playing xD

Uhh that wasn't the point, it was the correct grammer translation that vovo4ka requested....now a mod thought it was a copy-pasta quote and removed it....

OMG :shock::shock::shock::shock::shock::shock:

:oops::oops::oops::oops: I missed..

Link to post
@jjsullivan: You don't need to quote all LONG post :o

@benox583: And ping will increase about 100ms when playing xD

Uhh that wasn't the point, it was the correct grammer translation that vovo4ka requested....now a mod thought it was a copy-pasta quote and removed it....

OMG :shock::shock::shock::shock::shock::shock:

:oops::oops::oops::oops: I missed..

Haha, no problem, your welcome.

Peds as actors

The experimental part of this resource is Player Motion Capture

After beginning recording your motions captured and stopping the recording- the ped can repeat(try to repeat ) your movement and actions. Ped synchronization is very bad in this version of MTA but it will be suitable for simple movement.

whoops, one more tiny thing

Edited by Guest
Link to post
benox583, sorry I don't understand your idea. You want to record camera movement across race track?

yes is that, see an example and its an MTA race :shock:

so the players see the map before playing it in a custom recording and after the race or map begin (you begin to play).

its just an idea, because its a lot of work,

just think about the sync. :|

Link to post
If it works bad, pls tell me too

ehm first question, ive added this too my resources and started it... it says it doesnt has a meta.xml file for it.... and the resource wont work? please tell me how to activate because i dont seem to find the answer anywhere.

EDIT: nevermind, i was really stupid not too unpack but straightly put the map in the resource folder.... my bad :oops:

EDIT2: ok i wanted to give myself admin privileges, but editing the acl just made server crash, and now i have to reinstall mta... plz, can you add a file where all privileges are already addes so it wont crash?

Link to post

thx it works now! gonna try it! :D

EDIT: ok i thought it worked, it clearly doesnt, even with your new acl, even when i edited it, it doesnt work! i just cant get the admin rights, and i also forgot how to create a account xD

Edited by Guest
Link to post

It's easy. I just tuned Freecam mode settings (reduce mouse sensivity and acceleration/deceleration values made more slow)

Also I love foto shooting and video. Maybe I have abilities in this area :oops:

Stage is not guarantee succes of your videos. It just gives you a powerfull (maybe not so :P ) tools for moviemaking in gta:sa

This short demo is just only cutscenes compilation from my new machinima. This is beginning of movie, but final version of this episode should be much shorter, I think.

Suggestion: What about making this a cutscene for a mission resource? That would be really cool!

Oh yes it would be nice! But I don't know what I should do :oops:

Link to post
  • 2 weeks later...

Hi.. I got problems with Stage resource..

I start my server (my map is already loaded - selected in resources menu on Host Game option), login as director and try to record a person driving a car. I record - everything is fine. But when record is over, I see bot standing in the position vehicle should be. I press play and... MTA starts freezing (unfreezes ~every 5seconds and after second freezes again), map objects and vehicles gets to player screen (I mean every object and vehicle moves to my screen so I can see whole map's objects) and after some work with it, I can make it stable again and here's what's in console:

[00:10:16] WARNING: stage\server.lua:631: Bad 'vehicle' pointer @ 'warpPedIntoVehicle'(2)

[00:10:19] WARNING: stage\server.lua:631: Bad 'vehicle' pointer @ 'warpPedIntoVehicle'(2)

[00:10:23] WARNING: stage\server.lua:631: Bad 'vehicle' pointer @ 'warpPedIntoVehicle'(2)

[00:10:23] WARNING: stage\server.lua:631: Bad 'vehicle' pointer @ 'warpPedIntoVehicle'(2)

I use latest MTA, latest Stage (1.4.0), latest resources.. What is wrong then?

EDIT: I made a video:

Link to post
Hi.. I got problems with Stage resource..

I start my server (my map is already loaded - selected in resources menu on Host Game option), login as director and try to record a person driving a car. I record - everything is fine. But when record is over, I see bot standing in the position vehicle should be. I press play and... MTA starts freezing (unfreezes ~every 5seconds and after second freezes again), map objects and vehicles gets to player screen (I mean every object and vehicle moves to my screen so I can see whole map's objects) and after some work with it, I can make it stable again and here's what's in console:

[00:10:16] WARNING: stage\server.lua:631: Bad 'vehicle' pointer @ 'warpPedIntoVehicle'(2)

[00:10:19] WARNING: stage\server.lua:631: Bad 'vehicle' pointer @ 'warpPedIntoVehicle'(2)

[00:10:23] WARNING: stage\server.lua:631: Bad 'vehicle' pointer @ 'warpPedIntoVehicle'(2)

[00:10:23] WARNING: stage\server.lua:631: Bad 'vehicle' pointer @ 'warpPedIntoVehicle'(2)

I use latest MTA, latest Stage (1.4.0), latest resources.. What is wrong then?

EDIT: I made a video:

maybe you didn't spawned cars with map editor?

you have to spawn cars with map editor.

Link to post

maybe you didn't spawned cars with map editor?

you have to spawn cars with map editor.

I've already fixed this.. I'm not sure what the problem was.. All vehicles was placed in map editor, but it didn't worked.. Now I created a completely new map and everything worked fine.. I have no idea what was wrong with it.. :\

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...