Jump to content

[Centos 5.4] libpcre.so.3 error


Nich

Recommended Posts

Hi,

I have a problem with running a MTA SA server on my VPS(Linux Centos 5.4), when i try to run it, i get:

./mta-server: error while loading shared libraries: libpcre.so.3: cannot open shared object file: No such file or directory

I've tried reinstalling and upgrading pcre and pcre-devel, but nothing. Can anyone help me please?

Thanks

Link to post

Hi,

I have a problem with running a MTA SA server on my VPS(Linux Centos 5.4), when i try to run it, i get:

./mta-server: error while loading shared libraries: libpcre.so.3: cannot open shared object file: No such file or directory

I've tried reinstalling and upgrading pcre and pcre-devel, but nothing. Can anyone help me please?

Thanks

Link to post
Hi,

I have a problem with running a MTA SA server on my VPS(Linux Centos 5.4), when i try to run it, i get:

./mta-server: error while loading shared libraries: libpcre.so.3: cannot open shared object file: No such file or directory

I've tried reinstalling and upgrading pcre and pcre-devel, but nothing. Can anyone help me please?

Thanks

Did you tried to install: libpcre3 ?

Link to post
Hi,

I have a problem with running a MTA SA server on my VPS(Linux Centos 5.4), when i try to run it, i get:

./mta-server: error while loading shared libraries: libpcre.so.3: cannot open shared object file: No such file or directory

I've tried reinstalling and upgrading pcre and pcre-devel, but nothing. Can anyone help me please?

Thanks

Did you tried to install: libpcre3 ?

Link to post
  • 1 month later...

How exactly did your host fix the problem asI am having the exact same problem.

I can't seem to find libpcre3 for cent os 5.4 or any centos for that matter.

I've checked up on yum and i have pcre and pcre-devel install version 6.6 i belive.

Link to post
  • 2 weeks later...

if you have yum installer, just install/update pcre and pcre-devel

yum install pcre
yum install pcre-devel

than open /usr/lib directory and find there "libpcre.so.3". If it founded you are done.

If no such file ("libpcre.so.3") there, just find any file (not link) which name starts from "libpcre.so" (for example - libpcre.so.0.0.1, libpcre.so). Make a symbolic links to it for /lib and /usr/lib :

ln -s /usr/lib/libpcre.so.0.0.1 /usr/lib/libpcre.so.3
ln -s /usr/lib/libpcre.so.0.0.1 /lib/libpcre.so.3

if no "libpcre.so.X.X.X" files in /usr/lib you can find it in /lib. After this make some think like this

ln -s /lib/libpcre.so.0.0.1 /usr/lib/libpcre.so.3
ln -s /lib/libpcre.so.0.0.1 /lib/libpcre.so.3

and you are done. If some problems still here, you can make same actions for file start with "libpcreposix.so".

Link to post
  • 2 weeks later...
if you have yum installer, just install/update pcre and pcre-devel

yum install pcre
yum install pcre-devel

than open /usr/lib directory and find there "libpcre.so.3". If it founded you are done.

If no such file ("libpcre.so.3") there, just find any file (not link) which name starts from "libpcre.so" (for example - libpcre.so.0.0.1, libpcre.so). Make a symbolic links to it for /lib and /usr/lib :

ln -s /usr/lib/libpcre.so.0.0.1 /usr/lib/libpcre.so.3
ln -s /usr/lib/libpcre.so.0.0.1 /lib/libpcre.so.3

if no "libpcre.so.X.X.X" files in /usr/lib you can find it in /lib. After this make some think like this

ln -s /lib/libpcre.so.0.0.1 /usr/lib/libpcre.so.3
ln -s /lib/libpcre.so.0.0.1 /lib/libpcre.so.3

and you are done. If some problems still here, you can make same actions for file start with "libpcreposix.so".

tried that.. still not working :/

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...