Sign in to follow this  
=UnitX=

How i make my server "Public"

Recommended Posts

Hello

how i can make my server public server ..

every1 can join it ..

i am .. [Feelling So Bored] .. with local servers .. :\

i have a server and i open ports to it .. }

and i wanna make my server "internet"

public ..

:]

Share this post


Link to post

Go to your server folder, find /mods/deathmatch/mtaserver.conf. make sure <ase>1</ase> is infact set to ''1''. Let the server be on for at least 24 hours, Master server is incredibly slow at picking up new servers.

The most usual problems are with your port forwarding though, all ports need to be permanently open. (by default the ''ase'' setting is already 1.. so unlikely it's that)

Type ''openports'' into server window and hit enter, to see if your ports are properly forwarded. It must output all 3 ports are ''open''. If it's not, make sure that if you have any forwarding done, it points to the right PC (local IP or MAC address in router). If not, go to windows network icon, rightclick to ''open network center'' or just go to network center elsewhere, click the active connection, then ''details'', find your DHCP or ''standard gateway'' address in there, take that IP and go there with your browser like it were a website, login (leave credentials empty or with ''admin'' as pass and username or just user) then you will be in router's configuration.. find ''Port forwarding'' and enter the server ports, like 22003 UDP and 22005 TCP for http/download of client resources - these are the ports of your server, as defined in mtaserver.conf - and also 22126 UDP (in the case your main server port is at default, 22003, if you changed it, it's newport + 123, so if you changed it to 22010 it will be 22133 UDP.

Now you entered all those ports to forward (open up), you will need to add a device to use the forwarding on, which is your local IP address, it usually looks like 192.168.2.x, add it to link the forwarding tables. Better is MAC address though, to tell the router it has to forward these ports for your PC you host MTA server on. If you use local IP over MAC address, make sure to set your local IP to static (in windows network setting customize ipv4 and more, copy all of it from existing config in ''details'' you opened earlier for DHCP address) or set it to static in the router, in DHCP settings make it always assign that local IP (192.168.x.x) to your server PC's MAC. If you just link the forwarding table to your PC once but not make sure to set it static, your MTA server can suddenly not work anymore when it assigns a new local IP to your PC.

If the generic explanation on how to forward ports or login details for router's configuration page doesn't work, read the model number off your router/modem and google for it's official manual and instructions to forward ports.

Share this post


Link to post
Go to your server folder, find /mods/deathmatch/mtaserver.conf. Change to 1. Let the server be on for at least 1-2 hours, Game-monitor is incredibly slow at picking up new servers.

i change it before allready ..

and no changes

<!-- This parameter can be used to make the server report to ASE master servers, allowing it to be visible in the ingame server browser. An additional UDP port needs to be available for this to work (value from <serverport> + 123 , so on a default <serverport> value 22003 the right port will be 22126 ). Available values: 0 - disabled , 1 - enabled. Optional parameter, defaults to 0. -->
<ase>1</ase>

Share this post


Link to post

So let your server stay on for a few hours like I told you.

Share this post


Link to post
So let your server stay on for a few hours like I told you.

i wait + 12 hours .

and the MTA Server.exe is opened ..

and i check game-monitor if they put my server ..

but i dont found anything about it :(

Share this post


Link to post
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.