50p

Unofficial MTA Script Editor 0.3 (4851) RELEASED!

Recommended Posts

I have XP and the editor doesn't save any file. Also many other features doesn't work (all of them have to with files).

In my other Vista PC it didn't work even with Admin rights, even if I moved the editor to the desktop and the virtual folder was empty!

Share this post


Link to post
Vista users must run this application with admin privileges otherwise the files are saved in different directory. Maybe 7 works the same. Try to run it with admin rights. Also, when the files is saved you will see confirmation message in status bar saying "File 'filename.lua' saved...".

I always run as admin and it's not in the Program Files folder so it wouldn't save in a different directory. I figured out the problem though, it only let's me save scripts in the main directory of the gamemode ("...\MTA San Andreas\server\mods\deathmatch\resources\mygamemode\"). I was working on client-side scripts that were placed in a sub-directory called "client" as the wiki suggested. When opening a file from that sub-directory (or any other directory) it doesn't save it. And it also doesn't show up in the resource browser. It seems the scripts have to be in the same directory as the map file or it just ignores them.

Share this post


Link to post

Say, I don't mean to be an ass, but the editor suddenly stopped saving or checking for edits on the script. This is painful since this is the only working editor with real-time checking with the mta syntax format. I have tried to remove the read-only settings but it still fails. What's the problem? Thanks.

Share this post


Link to post

How come it used to save files and now it stopped? Your "Script Editor.exe" hasn't changed, has it? If it hasn't, then why should it stop saving or detect changes in file? I have no idea why it doesn't work for you. Maybe give some details on what did you do before it stopped working, what is your OS (SP2, SP3)?

Also, are you talking about "New" files not being saved or already opened file from a resource? If it's a "New" file then was it added to your resource (in Resource explorer)?

I just need more details.

Share this post


Link to post

OS: Windows XP, SP2.

Creating a new file seems to work, and it's displayed in the resource browser perfectly. However, saving (nor does the Save As dialogue show up) doesn't work, and it doesn't prompt you to save before exit.

Share this post


Link to post

Hm...are u calling the Save Dialog correctly ?

cause yeah im using Vista too. and it dont Execute() nothing

Could u re-upload the Source Files ?

Share this post


Link to post

Possible solution: While MTA:SE was on a seperate partition (Y:\) from Windows, it didn't seem to work. After moving it to my desktop folder, it works.

Share this post


Link to post

Doesn't seem to save files on Windows 7. Nothing happens when i click Save or Save As, short-keys wont work neither.

Share this post


Link to post

Unfortunately, I don't have Windows 7 nor Vista (have never ever used any of them) so I can't test it and find out what is wrong but the only reason I see why it's not saving is the lack of admin rights (that's how other users found out).

Share this post


Link to post

50p I will help you a bit. I have windows 7! There are some stuff that aint working.

The mta functions are not highlighted ( i don't know if it is on windows xp)

Autocompletion works now, but in side of the function i don't get help with the arguments.

Save-as menu option doesn't work!

I can't rename a file. And i hate the untitled files (it makes a mass of the resource.)

Most of the settings are not saving proberbly.

What i miss is, is to choice a font-family and font-size.

I hope this is helping you. If you need someone to test, just drop a pm right in my inbox. And i'll be happy to help you out!

Greetings,

Alexander

edit

Don't botter about the security popups. They are not needed in the downloads folder, and also not on my D drive.

Share this post


Link to post
50p I will help you a bit. I have windows 7! There are some stuff that aint working.

The mta functions are not highlighted ( i don't know if it is on windows xp)

Autocompletion works now, but in side of the function i don't get help with the arguments.

Save-as menu option doesn't work!

I can't rename a file. And i hate the untitled files (it makes a mass of the resource.)

Most of the settings are not saving proberbly.

What i miss is, is to choice a font-family and font-size.

I hope this is helping you. If you need someone to test, just drop a pm right in my inbox. And i'll be happy to help you out!

Greetings,

Alexander

edit

Don't botter about the security popups. They are not needed in the downloads folder, and also not on my D drive.

1. MTA functions highlighting isn't yet supported, only Lua functions.

2. If you mean the side of the window functions list, yes, it's not fully working as I want it to work.

3. Yes, it doesn't work (not implemented)

4. In 0.2.8 you can rename files. If you're using 0.2.8, what do you mean rename files? In the Resource Explorer itself or on HDD?

5. Yes, they are not being saved due to lack of time on my hands.

6. All the file related issues will be fixed as the last ones because I have to fix the syntax library we're using since the author of it has been inactive for ages... Fixing libraries that aren't written by you is pain in the ass since you have to find the code that is bugged which you don't know where it is located.

Also, what security popups do you mean? What is not needed in your downloads folder?

Share this post


Link to post

Well I don't think it is the admins rights. UAC is turned off, and I'm the root Administrator of the machine. The app is running with full rights to read/write.

Share this post


Link to post
...

1. MTA functions highlighting isn't yet supported, only Lua functions.

2. If you mean the side of the window functions list, yes, it's not fully working as I want it to work.

3. Yes, it doesn't work (not implemented)

4. In 0.2.8 you can rename files. If you're using 0.2.8, what do you mean rename files? In the Resource Explorer itself or on HDD?

5. Yes, they are not being saved due to lack of time on my hands.

6. All the file related issues will be fixed as the last ones because I have to fix the syntax library we're using since the author of it has been inactive for ages... Fixing libraries that aren't written by you is pain in the ass since you have to find the code that is bugged which you don't know where it is located.

Also, what security popups do you mean? What is not needed in your downloads folder?

4. I'm using 0.2.8 and i can't rename the files, and i can't change the filenames anyway (in the script editor).

6. Uhm, i know that the puzzle syntax library is inactive, na they quit with working on it. There is somebody who took it over: http://code.google.com/p/alsing/

What i mean by security popups,i mean the UAC thing in windows vista and 7. The downloads folder (standard in windows vista and 7) there is where the program is located, has just read and write access without administrator rights. And my order hard disk has also read and write access with no administrator rights. And my uac is turned on. But don't mind it.

And i'm running windows 7 ultimate.

Alexander.

Share this post


Link to post

I got an suggestion.. If you havent already planned this... Avalible to edit .db files, pehraps a wizard would be kewl.

Share this post


Link to post
I got an suggestion.. If you havent already planned this... Avalible to edit .db files, pehraps a wizard would be kewl.

It's been planned for a long time now but due to lack of time even some basic features are missing or bugged.

Share this post


Link to post
download sqlbudy for that. Google for it!

I use SQLite manager for that stuff. But i think people would like it to have a built in SQL manager in the script editor. I also cant wait for the FTP connection to be finished.

Share this post


Link to post

A useful tool would be an inbuilt CEGUI interface so that we can design GUI out of game.

Share this post


Link to post
A useful tool would be an inbuilt CEGUI interface so that we can design GUI out of game.

I've started making one long time ago but couldn't figure out why it stops rendering after loading cgui.dll up... There is no MTA Developer that knows why at least that's what they said when I asked them on IRC.

If there is anyone that wants to help me, feel free to do so with my source code (it's C++):

http://scripteditor.beta.mtasa.com/file ... or_src.zip

I'm including here binaries if you can't compile it yourself:

http://scripteditor.beta.mtasa.com/file ... Editor.zip

As I said, I started making it pretty long time ago when MTA went open source, so the "CGUI..." classes and cgui.dll are old but that doesn't mean it's the cause of stopping DirectX from rendering since it worked with MTA.

There are following features:

- change resolution of rendering window (from 640x480 to 1680x1050)

- loads cgui.dll from "File" menu

- context menu (right-click menu) on "black screen" which is meant to let user create GUI elements quickly (it's useless since cgui.dll doesn't initialize at all)

I'll say it again, MTA Developers weren't able or willing to help me and I got pissed off after a few weeks of trying to fix it.

Share this post


Link to post

Editor is perfect. I've just missed one simple thingy, when one word is highlighted, other same words should be highlighted as well, to see wheres it's used in all script, pretty useful to me. Best regards.

Share this post


Link to post

I've been trying to reproduce what causes the glitch inability-to-save glitch.

So far; I've noticed:

  • Saving does not work if the file isn't part of a resource. Nor does it show in the SW info bar.
  • It occured after trying to change my profile settings.
  • A reinstall does not fix it. Nor could I find anything in Applications Data. Registry perhaps (though I searched for MTASE in regedit and got nothing)?
  • If saving doesn't work; neither does right-clicking or IntelliSense.

Share this post


Link to post

A suggestion/feature request: allow opening other file formats (defaultly interpreting it as Lua).

Share this post


Link to post
I've been trying to reproduce what causes the glitch inability-to-save glitch.

So far; I've noticed:

  • Saving does not work if the file isn't part of a resource. Nor does it show in the SW info bar.
  • It occured after trying to change my profile settings.
  • A reinstall does not fix it. Nor could I find anything in Applications Data. Registry perhaps (though I searched for MTASE in regedit and got nothing)?
  • If saving doesn't work; neither does right-clicking or IntelliSense.

- Oh, I know it doesn't save files that weren't added to any resource that's because of the way I open files.

- What did you mean by "after trying to change my profile settings"? Your PC profile? And what settings?

- MTASE is not stored in registry yet.

A suggestion/feature request: allow opening other file formats (defaultly interpreting it as Lua).

MTASE supports XML files as well. That was mainly to let users change their map files manually.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.