Sign in to follow this  
Donny7878

Bug with 'attachElements'

Recommended Posts

Nightly build server side code, a command spawns these.

  
--command 
    local tanker = createVehicle ( 514, ........ 
    local plane = createVehicle ( 511, ........ 
    attachElements ( plane, tanker, ........ 
  

The attach offsets for the plane on the tanker are:

  
0, -4, 3, ........ --this is the x, y, z, the rotations are 0 
  

So the plane is attached ontop of the tanker a little behind the driver doors, all this is good and works great but my problem is that if I say drive off Chilliad or any steep slope then the plane will detach itself and later respawn itself ontop of the tanker again.

What I require is a fix for this where the plane and tanker will stay attached at all times if that's possible please and if not then oh well (sh!t happens) but where should I report this and could it possibly be fixed in a later version do you think ?

Thanks.

Share this post


Link to post

Issue #3962: Vehicle attachment bug.

It's pretty much known since r182, maybe even before that. But I guess this is pretty difficult to fix. I guess there isn't any scriptable way around it.

Share this post


Link to post

Cheers for the reply and the link, I'm glad it's been noted and hopefully a fix for this will be included in a later version. If I myself come up with a fix for it then I shall post but until then I'll keep away from hills hehe.

Share this post


Link to post
It must me able the fix it, by this script, it doesn't happen. Look at the video. :?

http://forum.multitheftauto.com/viewtop ... se#p276951

Look for key differences between the thing in the first post, and the bomb dropping. When thinking carefully, you should notice the bomb is an object. Object attached to a vehicle, to be exact. While here the plane AND the tanker are both vehicles.

It seems like that vehicles being attached to eachother is the bug. Not objects, players, markers... Whatever. (would be cool with markers, you could make a ringthrowing gamemode :D)

Share this post


Link to post
It must me able the fix it, by this script, it doesn't happen. Look at the video. :?

http://forum.multitheftauto.com/viewtop ... se#p276951

Look for key differences between the thing in the first post, and the bomb dropping. When thinking carefully, you should notice the bomb is an object. Object attached to a vehicle, to be exact. While here the plane AND the tanker are both vehicles.

It seems like that vehicles being attached to eachother is the bug. Not objects, players, markers... Whatever. (would be cool with markers, you could make a ringthrowing gamemode :D)

I don't really understand you. By this script is it like this: The RC tanker attached to the rustler, and the object (the bomb skin) is attached to the RC tanker, so that the object have dynamic features. I mean that because by that script the bomb/RC tanker don't falling of. And by the script of the topic starter he falling.

Share this post


Link to post

try using setVehicleFrozen to the vehicle thats being attached to the other one right before atttaching, see if that helps.

EDIT: okay, thats no good either. after testing, glue on vehicles, the server seems to have trouble determining where it is once what your glued to moves.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.