Sign in to follow this  
ijsf

MTA:VC PROBLEM FIX

Recommended Posts

Notes - Rules

Ok thanks to Juggernaut i'm setting up this first MTA:VC Problem fix.

- Trainers conflict with MTA and probably mess up the whole game. We will try to disable these in further releases, please do not use them in combination with MTA:VC

- Please see this topic before you're posting any problems with MTA:VC yourself!

- Only post replies when you know how to solve problems you've experienced.

(P* stands for Problem, A* stands for Answer)

Problem Fixes

P1: When i'm in a game, i can see the people but people can't see me!

A1: Put MTA:VC on Windows 2000 compatibility mode and GTA: Vice City on Windows XP mode.

P2: My game is crashing/giving unhandled exceptions

A2: This happends sometimes.. if you're having a crash, you only have to restart Vice City and to start a new game, and you're back in. No need to restart MTA or your computer. If you're experiencing several crashes after each other, probably someone is messing up the game by using trainers or such. Enter another server and see if it's working now.

Change your VC to english.

If you still got problems, check your version settings in the MTA Client, if you've mods installed or using another program that modifies GTA in any way. It none of these work, which is very rare, try to reinstall Vice City and MTA and test it again.

More problems will be posted

Share this post


Link to post

P3: I keep shooting this guy but he never dies! I see blood all over but he still moving!

A3: A good reason why this happends is because the player you're shooting at is either in the Vice City menu, so not syncing its data or alt+tabbed to Windows. Another reason is that you're playing with either a server that has not enough bandwidth to handle the amount of players connected (which requires alot of bandwitdth) or your connection can't handle the amount of data that must be uploaded (2 kb/s) or downloaded (+- 10kb/s with 15 players).

P4: Also if you see the guy's guns lying around all of a sudden, but he's standing up, he is really dead and the camera is fading on his screen, but for some reason on other people's screen it doesn't show him lying on the ground.

A4: The dead animation isn't synced very well. If the weapons are lying around him he's dead.

Edit bij IJsVogel: sorry Jack, your newspost isn't right.. i'll fix it

Share this post


Link to post

first great job guys this is really stable,but like many said already we just need a goal now :) and running animation and stuff :)

ok one bug with the win server when u use the config file editor it just dont modifie the mateserver.conf dont why the only way to get ur parameter on is to edit the file with notepad

One last feature I would really like to see is the name of the player above the arrow.

Share this post


Link to post

the player name above the arrow is expected for next release, but please keep posting problems/fixes only, in the way Jack and me did... next problem will be P5

Share this post


Link to post

P5: (When hosting using a connection with a firewall) The server starts and players can connect (So long as they are TOLD the IP), when a port is specified for the server. However, ASE server posting doesn't work... (ie. Your server doesn't appear in the server listings after refreshing ASE.)

A5: (I don't actually know which... Cuz i'd like to solve this one too! But there MUST be a port which the server uses to connect with ASE, and this can then just be forwarded to the appropriate machine.. Any idea's which port anyone?)

P.S. I tried to make as much sense as possible... But see it's your fault I don't make sense.. Because it's 2:43am and the reason WHY im up this late is because i've been playing UR GOD DAMN MOD!!! (P6??)

Share this post


Link to post

the ASE port runs on whatever port your game runs on + 123

so by default a 2003 game port would be 2126 for ASE

Share this post


Link to post

P1: When i'm in a game, i can see the people but people can't see me!

A1: Put MTA:VC on Windows 2000 compatibility mode and GTA: Vice City on Windows XP mode.

So, does it mean, that this mta patch wouldn't work on win98. or should I install some upgrades?for example update to 1.1 :?:

Share this post


Link to post
Guest

Problem:-

a) I install the VC multiplayer to our LAN parties. Our PC are using Win98. (We did not upgrade to WinXP because the mouse problem for CS). PC will perform illegal operation if join to the server for a while.

b) I can't see other players after join to the server. I can see the server said we all joined and connected. We are at the same spawn point. But we are in different time (i am in daytime or my friend is in nighttime...) any ideas?

thanks]

Share this post


Link to post
Guest

I have the time-out problem.

According to the read me it's because the routing i bad.

But I'm using all seeying eye to find servers and I tried serveral servers (10+) with ping less than 100 ms.

I even trace routed the ips to check for bad routing but it all seemed fine to me (5-9 hops).

I'm using a dutch ISP (@HOME) and I connected to dutch servers.

One thing:

I'm using a router to share my internet connection but i forwarded port 2003. To check if that worked someone else tried to connect to me. He was able to but he timed out after 5 seconds too.

You would probably say it's just my ISP acting weird, but I played counter-strike a few minutes ago and the ping was normal (around 30 ms).

MrBump said on IRC I had to check the forum for the answer but I worked myself through all threads and couldn't find any sollution.

Share this post


Link to post
Problem:-

a) I install the VC multiplayer to our LAN parties. Our PC are using Win98. (We did not upgrade to WinXP because the mouse problem for CS). PC will perform illegal operation if join to the server for a while.

b) I can't see other players after join to the server. I can see the server said we all joined and connected. We are at the same spawn point. But we are in different time (i am in daytime or my friend is in nighttime...) any ideas?

thanks]

I had the same problems, but they've dissapeared after installation of WinXp. There are no problems there. Today there were three of us in the game. But after an hout it becomes to boring.

to Creators

Will you make better patch with people and cars on the streets?

Share this post


Link to post
Guest

My problem:

I have winpx pro.(without sp1). I set the game and the client to win98/me compatibility mode (when i set xp/2k/nt mode the client exit without any error msg). So its running, i see other players moving, shoting... but other players can't see me! First i think, my isdn a little slow (yes its slow:P), but my friend tryed it an adsl connenct, and she have a same problem as me.

Thanks, and sorry for my bad english

Share this post


Link to post
My problem:

I have winpx pro.(without sp1). I set the game and the client to win98/me compatibility mode (when i set xp/2k/nt mode the client exit without any error msg). So its running, i see other players moving, shoting... but other players can't see me! First i think, my isdn a little slow (yes its slow:P), but my friend tryed it an adsl connenct, and she have a same problem as me.

Thanks, and sorry for my bad english

set it to win 2000 mode then it should work

Share this post


Link to post

P5?/6?: OK, get this... When hosting my own server, and my friends connect... they can see each other and shoot each other, etc.. When I join; I can see them but they can't see me! However, when using my screen as a guide they can SHOOT me AND injure me.. (All three players concerned have brand new installs of GTA:VC)

This sound's like a connection send/recieve error... However, its very wierd as it is still SORT of working..

*MODS DELETE THIS IF YOU FEEL IT IS INNAPROPRIATE* ->

Also I hate to bring this up.. but I like most peopl can't STAND having to mess around with CD's... Including game CD's so I patch Vice City normally to avoid having to bother.. However, with most of the patches MTA stops working and "Unhandled Excep..etc". The no-cd patches are completely legal and so I was wondering if you knew of any which worked with MTA?

<- *MODS DELETE THIS IF YOU FEEL IT IS INNAPROPRIATE*

Thanks,

Share this post


Link to post
Guest

Yes, its worked one time..

Next time i started the client, but 5-10 sec later the client window closed.

I try restart my computer, and run again the client, but no effect..

Sometimes i start the client, she give me some message from the chat box, like this: http://nihil.counter-strike.hu/~addam/bla.jpg

i dont know this god or not :)

thanks again

Share this post


Link to post
Guest

I am using win 98 se and cannot see anyone in the game. Is there a fix for this? I dont own nor do i want to buy xp just to get this to work.

No fix, mtavc0.1 isnt windows 98x compatible im afraid- MrBump

Share this post


Link to post

*MODS DELETE THIS IF YOU FEEL IT IS INNAPROPRIATE* ->

Also I hate to bring this up.. but I like most peopl can't STAND having to mess around with CD's... Including game CD's so I patch Vice City normally to avoid having to bother.. However, with most of the patches MTA stops working and "Unhandled Excep..etc". The no-cd patches are completely legal and so I was wondering if you knew of any which worked with MTA?

The NO-CD cracks modify the .exe... this could really mess with MTA. Chances are that there aren't any no-cd cracks that'll work with MTA :(

Edited by Guest

Share this post


Link to post
Guest

I connect to the server and i start my VC game. I can play about 3 minutes and then server disconnects. i tried several times but the same problem can any one help me??? Please!!!

Sorry For The Bad English.

Share this post


Link to post

i dunno if this will be frowned upon, but for gta3 i used nero + that image drive program which is so handy that comes with it (although i've noticed it only seems to appear on some nero cd's?)

i made an image of the play cd and used it for gta3, makes it smoother running to, at least i got the feeling it was, instead of patching the exe you just have a virtual cd drive, theres tons of programs out there, most motherboards seem to come with a virtual drive program too, (sorry if this upsets anyone, but i don't belive this to be wrong, i have most of my games on an image, but thats mainly due to my incredibly dodgy can't be bothered to replace cd drive)

Share this post


Link to post

IJsvogel can you explain me how exactly i change settings to Windows 2000 Proffesional?

Maybe you can send me a mail to aeon_nosgoth@hotmail.com

(then u can speak dutch easier for me 8) )

I really wanna play, cause when people can't see u it's a pain in the ass...

Thanks man

Share this post


Link to post

sometimes the arrows over players dont shows up but everything else works fine for me (pweh :P )

a small bug, but this is a bug topic isnt it :)

Share this post


Link to post
1. Car Jackings, no matter where the hell you are

( Ive gotten jacked from a helicopter like 7 times when I was miles above any building or person)

2. Ghost Town

Without any Pedestrians or Police The game just doesnt feel right.

3. The Walking / Running Issues

For some reason everyone besides you slides around instead of walking

Also, whenever someone is on the ground after a blast from a shotgun, they they slide on the ground, making it extremely hard to shoot them

4. That Damn Unhandled Exception Crash

5. You need new game modes such as Gang Wars or something

.

Rage its a beta :wink:

I found some bugs:

1:I was shooting at a guy, after a while his equipment fell down so I thought he was dead but he killed me :)

2:sometimes the game freezes and it never happened on VC sp (not the unhandled exception error)

Share this post


Link to post

Can you not play with more than 1 person connected behind a NAT? I have a netgear "router" and when I try to connect my 2nd PC, it says another player is already connected from this IP :( Help!!!

Share this post


Link to post

Snow, that would be a negative.

Currently the Server defines identifies who you are by the IP that you are communicating with, therefore limiting the amount of players on a single server from a single ip value to 1.

Share this post


Link to post
hi guys,listen ive got a problem

i installed the MTA + the newer version of GTA :vc

every thing works just fine,its stuck a little bit but its ok.

the main problem is that im connected to a server (ive tried like 4 or 5 different servers and in different countrys) i play for 20secs ,less or more,and then its says

that ive been dissconnected form the server

anther thing is that i cant say nothing,but its ok...

hope ull fix it for the next time

BTW im using 98se and Burned GTA vc discs (iso).

DOES NOT WORK on 98!!! Everyone using 98 has these problems including me!!! I upgraded to XP and it works perfect now!

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.