Sign in to follow this  
rockstarrem

Error #9 (followed all instructions in the wiki) Please Help

Recommended Posts

Hey guys, I'm getting an error 9 when connecting to my server after configuring the optional HTTP hosting option. I believe I did everything correctly, here is the config:

<!-- This parameter specifies whether the builtin http server is going to be used. Values: 0 - disabled , 1 - enabled ; default value: 1. Optional parameter. --> 
    <httpserver>0</httpserver> 
     
    <!-- This parameter specifies the TCP port on which the server will be accepting incoming http connections. It can be set to the same value as <serverport>. It's a required parameter if <httpserver> is set to 1. --> 
    <httpport>3021</httpport> 
     
    <!-- This parameter specifies whether connecting players will be able to download needed resources for them from an external site rather than from the server. 0 - disabled , 1 - enabled; default value: 0. --> 
    <httpdownload>1</httpdownload> 
     
    <!-- If set, this parameter specifies the external URL from which clients will be able to download needed resources ingame. Required parameter if <httpdownload> is set to 1. --> 
    <httpdownloadurl>http://tgtap.rockstarrem.com/mta/server1/resources</httpdownloadurl> 

Here's the strange part, it downloads the files but they are all empty. Like, there will be all the lua files but they're all empty. I don't get it. Here's the URL of all the resources, they're all default: http://tgtap.rockstarrem.com/mta/server1/resources

I believe I did everything correctly, could someone help me please?

Share this post


Link to post

It's definitely not that, it has to do with the admin resource, me and Talidan are trying to debug it now. If I take out the admin resource from the startup everything downloads fine.

Share this post


Link to post

i had Error #9 when i had a outside link to http with resources.... it was due to server was using some newer resources that the http site didn't have... so it may be confirmed as a bug but rockstarrem may not have uplaoded all resources... or may updated his server's resources after uploading them.... so server wont be able to give out resources which gives the Error #9

Share this post


Link to post
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.