Sign in to follow this  
waydee

Wont load beyond splash screen, bit more info

Recommended Posts

Hi guys, been trying to get MTA:SA:DM to work and not having much luck.

Have installed latest version of SA:DM last night, have a V1.00 version of gta_sa.exe and I'm running Vista ultimate SP1.

When loading Multi Theft Auto.exe I get the "stop playing with yourself splash screen" which disappears and then nothing. Checked task manager and no gta_sa.exe process is running.

I have tried adding Multi Theft Auto.exe to Data Execution Prevention exemption list, running as administrator, running in compatibility mode (XP SP2, 95/98, NT4), modifying permissions to allow full access of files contained within "C:\Program Files\MTA San Andreas" and "C:\Program Files\Rockstar Games\GTA San Andreas\MTA" but to no avail.

Found the core.log file in "C:\Program Files\Rockstar Games\GTA San Andreas\MTA" while looking for a clue to the problem, seems the error is with multiplayer_sa.dll as the log shows:

** -- Unhandled exception -- **

Time = Wed Aug 06 02:00:32 2008

Module = C:\PROGRA~1\ROCKST~1\GTASAN~1\mta\MULTIP~1.DLL

Code = 0xC0000005

Offset = 0x02EA373A

EAX=00000000 EBX=00000006 ECX=00000001 EDX=00000006 ESI=0012F7DC

EDI=00000000 EBP=00000000 ESP=0012F7CC EIP=02EA373A FLG=00010203

CS=001B DS=0023 SS=0023 ES=0023 FS=003B GS=0000

** -- End of unhandled exception -- **

Unfortunately I can't really make much sense of that but was perhaps hoping if a dev sees this maybe it'll make some sense. I'm guessing this is a Vista specific problem but as far as I know I've gone to every length to get it working, normally a combination of what I've tried will get incompatible software working but it seems not in this case.

Any information much appreciated, sorry if you're all tired of these threads.

Thanks.

Share this post


Link to post

did you have a quick look over the wiki? there might be something there you might be able to try.

Nothing happens after the 'Stop playing with yourself' splash screen

If you use nVidia GeForce, try turning off nView Desktop Manager before starting MTA.

Also try deleting GTA San Andreas settings file ("gta_sa.set") in "Documents\GTA San Andreas User Files" folder

Crash after MTA splash screen

MTA crashes after the 'Stop playing with yourself' logo. Both single player and the MTA: Race ran fine before.

Try downloading the latest DirectX Runtime files from Microsoft. Also check in Task Manager, if gta_sa.exe process isn't already running.

If you run at any substandard resolutions (e.g. 960x720), try to change your resolution to a commonly supported one (e.g. 640×480, 800×600, 1024×768, 1152×864, 1280×1024) by launching Grand Theft Auto: San Andreas in normal mode, setting the new resolution and exiting.

Crash on launch

I've successfully upgraded from MTA Race to MTASA DM on Vista, but it seems to crash on launch.

Go to your Program Files\MTA San Andreas\mods\race directory, and rename client.dll to something else.

http://development.mtasa.com/index.php? ... sues_-_FAQ

Share this post


Link to post

Yeah I've tried those, using DirectX 10 never had Race installed so I've no client.dll to delete, not got an nvidia card so no nview installed, use 800x600 res in game, deleted the settings file.

Share this post


Link to post

This is not supposed to happen. You should verify that you have a GTA San Andreas executable that is version 1.0 (European or United States only) and not anything else, since is the most likely source of your problem.

Share this post


Link to post
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.