Jump to content

installing under linux "the installer needs admin access"


delfick

Recommended Posts

I had the same error. I updated wine to 0.9.52 and installed mta with no errors. but i can't run it :(

$ wine Multi\ Theft\ Auto.exe  
err:ntdll:RtlpWaitForCriticalSection section 0x7efec964 "loader.c: loader_section" wait timed out in thread 000f, blocked by 000e, retrying (60 sec) 
err:seh:raise_exception Unhandled exception code c0000194 flags 0 addr 0x7ef97bc0 
  

Link to comment

wine-0.9.45

$ wine Multi\ Theft\ Auto.exe  
wine: Unhandled page fault on write access to 0x7ee4b33f at address 0x7ee4b340 (thread 000f), starting debugger... 
Unhandled exception: page fault on write access to 0x7ee4b33f in 32-bit code (0x7ee4b340). 
Register dump: 
 CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b 
 EIP:7ee4b340 ESP:7eda6a1c EBP:7eda6a28 EFLAGS:00010206(   - 00      - RIP1) 
 EAX:7ee4b340 EBX:7efe46d4 ECX:7efec884 EDX:00000000 
 ESI:00240000 EDI:7ee4b340 
Stack dump: 
0x7eda6a1c:  7efc763e 00240000 00240000 7eda6ac8 
0x7eda6a2c:  7efc8299 7ee4b340 00240000 7eda6a78 
0x7eda6a3c:  7efa7171 7efec884 ffffffff 00000000 
0x7eda6a4c:  7eda6a68 7ffdaf98 7ffda000 7eda6a68 
0x7eda6a5c:  7efba4d7 7efe0e3c 001101c0 000074ec 
0x7eda6a6c:  7efe46d4 7eda6ab0 7eda6aa8 7eda6ac8 
Backtrace: 
=>1 0x7ee4b340 in kernel32 (+0xb340) (0x7eda6a28) 
  2 0x7efc8299 in ntdll (+0x48299) (0x7eda6ac8) 
  3 0x7efc8506 in ntdll (+0x48506) (0x7eda73b8) 
  4 0xb7dff1b3 start_thread+0xb3() in libpthread.so.0 (0x7eda74b8) 
  5 0xb7d8803e __clone+0x5e() in libc.so.6 (0x00000000) 
0x7ee4b340: addb        %dl,0xffffffff(%eax) 
Modules: 
Module  Address                 Debug info      Name (15 modules) 
PE        400000- 1577000       Deferred        gta_sa 
ELF     7bf00000-7bf03000       Deferred        <wine-loader> 
ELF     7eda8000-7edb3000       Deferred        libnss_files.so.2 
ELF     7edb3000-7edbd000       Deferred        libnss_nis.so.2 
ELF     7edbd000-7edd4000       Deferred        libnsl.so.1 
ELF     7ee22000-7ef3e000       Export          kernel32<elf> 
  \-PE  7ee40000-7ef3e000       \               kernel32 
ELF     7ef3e000-7ef65000       Deferred        libm.so.6 
ELF     7ef65000-7f000000       Export          ntdll<elf> 
  \-PE  7ef80000-7f000000       \               ntdll 
ELF     b7cb4000-b7cb8000       Deferred        libdl.so.2 
ELF     b7cb8000-b7dfa000       Export          libc.so.6 
ELF     b7dfa000-b7e11000       Export          libpthread.so.0 
ELF     b7e11000-b7e1a000       Deferred        libnss_compat.so.2 
ELF     b7f39000-b7f56000       Deferred        ld-linux.so.2 
Threads: 
process  tid      prio (all id:s are in hex) 
0000000d (D) Z:\mnt\ros\gta_sa\gta_sa.exe 
        0000000f    0 <== 
        0000000e    0 
0000000a  
        0000000c    0 
        0000000b    0 
00000008  
        00000009    0 
bash-3.1$ ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0 
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL default:0 
fixme:system:SystemParametersInfoW Unimplemented action: 8193 (SPI_SETFOREGROUNDLOCKTIMEOUT) 
  

gta doesn't start. but i have process gta_sa.exe

it's interesting. wine-0.9.52 can start gta, but can't start mta. wine -0.9.45 can't start gta, but can start mta...

UPD: i deleted gta user files, and now gta works. But still not work with mta

Link to comment
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...