Ring_of_Fire

How to get MTA:SA Client running on Vista!

Recommended Posts

I made a thread like this before and it got deleted for some reason I don't know (guess someone is jealous???) If there are any problems, criticisms/controversies of my post-writing, please PM my so I can edit out problematic posts. This time I am gonna backup this entire thread in Microsoft Office 2007 as a [.doc] file and/or save it using the "Save" button right next to "Preview/Submit"! :P Hmm... it turns out to be that I tried to force a sticky by putting "[sOLUTION]" before my subject.

Before we begin, the problem with MTA:SA on Vista is because of the "Client.dll" file. There are some DLL script contents inside that doesn't support Vista. Removing it, allows MTA to work. If it is not removed, you will get an "Exception Processing Message" and that "MTA has encountered an unrecoverable error". Also, a crash log will be posted in "C:\Program Files\Rockstar Games\GTA San Andreas\MTA\core.log" Now let's take a look below:

OK, many of you have had problems getting MTA to work on Vista like when installing. For example, you get the message "Application falied to launch because MSVCP71.DLL was not found." The fix is to go to http://www.dll-files.com/dllindex/dll-files.shtml?msvcp71 and copy and paste this in C:\Windows\System32 (of course your graphics driver package or NET Framework/Visual C++ Runtime have these files as well). Note: This solution is NOT posted in the wiki troubleshooting section for MTA:SA - it's only for the "MSVCR71.DLL" file.

So now the "MTA Center Login" works; but what about MTA itself?

Here's a trick to get to the launching screen successfully! :D

To fix this, go to C:\Program Files\MTA San Andreas\mods\race. Delete "Client.dll" file! The contents in this file happens to be not supported for Vista. So...

Step 1

Delete this file!

Step 2

Launch MTA!

Step 3

Servers ready to be executed!

Congratualations, you have managed to get to the server browsing screens. Now what happens if you launch a server, or do a "Quick Connect"?

Edited by Guest

Share this post


Link to post

But, once you launch the server, you will get "Could not load race mod"! :(

It really wants back the "Client.dll" file, but it has some issues with Vista. I started this thread so that people can experiment, contribute, and to see what other clues they can dig up. All that needs to be fixed is the "Could not load race mod" under Vista. It seems that all the MTA Staff has to do is to debug this "Client.dll" file, and send us a patched version for us that works with Vista.

Share this post


Link to post
Oh yeah it says that error...

The map editor works....

LOL, I totally forgot to try the Map Editor, and that actually worked on Vista! See... it's because the Client.dll file for it is not as buggy as the one for the race mod.

Trick: Try to let the Map Editor's CLIENT.DLL file take over the race one. Launch MTA and start a server, it should start - the map editor! But without giving the "Could not load race mod" error message.

I am going to send an e-mail to the MTA Staff that Vista can run MTA:SA if the Client.dll file is debugged. That should help them a little, I hope. :mrgreen:

Share this post


Link to post

The MTA team wont go back to work on race, plus race can be coded in lua to work on dm

Share this post


Link to post
That dont work for me :(

I get insert original disc error

That's a different problem. Is your San Andreas working in single player? If yes, then make sure you are using v1.0 and not v1.01/v2.0

Share this post


Link to post
The MTA team wont go back to work on race, plus race can be coded in lua to work on dm

If so, will MTA:DM run in Vista just fine?

Share this post


Link to post
That dont work for me :(

I get insert original disc error

That's a different problem. Is your San Andreas working in single player? If yes, then make sure you are using v1.0 and not v1.01/v2.0

Works in single player, already patched it to v1.01.....

Share this post


Link to post

cool, you remove the Race mode module and call it the solution (race wont work without it). That's the same as i say that solution is to uninstall your mta :/

Share this post


Link to post

It's a solution to make the MTA San Andreas program itself work, but not the Race mod. You need to also do this to make the MAP MAKER work!

Share this post


Link to post
They have a working RACE, why they don't want to release is beyond me.

Who the hell told you that? In MTA:DM Race is being just a resource, It's not stand alone.

Share this post


Link to post

Let's sum up all the facts we know:

1. RACE doesn't work under Vista because of the anti-cheat functions.

2. It has been prooved that MTA: RACE will work under Vista if anti-cheat functions are disabled.

3. Internal MTA: RACE builds come with anti-cheat disabled by default.

All the above facts are said by developers/QA Team.

Exactly WHAT is the problem to release last internal build of RACE?

Share this post


Link to post

Yes, MTA Team had their builds without anticheat but now MTA Team does not have MTA Race sources anymore to compile it without anticheat.

Share this post


Link to post

You do not know a lot of things.. So just shut up. It has to be newly compiled without it. And MTA/QA Builds have some things that are not for public. As it can not be compiled without the race sources you have to wait for DM. Anything unclear?

Share this post


Link to post

  • Recently Browsing   0 members

    No registered users viewing this page.