Jump to content

ApplyShader Lag


Recommended Posts

Estou tendo um problema com otimização de um script, tenho um script de TXD compartilhada, que muda a txd da viatura para todos por meio de um triggerClientEvent em serverside em todo mundo com o "root" quando o cara digita um comando, porem fiz uns testes e todos os 35 players que estavam online no momento do teste tiveram uma queda de FPS bem grande no momento que a textura foi trocada para todos quando eu dei o comando de trocar na minha viatura, tem algum metodo de otimizar isso ou resolver essa queda de fps? (Utilizo applyShader de uma imagem PNG trocando a imagem da txd original assim alterando ela)

Link to post
2 hours ago, Boechat said:

Não deu nenhum erro no debug?

Nenhum, so trava mesmo

1 hour ago, andr0xy said:

Se a imagem for muito grande, por exemplo 512x512, já começa a travar. Ainda mais se estiver mais de uma sendo carregada.

 

A imagem que estou usando é 1024x1024, so carrego 1 por vez, posso tentar diminuir ela pra ver se diminui o lag, mas fora isso n tem nenhum metodo de otimizar? Eu vejo customs ai de pessoas que tu vai analisar as .png que tem nas pastas que é a unica coisa que nao fica compilada e as imagens sao td 960x960 / 512x512 / 1024x1024 . E o deles os caras vao na loja de roupa compram tudo de uma vez e nao laga nada, fico sem entender oq eles fazem kkkk

Link to post

Eu nunca trabalhei com esses sistemas, então não sei dizer com experiência. Mas provavelmente eles criam as texturas todas de uma só vez, depois bastaria só aplicar e/ou remover.

Ainda assim, acredito que definitivamente NÃO SEJA o caminho mais otimizado, pois consumiria uma quantidade considerável de memória de vídeo.

Link to post
3 minutes ago, andr0xy said:

Eu nunca trabalhei com esses sistemas, então não sei dizer com experiência. Mas provavelmente eles criam as texturas todas de uma só vez, depois bastaria só aplicar e/ou remover.

Ainda assim, acredito que definitivamente NÃO SEJA o caminho mais otimizado, pois consumiria uma quantidade considerável de memória de vídeo.

Como aqui nos foruns brasileiros nao tem mt sobre isso fui procurar em uns gringos e vi um falando sobre isso, ele disse que o dele estava lagando e para resolver era so carregar todas de uma vez, mas nao entendi ao certo oq ele quis dizer com isso, como eu poderia fazer isso? Realmente nao me vem nada a cabeça

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...