Jump to content

[HELP] I can't make a connection with a database


Recommended Posts

Database Problems

 

Hello, I'm a beginner in this type of development, and I never used before any database, but I want to learn how to connect the database and the server, I'm just really struggling with databases, and I didn't found anything helpful for beginners, and I definitely don't know how to make my own script, so I downloaded a database system from MTA Community, and I tried to figure it out by myself, but no matter what I did, I couldn't connect the database and the server together, here is a picture of my problem:

spacer.png

 

The steps I did to make a connection to the database

  1. I tried to do the exact same steps as the Script Author wrote it down in points but I failed in the first step, which is to configure my database configurations in server.lua
  2. I Successfully made a database via xampp, and exported the sql file into the database.
  3. I added the resource to my ACL's  admin group

I did these steps, and the connection was still unsuccessful, what did I do wrong? I really don't understand and I really appreciate any help, or suggestions to where to start to learn about these more, or just how to make a connection between the server and the database, thank y'all in advance!

Link to post

Hello,

The error you get is to inform you that probably the password used to log into "root" user is incorrect.
You should check what the password of the root user is (maybe default?) and if you can't find/remember it you will have to reset it.

 

Edited by SpecT
  • Thanks 1
Link to post
3 hours ago, SpecT said:

Hello,

The error you get is to inform you that probably the password used to log into "root" user is incorrect.
You should check what the password of the root user is (maybe default?) and if you can't find/remember it you will have to reset it.

 

Hi, 

first of all thank you very much for your answer, I didn’t set up any password manually,  if I fill  that “” after the root with “password”, it does the same thing,  maybe this is not the default password,  where can I reset the password? 
I never did before this database connection, and I’m really lost.

thank you in advance. 

Link to post
14 minutes ago, Patrick said:

You can manage users in phpMyAdmin, start MySQL and Apache too in XAMPP, then you can reach it on: http://localhost/phpmyadmin

Select 'User accounts' menu, this is how it looks like by default:

image.png.bd7ce3c02479cdf8c912aa534fc1b2a1.png

O my god, thank y'all very much, I connected with the database successfully, thanks for all the help I got from here.

Link to post
  • Moderators
3 minutes ago, JustPlayer123 said:

O my god, thank y'all very much, I connected with the database successfully, thanks for all the help I got from here.

:toothy8:

  • Thanks 1
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...