Satans-Turd

Disconnected From Server every 5-20 minutes: Please help

Recommended Posts

Hi,

I have version 1.1.1 installed and I am constantly being disconnected from the server I am playing on. Which server is irrelevant, it occurs on every server I connect to. I can sometimes play several races on a server, eventually I get disconnected. I have rarely played for more than 20 minutes without a disconnection.

This is now the ONLY issue I have with MTA-SA.

My network is stable and secure with several machines running Linux and w2k3 server as well as XP pro. I have absolutely no networking issues of any kind with the other machines, nor when I play other online games with the machine I use for MTA-SA.

Can someone please offer some advice? I relly enjoy this game, but the regular disconnectons are driving me crazy.

Regards

S-T

Share this post


Link to post

What is the speed of your internet? Is other people on your network using the internet as you play MTA?

Your internet might not be able to keep up with MTA. Try joining servers with less players and a good ping.

Share this post


Link to post

Hi KillFrenzy, thanks.

I have a 1Mb ADSL broadband connection. I live in UK and connect to servers with a ping of between 30 and 80. I understand the effect that other protocols and other machines simultaneously connecting to the internet or downloading can have whilst I am playing. As an aid to diagnosis I have removed IPSec, my VPN tunnels, software firewalls and shutdown every other machine on my network and tried. Unfortunately the problem persists, with no noticable change. :(

S-T

Share this post


Link to post
Guest
Hi KillFrenzy, thanks.

I have a 1Mb ADSL broadband connection. I live in UK and connect to servers with a ping of between 30 and 80. I understand the effect that other protocols and other machines simultaneously connecting to the internet or downloading can have whilst I am playing. As an aid to diagnosis I have removed IPSec, my VPN tunnels, software firewalls and shutdown every other machine on my network and tried. Unfortunately the problem persists, with no noticable change. :(

S-T

I got a 3Mb connection with the same problem ever since i installed 1.1 plus my gaming pc is the only thing running on my network when im playing and my gaming pc is the only one that has the best connection bc i have deleted a few registries that slow or limit connection speeds

Share this post


Link to post
I am constantly being disconnected from the server I am playing on

Is there a message stating WHY you are disconnected? e.g. timed out or Unexpected Packet data. Is it the same error every time?

Are there any other processes running on the MTA pc that are using high CPU or network utilisation?

Share this post


Link to post

Tell me what kind of error this is, cause it seems that if you play over an amount of time but not immediatly or very short, you get disconnected, but I don't know for what reason.

Share this post


Link to post

Ive noticed that every game i play in and it happens to me aswell that nearly everyone gets timed out at some point during a session. Any heads up on why this is happening and any possible news on if this is being fixed?

Share this post


Link to post

In response to: Chain

The dialogue box states: "Connection with server lost!" the same error every disconnection.

My machine is old now.. single core XP3200+ 9800pro So I do not have any other tasks running when game is playing. I disable AV when playing any game and that is normally all I have running in background anyway. Oh apart from flask mpeg converting a 4Gb video file and lightwave rendering a battle scene from Babylon 5 ;)

In response to: KillFrenzy

Can happen anytime, during first 30 seconds of connecting and spawning, sometimes before I past the first CP. I can play several races before I am disconnected too. Happens on many servers, just loses connection.

I have not had this issue with other online games, no matter how much change my network setup.

S-T

Share this post


Link to post

Does this happen if you connect to a local server as well?

Do you run a firewall?

Share this post


Link to post

"Connection with server lost!" same here, i have noticed that this happens when the server i play in(Betafield.de MTA:SA StuntServer) get full i get disconnected. I was wondering if the problem could be the same as in another application that i know of....... the problem with the other application(i don't want to say the name) is that if the client lags and sends some packets a bit lame, the server disconnects him and the server itself get laggy with every packet late.

I have cable internet but its speed is 20KBs, i didn't have this problem with MTA Race 1.0.

Share this post


Link to post
Does this happen if you connect to a local server as well?

Do you run a firewall?

Not tried a local server.... will give that a go.

I have the usual harware firewall that comes as part of the broadband router. Although I have another firewall that serves other machines, the PC I use for MTA is not routed through it.

I have shutdown everything except my gaming PC and the router in an attempt to sus this out

S-T

Share this post


Link to post

I think this is a coding problem of MTA v1.1 and v1.1.1 where you get disconnected in your own LAN server. The MTA Team might have to fix this problem up. Ever since v1.1 came out, lots of bugs were found that gotta be fixed.

Share this post


Link to post

I set up a MTA server on a win2k3 server on the local LAN and connected. I played several maps before I was kicked "client not responding". This also occurs when the MTA server is run on the same machine as the client, so yes this does happen on local servers.

S-T

Share this post


Link to post
Oh apart from flask mpeg converting a 4Gb video file and lightwave rendering a battle scene from Babylon 5

Lol I know you're kidding - your spec prob couldn't even manage either of those :wink:

I've seen another post in this forum where your same issue is experienced on LAN also. I think erorr404 was suprised but noted it, so I reckon the team are already on the case....

However, I have been able to play for more that 20mins on loads of occasions...

I have rarely played for more than 20 minutes without a disconnection.

Share this post


Link to post
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.