Jump to content

You were kicked by (AC #4 6I9T) Windows 7


yuyu

Recommended Posts

Upon loading into a server, after a short delay, the length of which often varies, I get kicked with the message "Disconnected[CD46] Disconnected: You were kicked by  (AC #4 6I9T)" coming up. This has happened every time since installing the OS.

So far I've tried: 

1. Reinstalling San Andreas/MTA

2. Trying SA version 1.01 as opposed to 1.0

3. Running as admin & compatibility mode

4. Installing antivirus & disabling antivirus

5. Updating Windows 7

6. Rebooting

 

Log: https://pastebin.mtasa.com/591299379

Link to post

Hi,

There is a problem with C:\Windows\system32\DRIVERS\amdxhci.sys on your PC, it's not original and authentic but it has been produced by, or tampered with by, something that is usually used in correlation to malware or hacks. It's most likely a symptom of a virus infection on your PC.

Likewise, if you installed custom or non-official drivers on your PC after re-installing (you apparently downgraded from Win10 to Win7, went with a fresh install), don't use that. Search for official drivers, like those that i will link in the below instructions

Steps:

Note: the video drivers steps are mentioned in 1 breath because they tend to include USB drivers (as part of the chipset drivers).

1) Run full virus and malware scans

2) Download DDU from https://www.wagnardsoft.com/forums/viewtopic.php?f=5&t=3271 and run it, selecting in your case "ATI" 

3) Uninstall "AMD USB3" driver/software, or any USB related stuff on your PC

4) Check if the mentioned file is still there. If it is, delete it, but if you can't delete it, go into your Windows 7's safe mode

5) Install the latest drivers for your card, in your case download them from https://www.nvidia.com/Download/driverResults.aspx/162977/en-us

6) Install the latest drivers for your USB3, which can be found at https://www.win-raid.com/t834f25-USB-Drivers-original-and-modded.html

Then it should be solved

EDIT: Instructions are changed, @yuyu

Edited by Dutchman101
  • Thanks 1
Link to post

Fixed.

Amdxhci.sys was indeed the culprit, and after uninstalling the driver associated with it, and removing the file itself, I stopped getting kicked. The problem was probably that the driver was unsigned and/or tampered with.

Thank you for your help.

Link to post
7 hours ago, yuyu said:

The problem was probably that the driver was unsigned

They used a hacktool to falsify a signing certificate, so that the driver (or what it came with) could easily be tampered with. Which is why i strongly recommend scanning your PC for viruses anyways. Np

Edited by Dutchman101
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...